aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/libxml2/Makefile35
-rw-r--r--textproc/libxml2/files/patch-aa10
-rw-r--r--textproc/libxml2/files/patch-python::Makefile.in33
-rw-r--r--textproc/libxml2/files/patch-python::tests::Makefile.in2
-rw-r--r--textproc/libxml2/pkg-descr2
-rw-r--r--textproc/libxml2/pkg-plist296
6 files changed, 167 insertions, 211 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 007a08ddd589..e0a9d615de1f 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -7,27 +7,30 @@
PORTNAME= libxml2
PORTVERSION= 2.6.11
-CATEGORIES= textproc gnome
+PORTREVISION= 1
+CATEGORIES?= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.6
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Xml parser library for GNOME
+COMMENT= XML parser library for GNOME
USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack gnometarget pkgconfig
+USE_GNOME?= gnomehack gnometarget pkgconfig
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-CONFIGURE_ARGS= --with-iconv=${LOCALBASE} \
+CONFIGURE_ARGS?= --with-iconv=${LOCALBASE} \
--with-html-dir=${PREFIX}/share/doc \
- --with-html-subdir=${PORTNAME}
+ --with-html-subdir=${PORTNAME} \
+ --without-python
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.if !defined(MASTERDIR)
MAN1= xml2-config.1 xmllint.1 xmlcatalog.1
MAN3= libxml.3
@@ -36,15 +39,6 @@ OPTIONS= THREADS "Enable pthread support (MAY BREAK OTHER PORTS!)" off \
MEM_DEBUG "Enable memory debugging (DEVELOPERS ONLY!)" off \
XMLLINT_HIST "Enable history for xmllint" off \
THREAD_ALLOC "Enable per-thread memory (DEVELOPERS ONLY!)" off
-
-.if !defined(WITHOUT_PYTHON)
-USE_PYTHON= yes
-PLIST_SUB+= PYTHON:=""
-CONFIGURE_ARGS+= --with-python=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --without-python
-PLIST_SUB+= PYTHON:="@comment "
-PKGNAMESUFFIX= -nopython
.endif
.include <bsd.port.pre.mk>
@@ -71,21 +65,8 @@ CONFIGURE_ARGS+= --with-history
CONFIGURE_ARGS+= --with-thread-alloc
.endif
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "libxml2 has the following additional tunables:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " WITHOUT_PYTHON=yes Turns off Python support"
- @${ECHO_MSG} ""
-
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/catalog.c ${WRKSRC}/xmlcatalog.c
-.if !defined(WITHOUT_PYTHON)
-post-install:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
-.endif
-
.include <bsd.port.post.mk>
diff --git a/textproc/libxml2/files/patch-aa b/textproc/libxml2/files/patch-aa
index c2a6689763b7..dff4eba3fdef 100644
--- a/textproc/libxml2/files/patch-aa
+++ b/textproc/libxml2/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.in.orig Tue Mar 23 09:17:22 2004
-+++ Makefile.in Tue Mar 23 09:18:51 2004
+--- Makefile.in.orig Fri Jul 2 13:56:41 2004
++++ Makefile.in Fri Jul 2 13:59:27 2004
@@ -418,13 +418,13 @@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
@@ -25,15 +25,17 @@
confexec_DATA = xml2Conf.sh
EXTRA_DIST = xml2-config.in xml2Conf.sh.in libxml.spec.in libxml2.spec \
libxml.m4 Copyright check-xml-test-suite.py \
-@@ -521,7 +521,7 @@
+@@ -521,8 +521,8 @@
# Instll the tests program sources as examples
#
BASE_DIR = $(datadir)/doc
-DOC_MODULE = libxml2-$(VERSION)
+-EXAMPLES_DIR = $(BASE_DIR)/$(DOC_MODULE)/examples
+DOC_MODULE = libxml2
- EXAMPLES_DIR = $(BASE_DIR)/$(DOC_MODULE)/examples
++EXAMPLES_DIR = $(datadir)/examples/libxml2
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive
+
@@ -1209,7 +1209,7 @@
check-am: all-am
$(MAKE) $(AM_MAKEFLAGS) check-local
diff --git a/textproc/libxml2/files/patch-python::Makefile.in b/textproc/libxml2/files/patch-python::Makefile.in
index e7f8a271b16b..8ab00f6e42dd 100644
--- a/textproc/libxml2/files/patch-python::Makefile.in
+++ b/textproc/libxml2/files/patch-python::Makefile.in
@@ -1,11 +1,32 @@
---- python/Makefile.in.orig Thu Aug 14 22:06:11 2003
-+++ python/Makefile.in Thu Aug 14 22:06:39 2003
-@@ -161,7 +161,7 @@
+--- python/Makefile.in.orig Fri Jul 2 10:54:27 2004
++++ python/Makefile.in Fri Jul 2 11:02:17 2004
+@@ -51,7 +51,7 @@
+ am__installdirs = $(DESTDIR)$(pythondir)
+ pythonLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(python_LTLIBRARIES)
+-@WITH_PYTHON_TRUE@am__DEPENDENCIES_1 = $(top_builddir)/libxml2.la
++@WITH_PYTHON_TRUE@am__DEPENDENCIES_1 =
+ @WITH_PYTHON_TRUE@libxml2mod_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
+ am__libxml2mod_la_SOURCES_DIST = libxml.c types.c libxml2-py.c
+ @WITH_PYTHON_TRUE@am_libxml2mod_la_OBJECTS = libxml.lo types.lo \
+@@ -284,7 +284,7 @@
+ -I$(PYTHON_INCLUDES) \
-I$(top_srcdir)/include
-
-DOCS_DIR = $(datadir)/doc/libxml2-python-$(LIBXML_VERSION)
-+DOCS_DIR = $(datadir)/doc/libxml2-python
++DOCS_DIR = $(datadir)/doc/py-libxml2
# libxml2class.txt is generated
- DOCS = TODO
+ DOCS = ${srcdir}/TODO
+ EXTRA_DIST = \
+@@ -299,9 +299,9 @@
+ libxml2-python-api.xml \
+ $(DOCS)
+
+-libxml2mod_la_LDFLAGS = -module -avoid-version -L$(top_builddir)/.libs
++libxml2mod_la_LDFLAGS = -module -avoid-version
+ @WITH_PYTHON_TRUE@mylibs = \
+-@WITH_PYTHON_TRUE@ $(top_builddir)/libxml2.la
++@WITH_PYTHON_TRUE@ -lxml2
+ @WITH_PYTHON_TRUE@python_LTLIBRARIES = libxml2mod.la
+ @WITH_PYTHON_TRUE@libxml2mod_la_SOURCES = libxml.c types.c libxml2-py.c
diff --git a/textproc/libxml2/files/patch-python::tests::Makefile.in b/textproc/libxml2/files/patch-python::tests::Makefile.in
index a2977bbd13ab..7a640460ea51 100644
--- a/textproc/libxml2/files/patch-python::tests::Makefile.in
+++ b/textproc/libxml2/files/patch-python::tests::Makefile.in
@@ -5,7 +5,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
-EXAMPLE_DIR = $(datadir)/doc/libxml2-python-$(LIBXML_VERSION)/examples
-+EXAMPLE_DIR = $(datadir)/doc/libxml2-python/examples
++EXAMPLE_DIR = $(datadir)/examples/py-libxml2
PYTESTS = \
build.py \
attribs.py \
diff --git a/textproc/libxml2/pkg-descr b/textproc/libxml2/pkg-descr
index 6156cfa85f09..962b4e38b0ac 100644
--- a/textproc/libxml2/pkg-descr
+++ b/textproc/libxml2/pkg-descr
@@ -1,3 +1,3 @@
-xml parser library for GNOME
+XML parser library for GNOME
WWW: http://xmlsoft.org/
diff --git a/textproc/libxml2/pkg-plist b/textproc/libxml2/pkg-plist
index 7e5bcd62bbbb..15889e5a2403 100644
--- a/textproc/libxml2/pkg-plist
+++ b/textproc/libxml2/pkg-plist
@@ -50,179 +50,131 @@ include/libxml2/libxml/xpointer.h
lib/libxml2.a
lib/libxml2.so
lib/libxml2.so.5
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/drv_libxml2.py
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/drv_libxml2.pyc
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/drv_libxml2.pyo
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxml2.py
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxml2.pyc
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxml2.pyo
-%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxml2mod.so
libdata/pkgconfig/libxml-2.0.pc
share/aclocal/libxml.m4
-%%PYTHON:%%share/doc/libxml2-python/TODO
-%%PYTHON:%%share/doc/libxml2-python/examples/attribs.py
-%%PYTHON:%%share/doc/libxml2-python/examples/build.py
-%%PYTHON:%%share/doc/libxml2-python/examples/ctxterror.py
-%%PYTHON:%%share/doc/libxml2-python/examples/cutnpaste.py
-%%PYTHON:%%share/doc/libxml2-python/examples/error.py
-%%PYTHON:%%share/doc/libxml2-python/examples/inbuf.py
-%%PYTHON:%%share/doc/libxml2-python/examples/indexes.py
-%%PYTHON:%%share/doc/libxml2-python/examples/invalid.xml
-%%PYTHON:%%share/doc/libxml2-python/examples/outbuf.py
-%%PYTHON:%%share/doc/libxml2-python/examples/push.py
-%%PYTHON:%%share/doc/libxml2-python/examples/pushSAX.py
-%%PYTHON:%%share/doc/libxml2-python/examples/pushSAXhtml.py
-%%PYTHON:%%share/doc/libxml2-python/examples/reader.py
-%%PYTHON:%%share/doc/libxml2-python/examples/reader2.py
-%%PYTHON:%%share/doc/libxml2-python/examples/reader3.py
-%%PYTHON:%%share/doc/libxml2-python/examples/reader4.py
-%%PYTHON:%%share/doc/libxml2-python/examples/reader5.py
-%%PYTHON:%%share/doc/libxml2-python/examples/reader6.py
-%%PYTHON:%%share/doc/libxml2-python/examples/reader7.py
-%%PYTHON:%%share/doc/libxml2-python/examples/reader8.py
-%%PYTHON:%%share/doc/libxml2-python/examples/readererr.py
-%%PYTHON:%%share/doc/libxml2-python/examples/regexp.py
-%%PYTHON:%%share/doc/libxml2-python/examples/relaxng.py
-%%PYTHON:%%share/doc/libxml2-python/examples/resolver.py
-%%PYTHON:%%share/doc/libxml2-python/examples/serialize.py
-%%PYTHON:%%share/doc/libxml2-python/examples/sync.py
-%%PYTHON:%%share/doc/libxml2-python/examples/thread2.py
-%%PYTHON:%%share/doc/libxml2-python/examples/tst.py
-%%PYTHON:%%share/doc/libxml2-python/examples/tst.xml
-%%PYTHON:%%share/doc/libxml2-python/examples/tstLastError.py
-%%PYTHON:%%share/doc/libxml2-python/examples/tstURI.py
-%%PYTHON:%%share/doc/libxml2-python/examples/tstxpath.py
-%%PYTHON:%%share/doc/libxml2-python/examples/valid.xml
-%%PYTHON:%%share/doc/libxml2-python/examples/validate.py
-%%PYTHON:%%share/doc/libxml2-python/examples/walker.py
-%%PYTHON:%%share/doc/libxml2-python/examples/xpath.py
-%%PYTHON:%%share/doc/libxml2-python/examples/xpathext.py
-%%PYTHON:%%share/doc/libxml2-python/examples/xpathret.py
-share/doc/libxml2/Copyright
-share/doc/libxml2/DOM.gif
-share/doc/libxml2/FAQ.html
-share/doc/libxml2/Libxml2-Logo-180x168.gif
-share/doc/libxml2/Libxml2-Logo-90x34.gif
-share/doc/libxml2/encoding.html
-share/doc/libxml2/examples/testHTML.c
-share/doc/libxml2/examples/testSAX.c
-share/doc/libxml2/examples/testXPath.c
-share/doc/libxml2/examples/xmllint.c
-share/doc/libxml2/html/book1.html
-share/doc/libxml2/html/home.png
-share/doc/libxml2/html/index.html
-share/doc/libxml2/html/left.png
-share/doc/libxml2/html/libxml-DOCBparser.html
-share/doc/libxml2/html/libxml-HTMLparser.html
-share/doc/libxml2/html/libxml-HTMLtree.html
-share/doc/libxml2/html/libxml-SAX.html
-share/doc/libxml2/html/libxml-SAX2.html
-share/doc/libxml2/html/libxml-c14n.html
-share/doc/libxml2/html/libxml-catalog.html
-share/doc/libxml2/html/libxml-chvalid.html
-share/doc/libxml2/html/libxml-debugXML.html
-share/doc/libxml2/html/libxml-dict.html
-share/doc/libxml2/html/libxml-encoding.html
-share/doc/libxml2/html/libxml-entities.html
-share/doc/libxml2/html/libxml-globals.html
-share/doc/libxml2/html/libxml-hash.html
-share/doc/libxml2/html/libxml-lib.html
-share/doc/libxml2/html/libxml-list.html
-share/doc/libxml2/html/libxml-nanoftp.html
-share/doc/libxml2/html/libxml-nanohttp.html
-share/doc/libxml2/html/libxml-parser.html
-share/doc/libxml2/html/libxml-parserInternals.html
-share/doc/libxml2/html/libxml-pattern.html
-share/doc/libxml2/html/libxml-relaxng.html
-share/doc/libxml2/html/libxml-schemasInternals.html
-share/doc/libxml2/html/libxml-threads.html
-share/doc/libxml2/html/libxml-tree.html
-share/doc/libxml2/html/libxml-uri.html
-share/doc/libxml2/html/libxml-valid.html
-share/doc/libxml2/html/libxml-xinclude.html
-share/doc/libxml2/html/libxml-xlink.html
-share/doc/libxml2/html/libxml-xmlIO.html
-share/doc/libxml2/html/libxml-xmlautomata.html
-share/doc/libxml2/html/libxml-xmlerror.html
-share/doc/libxml2/html/libxml-xmlexports.html
-share/doc/libxml2/html/libxml-xmlmemory.html
-share/doc/libxml2/html/libxml-xmlreader.html
-share/doc/libxml2/html/libxml-xmlregexp.html
-share/doc/libxml2/html/libxml-xmlsave.html
-share/doc/libxml2/html/libxml-xmlschemas.html
-share/doc/libxml2/html/libxml-xmlschemastypes.html
-share/doc/libxml2/html/libxml-xmlstring.html
-share/doc/libxml2/html/libxml-xmlunicode.html
-share/doc/libxml2/html/libxml-xmlversion.html
-share/doc/libxml2/html/libxml-xmlwriter.html
-share/doc/libxml2/html/libxml-xpath.html
-share/doc/libxml2/html/libxml-xpathInternals.html
-share/doc/libxml2/html/libxml-xpointer.html
-share/doc/libxml2/html/right.png
-share/doc/libxml2/html/up.png
-share/doc/libxml2/libxml.gif
-share/doc/libxml2/redhat.gif
-share/doc/libxml2/smallfootonly.gif
-share/doc/libxml2/structure.gif
-share/doc/libxml2/tutorial/apa.html
-share/doc/libxml2/tutorial/apb.html
-share/doc/libxml2/tutorial/apc.html
-share/doc/libxml2/tutorial/apd.html
-share/doc/libxml2/tutorial/ape.html
-share/doc/libxml2/tutorial/apf.html
-share/doc/libxml2/tutorial/apg.html
-share/doc/libxml2/tutorial/aph.html
-share/doc/libxml2/tutorial/api.html
-share/doc/libxml2/tutorial/ar01s02.html
-share/doc/libxml2/tutorial/ar01s03.html
-share/doc/libxml2/tutorial/ar01s04.html
-share/doc/libxml2/tutorial/ar01s05.html
-share/doc/libxml2/tutorial/ar01s06.html
-share/doc/libxml2/tutorial/ar01s07.html
-share/doc/libxml2/tutorial/ar01s08.html
-share/doc/libxml2/tutorial/ar01s09.html
-share/doc/libxml2/tutorial/images/blank.png
-share/doc/libxml2/tutorial/images/callouts/1.png
-share/doc/libxml2/tutorial/images/callouts/10.png
-share/doc/libxml2/tutorial/images/callouts/2.png
-share/doc/libxml2/tutorial/images/callouts/3.png
-share/doc/libxml2/tutorial/images/callouts/4.png
-share/doc/libxml2/tutorial/images/callouts/5.png
-share/doc/libxml2/tutorial/images/callouts/6.png
-share/doc/libxml2/tutorial/images/callouts/7.png
-share/doc/libxml2/tutorial/images/callouts/8.png
-share/doc/libxml2/tutorial/images/callouts/9.png
-share/doc/libxml2/tutorial/images/caution.png
-share/doc/libxml2/tutorial/images/draft.png
-share/doc/libxml2/tutorial/images/home.png
-share/doc/libxml2/tutorial/images/important.png
-share/doc/libxml2/tutorial/images/next.png
-share/doc/libxml2/tutorial/images/note.png
-share/doc/libxml2/tutorial/images/prev.png
-share/doc/libxml2/tutorial/images/tip.png
-share/doc/libxml2/tutorial/images/toc-blank.png
-share/doc/libxml2/tutorial/images/toc-minus.png
-share/doc/libxml2/tutorial/images/toc-plus.png
-share/doc/libxml2/tutorial/images/up.png
-share/doc/libxml2/tutorial/images/warning.png
-share/doc/libxml2/tutorial/includeaddattribute.c
-share/doc/libxml2/tutorial/includeaddkeyword.c
-share/doc/libxml2/tutorial/includeconvert.c
-share/doc/libxml2/tutorial/includegetattribute.c
-share/doc/libxml2/tutorial/includekeyword.c
-share/doc/libxml2/tutorial/includexpath.c
-share/doc/libxml2/tutorial/index.html
-share/doc/libxml2/tutorial/ix01.html
-share/doc/libxml2/tutorial/xmltutorial.pdf
-share/doc/libxml2/w3c.png
-share/doc/libxml2/xml.html
-@dirrm share/doc/libxml2/tutorial/images/callouts
-@dirrm share/doc/libxml2/tutorial/images
-@dirrm share/doc/libxml2/tutorial
-@dirrm share/doc/libxml2/html
-%%PYTHON:%%@dirrm share/doc/libxml2-python/examples
-%%PYTHON:%%@dirrm share/doc/libxml2-python
-@dirrm share/doc/libxml2/examples
-@dirrm share/doc/libxml2
+%%DOCSDIR%%/Copyright
+%%DOCSDIR%%/DOM.gif
+%%DOCSDIR%%/FAQ.html
+%%DOCSDIR%%/Libxml2-Logo-180x168.gif
+%%DOCSDIR%%/Libxml2-Logo-90x34.gif
+%%DOCSDIR%%/encoding.html
+%%DOCSDIR%%/html/book1.html
+%%DOCSDIR%%/html/home.png
+%%DOCSDIR%%/html/index.html
+%%DOCSDIR%%/html/left.png
+%%DOCSDIR%%/html/libxml-DOCBparser.html
+%%DOCSDIR%%/html/libxml-HTMLparser.html
+%%DOCSDIR%%/html/libxml-HTMLtree.html
+%%DOCSDIR%%/html/libxml-SAX.html
+%%DOCSDIR%%/html/libxml-SAX2.html
+%%DOCSDIR%%/html/libxml-c14n.html
+%%DOCSDIR%%/html/libxml-catalog.html
+%%DOCSDIR%%/html/libxml-chvalid.html
+%%DOCSDIR%%/html/libxml-debugXML.html
+%%DOCSDIR%%/html/libxml-dict.html
+%%DOCSDIR%%/html/libxml-encoding.html
+%%DOCSDIR%%/html/libxml-entities.html
+%%DOCSDIR%%/html/libxml-globals.html
+%%DOCSDIR%%/html/libxml-hash.html
+%%DOCSDIR%%/html/libxml-lib.html
+%%DOCSDIR%%/html/libxml-list.html
+%%DOCSDIR%%/html/libxml-nanoftp.html
+%%DOCSDIR%%/html/libxml-nanohttp.html
+%%DOCSDIR%%/html/libxml-parser.html
+%%DOCSDIR%%/html/libxml-parserInternals.html
+%%DOCSDIR%%/html/libxml-pattern.html
+%%DOCSDIR%%/html/libxml-relaxng.html
+%%DOCSDIR%%/html/libxml-schemasInternals.html
+%%DOCSDIR%%/html/libxml-threads.html
+%%DOCSDIR%%/html/libxml-tree.html
+%%DOCSDIR%%/html/libxml-uri.html
+%%DOCSDIR%%/html/libxml-valid.html
+%%DOCSDIR%%/html/libxml-xinclude.html
+%%DOCSDIR%%/html/libxml-xlink.html
+%%DOCSDIR%%/html/libxml-xmlIO.html
+%%DOCSDIR%%/html/libxml-xmlautomata.html
+%%DOCSDIR%%/html/libxml-xmlerror.html
+%%DOCSDIR%%/html/libxml-xmlexports.html
+%%DOCSDIR%%/html/libxml-xmlmemory.html
+%%DOCSDIR%%/html/libxml-xmlreader.html
+%%DOCSDIR%%/html/libxml-xmlregexp.html
+%%DOCSDIR%%/html/libxml-xmlsave.html
+%%DOCSDIR%%/html/libxml-xmlschemas.html
+%%DOCSDIR%%/html/libxml-xmlschemastypes.html
+%%DOCSDIR%%/html/libxml-xmlstring.html
+%%DOCSDIR%%/html/libxml-xmlunicode.html
+%%DOCSDIR%%/html/libxml-xmlversion.html
+%%DOCSDIR%%/html/libxml-xmlwriter.html
+%%DOCSDIR%%/html/libxml-xpath.html
+%%DOCSDIR%%/html/libxml-xpathInternals.html
+%%DOCSDIR%%/html/libxml-xpointer.html
+%%DOCSDIR%%/html/right.png
+%%DOCSDIR%%/html/up.png
+%%DOCSDIR%%/libxml.gif
+%%DOCSDIR%%/redhat.gif
+%%DOCSDIR%%/smallfootonly.gif
+%%DOCSDIR%%/structure.gif
+%%DOCSDIR%%/tutorial/apa.html
+%%DOCSDIR%%/tutorial/apb.html
+%%DOCSDIR%%/tutorial/apc.html
+%%DOCSDIR%%/tutorial/apd.html
+%%DOCSDIR%%/tutorial/ape.html
+%%DOCSDIR%%/tutorial/apf.html
+%%DOCSDIR%%/tutorial/apg.html
+%%DOCSDIR%%/tutorial/aph.html
+%%DOCSDIR%%/tutorial/api.html
+%%DOCSDIR%%/tutorial/ar01s02.html
+%%DOCSDIR%%/tutorial/ar01s03.html
+%%DOCSDIR%%/tutorial/ar01s04.html
+%%DOCSDIR%%/tutorial/ar01s05.html
+%%DOCSDIR%%/tutorial/ar01s06.html
+%%DOCSDIR%%/tutorial/ar01s07.html
+%%DOCSDIR%%/tutorial/ar01s08.html
+%%DOCSDIR%%/tutorial/ar01s09.html
+%%DOCSDIR%%/tutorial/images/blank.png
+%%DOCSDIR%%/tutorial/images/callouts/1.png
+%%DOCSDIR%%/tutorial/images/callouts/10.png
+%%DOCSDIR%%/tutorial/images/callouts/2.png
+%%DOCSDIR%%/tutorial/images/callouts/3.png
+%%DOCSDIR%%/tutorial/images/callouts/4.png
+%%DOCSDIR%%/tutorial/images/callouts/5.png
+%%DOCSDIR%%/tutorial/images/callouts/6.png
+%%DOCSDIR%%/tutorial/images/callouts/7.png
+%%DOCSDIR%%/tutorial/images/callouts/8.png
+%%DOCSDIR%%/tutorial/images/callouts/9.png
+%%DOCSDIR%%/tutorial/images/caution.png
+%%DOCSDIR%%/tutorial/images/draft.png
+%%DOCSDIR%%/tutorial/images/home.png
+%%DOCSDIR%%/tutorial/images/important.png
+%%DOCSDIR%%/tutorial/images/next.png
+%%DOCSDIR%%/tutorial/images/note.png
+%%DOCSDIR%%/tutorial/images/prev.png
+%%DOCSDIR%%/tutorial/images/tip.png
+%%DOCSDIR%%/tutorial/images/toc-blank.png
+%%DOCSDIR%%/tutorial/images/toc-minus.png
+%%DOCSDIR%%/tutorial/images/toc-plus.png
+%%DOCSDIR%%/tutorial/images/up.png
+%%DOCSDIR%%/tutorial/images/warning.png
+%%DOCSDIR%%/tutorial/includeaddattribute.c
+%%DOCSDIR%%/tutorial/includeaddkeyword.c
+%%DOCSDIR%%/tutorial/includeconvert.c
+%%DOCSDIR%%/tutorial/includegetattribute.c
+%%DOCSDIR%%/tutorial/includekeyword.c
+%%DOCSDIR%%/tutorial/includexpath.c
+%%DOCSDIR%%/tutorial/index.html
+%%DOCSDIR%%/tutorial/ix01.html
+%%DOCSDIR%%/tutorial/xmltutorial.pdf
+%%DOCSDIR%%/w3c.png
+%%DOCSDIR%%/xml.html
+%%EXAMPLESDIR%%/testHTML.c
+%%EXAMPLESDIR%%/testSAX.c
+%%EXAMPLESDIR%%/testXPath.c
+%%EXAMPLESDIR%%/xmllint.c
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%/tutorial/images/callouts
+@dirrm %%DOCSDIR%%/tutorial/images
+@dirrm %%DOCSDIR%%/tutorial
+@dirrm %%DOCSDIR%%/html
+@dirrm %%DOCSDIR%%
@dirrm include/libxml2/libxml
@dirrm include/libxml2