aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Apache-Peek/Makefile25
-rw-r--r--www/p5-Apache-Peek/distinfo1
-rw-r--r--www/p5-Apache-Peek/pkg-comment1
-rw-r--r--www/p5-Apache-Peek/pkg-descr7
-rw-r--r--www/p5-Apache-Peek/pkg-plist5
6 files changed, 40 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f65077d63303..dfeec263d70e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -112,6 +112,7 @@
SUBDIR += p5-Apache
SUBDIR += p5-Apache-ASP
SUBDIR += p5-Apache-DBI
+ SUBDIR += p5-Apache-Peek
SUBDIR += p5-Apache-Radius
SUBDIR += p5-Apache-Session
SUBDIR += p5-CGI
diff --git a/www/p5-Apache-Peek/Makefile b/www/p5-Apache-Peek/Makefile
new file mode 100644
index 000000000000..b8e6a50e624b
--- /dev/null
+++ b/www/p5-Apache-Peek/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Apache-Peek
+# Date created: 24-Jul-2000
+# Whom: Leo Kim <leo@florida.sarang.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Peek
+PORTVERSION= 0.9501
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR=Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leo@florida.sarang.net
+
+USE_PERL5= YES
+MAN3= Apache::Peek.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/www/p5-Apache-Peek/distinfo b/www/p5-Apache-Peek/distinfo
new file mode 100644
index 000000000000..579b3f93511c
--- /dev/null
+++ b/www/p5-Apache-Peek/distinfo
@@ -0,0 +1 @@
+MD5 (Apache-Peek-0.9501.tar.gz) = aadaa2f9a37cba78d614e3ba9fd630e8
diff --git a/www/p5-Apache-Peek/pkg-comment b/www/p5-Apache-Peek/pkg-comment
new file mode 100644
index 000000000000..30123917d49d
--- /dev/null
+++ b/www/p5-Apache-Peek/pkg-comment
@@ -0,0 +1 @@
+A perl5 data debugging tool for the XS programmer
diff --git a/www/p5-Apache-Peek/pkg-descr b/www/p5-Apache-Peek/pkg-descr
new file mode 100644
index 000000000000..c190436dd2f3
--- /dev/null
+++ b/www/p5-Apache-Peek/pkg-descr
@@ -0,0 +1,7 @@
+Apache::Peek is Ilya Zakharevich's Devel::Peek module that sends
+output to the browser instead of stderr.
+
+WWW: http://search.cpan.org/doc/DOUGM/mod_perl-1.24/apache-modlist.html
+
+- Leo Kim
+leo@florida.sarang.net
diff --git a/www/p5-Apache-Peek/pkg-plist b/www/p5-Apache-Peek/pkg-plist
new file mode 100644
index 000000000000..67f839a68cd0
--- /dev/null
+++ b/www/p5-Apache-Peek/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Apache/Peek.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Peek/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Peek/Peek.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Peek/Peek.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Apache/Peek