aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/fortune-mod-bible/Makefile34
-rw-r--r--misc/fortune-mod-bible/distinfo2
-rw-r--r--misc/fortune-mod-bible/files/pkg-message.in3
-rw-r--r--misc/fortune-mod-bible/pkg-descr7
-rw-r--r--misc/fortune-mod-bible/pkg-plist4
6 files changed, 51 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 4e83ae0688b6..e27f414602d6 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -83,6 +83,7 @@
SUBDIR += firestring
SUBDIR += floatator
SUBDIR += flyway
+ SUBDIR += fortune-mod-bible
SUBDIR += fortune-mod-bofh
SUBDIR += fortune-mod-futurama
SUBDIR += fortuneit
diff --git a/misc/fortune-mod-bible/Makefile b/misc/fortune-mod-bible/Makefile
new file mode 100644
index 000000000000..0f9504c3783c
--- /dev/null
+++ b/misc/fortune-mod-bible/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fortune-mod-bible
+# Date created: 3/30/2004
+# Whom: djp
+#
+# $FreeBSD$
+#
+
+PORTNAME= fortune-mod-bible
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fortunebible
+DISTNAME= bible
+
+MAINTAINER= doug@polands.org
+COMMENT= King James V Bible in fortune file format
+
+DIST_SUBDIR= ${PORTNAME}
+NO_WRKSUBDIR= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
+USE_BZIP2= yes
+
+do-build:
+ @${CAT} ${FILESDIR}/pkg-message.in | ${SED} 's#PREFIX#${PREFIX}#' > ${PKGMESSAGE}
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/games
+ @${MKDIR} ${PREFIX}/share/games/fortune
+ @${INSTALL_DATA} ${WRKSRC}/bible* ${PREFIX}/share/games/fortune
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/misc/fortune-mod-bible/distinfo b/misc/fortune-mod-bible/distinfo
new file mode 100644
index 000000000000..c88cb33a5681
--- /dev/null
+++ b/misc/fortune-mod-bible/distinfo
@@ -0,0 +1,2 @@
+MD5 (fortune-mod-bible/bible.tar.bz2) = eeeab5b2ad0d514ae728eaeea2fac21e
+SIZE (fortune-mod-bible/bible.tar.bz2) = 1105456
diff --git a/misc/fortune-mod-bible/files/pkg-message.in b/misc/fortune-mod-bible/files/pkg-message.in
new file mode 100644
index 000000000000..f712587b218c
--- /dev/null
+++ b/misc/fortune-mod-bible/files/pkg-message.in
@@ -0,0 +1,3 @@
+
+Usage: fortune PREFIX/share/games/fortune/bible
+
diff --git a/misc/fortune-mod-bible/pkg-descr b/misc/fortune-mod-bible/pkg-descr
new file mode 100644
index 000000000000..d21ab678aaeb
--- /dev/null
+++ b/misc/fortune-mod-bible/pkg-descr
@@ -0,0 +1,7 @@
+fortune-mod-bible is the King James V Bible processed into the fortune format.
+Original text is in the public domain.
+
+WWW: http://fortunebible.sourceforge.net
+
+- Doug
+doug@polands.org
diff --git a/misc/fortune-mod-bible/pkg-plist b/misc/fortune-mod-bible/pkg-plist
new file mode 100644
index 000000000000..c77d709e5c46
--- /dev/null
+++ b/misc/fortune-mod-bible/pkg-plist
@@ -0,0 +1,4 @@
+share/games/fortune/bible
+share/games/fortune/bible.dat
+@unexec rmdir %D/share/games/fortune 2>/dev/null || true
+@unexec rmdir %D/share/games 2>/dev/null || true