aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-transitions/Makefile22
-rw-r--r--devel/py-transitions/distinfo3
-rw-r--r--devel/py-transitions/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 069fe9f3fbb1..33cd07bcbdf3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5125,6 +5125,7 @@
SUBDIR += py-traitlets
SUBDIR += py-traits
SUBDIR += py-transaction
+ SUBDIR += py-transitions
SUBDIR += py-tree-format
SUBDIR += py-trollius
SUBDIR += py-ttystatus
diff --git a/devel/py-transitions/Makefile b/devel/py-transitions/Makefile
new file mode 100644
index 000000000000..6302e7e489ce
--- /dev/null
+++ b/devel/py-transitions/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= transitions
+DISTVERSION= 0.7.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sergey@akhmatov.ru
+COMMENT= Lightweight, object-oriented Python state machine implementation
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-transitions/distinfo b/devel/py-transitions/distinfo
new file mode 100644
index 000000000000..9ed16b641355
--- /dev/null
+++ b/devel/py-transitions/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1569669785
+SHA256 (transitions-0.7.1.tar.gz) = b73015080833b753cbb4a10f51f8234924ddfbdbaf33539fee4e4f3abfff454d
+SIZE (transitions-0.7.1.tar.gz) = 1318322
diff --git a/devel/py-transitions/pkg-descr b/devel/py-transitions/pkg-descr
new file mode 100644
index 000000000000..50f2849ec9b0
--- /dev/null
+++ b/devel/py-transitions/pkg-descr
@@ -0,0 +1,4 @@
+A lightweight, object-oriented state machine implementation in Python.
+Compatible with Python 2.7+ and 3.0+.
+
+WWW: https://github.com/pytransitions/transitions