aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-CouchDB-View/Makefile34
-rw-r--r--databases/p5-CouchDB-View/distinfo2
-rw-r--r--databases/p5-CouchDB-View/pkg-descr3
-rw-r--r--databases/p5-CouchDB-View/pkg-plist9
5 files changed, 49 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 0b891d0fd9c2..ef27603f41f3 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -310,6 +310,7 @@
SUBDIR += p5-Class-DBI-Untaint
SUBDIR += p5-Class-DBI-mysql
SUBDIR += p5-Class-Inflate
+ SUBDIR += p5-CouchDB-View
SUBDIR += p5-DBD-AnyData
SUBDIR += p5-DBD-CSV
SUBDIR += p5-DBD-Excel
diff --git a/databases/p5-CouchDB-View/Makefile b/databases/p5-CouchDB-View/Makefile
new file mode 100644
index 000000000000..660eb5700272
--- /dev/null
+++ b/databases/p5-CouchDB-View/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-CouchDB-View
+# Date created: 2011-09-03
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CouchDB-View
+PORTVERSION= 0.003
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Handle and create CouchDB views in Perl
+
+BUILD_DEPENDS= p5-Data-Dump-Streamer>=0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
+ p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-PadWalker>=0:${PORTSDIR}/devel/p5-PadWalker \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= p5-Data-Dump-Streamer>=0:${PORTSDIR}/devel/p5-Data-Dump-Streamer \
+ p5-JSON-XS>=0:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-PadWalker>=0:${PORTSDIR}/devel/p5-PadWalker \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+
+TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
+
+PERL_CONFIGURE= yes
+
+MAN3= CouchDB::View.3 \
+ CouchDB::View::Document.3 \
+ CouchDB::View::Server.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-CouchDB-View/distinfo b/databases/p5-CouchDB-View/distinfo
new file mode 100644
index 000000000000..41edbbaa6c6e
--- /dev/null
+++ b/databases/p5-CouchDB-View/distinfo
@@ -0,0 +1,2 @@
+SHA256 (CouchDB-View-0.003.tar.gz) = 8f7ee2432dce3ec91b69c8377b34442e8b9b3938405a3d7d68b5f99234e45ebb
+SIZE (CouchDB-View-0.003.tar.gz) = 17094
diff --git a/databases/p5-CouchDB-View/pkg-descr b/databases/p5-CouchDB-View/pkg-descr
new file mode 100644
index 000000000000..0817db45ce64
--- /dev/null
+++ b/databases/p5-CouchDB-View/pkg-descr
@@ -0,0 +1,3 @@
+CouchDB::View is a Perl module to handle and create CouchDB views.
+
+WWW: http://search.cpan.org/dist/CouchDB-View/
diff --git a/databases/p5-CouchDB-View/pkg-plist b/databases/p5-CouchDB-View/pkg-plist
new file mode 100644
index 000000000000..e7546e7b4d7f
--- /dev/null
+++ b/databases/p5-CouchDB-View/pkg-plist
@@ -0,0 +1,9 @@
+bin/couchdb-view-server.pl
+%%SITE_PERL%%/CouchDB/View.pm
+%%SITE_PERL%%/CouchDB/View/Document.pm
+%%SITE_PERL%%/CouchDB/View/Server.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CouchDB/View/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CouchDB/View
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CouchDB
+@dirrmtry %%SITE_PERL%%/CouchDB/View
+@dirrmtry %%SITE_PERL%%/CouchDB