aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/sma/Makefile39
-rw-r--r--mail/sma/distinfo1
-rw-r--r--mail/sma/pkg-comment1
-rw-r--r--mail/sma/pkg-descr14
-rw-r--r--mail/sma/pkg-plist10
6 files changed, 66 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 3d3243cb7e58..fa160b67b9ce 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -206,6 +206,7 @@
SUBDIR += serialmail
SUBDIR += sigit
SUBDIR += sigrot
+ SUBDIR += sma
SUBDIR += smail
SUBDIR += smapi
SUBDIR += smtpclient
diff --git a/mail/sma/Makefile b/mail/sma/Makefile
new file mode 100644
index 000000000000..56ea4a423aef
--- /dev/null
+++ b/mail/sma/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: sma
+# Date created: 28. Mar 2002
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= sma
+PORTVERSION= 1.0
+CATEGORIES= mail
+MASTER_SITES= http://www.klake.org/sma/dl/
+
+MAINTAINER= dinoex@FreeBSD.org
+
+MAN8= sma.8
+DOCSFILES= BUGS COPYRIGHT HISTORY README TODO
+SAMPLEFILES= sma.conf
+ALL_TARGET= sma
+
+do-configure:
+ ${PERL} -pi -e "s,CC =,CC?=," ${WRKSRC}/Makefile
+ ${PERL} -pi -e "s,CFLAGS = -Wall -O,CFLAGS+= ," \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sma ${PREFIX}/bin/sma
+ ${INSTALL_MAN} ${WRKSRC}/sma.8 ${PREFIX}/man/man8/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in ${DOCSFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.for i in ${SAMPLEFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${EXAMPLESDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/sma/distinfo b/mail/sma/distinfo
new file mode 100644
index 000000000000..ad2703b88ca8
--- /dev/null
+++ b/mail/sma/distinfo
@@ -0,0 +1 @@
+MD5 (sma-1.0.tar.gz) = 993d6b2d24696a6462d1149b4fdc61ab
diff --git a/mail/sma/pkg-comment b/mail/sma/pkg-comment
new file mode 100644
index 000000000000..438483db3cba
--- /dev/null
+++ b/mail/sma/pkg-comment
@@ -0,0 +1 @@
+Program that analyses Sendmail log entries
diff --git a/mail/sma/pkg-descr b/mail/sma/pkg-descr
new file mode 100644
index 000000000000..41c9ee04d176
--- /dev/null
+++ b/mail/sma/pkg-descr
@@ -0,0 +1,14 @@
+SMA is a program that analyses sendmail log entries.
+The key features of SMA are
+ Fast (written in C)
+ Portable
+ Free (BSD-style licensing)
+ output as HTML or ASCII.
+
+SMA features
+ Support for all recent sendmail versions (UNIX/NT)
+ Flexible output formatting - HTML, ASCII and Custom Log
+ Regular expression filtering of messages
+ Multiple hosts in a same report
+
+WWW: http://www.klake.org/sma/
diff --git a/mail/sma/pkg-plist b/mail/sma/pkg-plist
new file mode 100644
index 000000000000..1496bd5b559e
--- /dev/null
+++ b/mail/sma/pkg-plist
@@ -0,0 +1,10 @@
+bin/sma
+%%PORTDOCS%%share/doc/sma/BUGS
+%%PORTDOCS%%share/doc/sma/COPYRIGHT
+%%PORTDOCS%%share/doc/sma/HISTORY
+%%PORTDOCS%%share/doc/sma/README
+%%PORTDOCS%%share/doc/sma/TODO
+%%PORTDOCS%%@dirrm share/doc/sma
+%%PORTDOCS%%share/examples/sma/sma.conf
+%%PORTDOCS%%@dirrm share/examples/sma
+