aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--finance/cbb/Makefile2
-rw-r--r--finance/p5-Finance-YahooQuote/Makefile3
-rw-r--r--finance/p5-Math-Financial/Makefile3
-rw-r--r--misc/gcstar/Makefile3
-rw-r--r--misc/gnuls/Makefile3
-rw-r--r--misc/kenny/Makefile2
-rw-r--r--misc/p5-Bot-Training-MegaHAL/Makefile3
-rw-r--r--misc/p5-Business-EDI/Makefile3
-rw-r--r--misc/p5-Geography-Countries/Makefile3
-rw-r--r--misc/p5-I18N-LangTags/Makefile3
-rw-r--r--misc/p5-List-Compare/Makefile3
-rw-r--r--misc/p5-Norge/Makefile3
-rw-r--r--misc/spamcalc/Makefile2
-rw-r--r--x11-toolkits/gnome-desktop-sharp20/Makefile3
-rw-r--r--x11-toolkits/gnome-sharp20/Makefile3
-rw-r--r--x11-toolkits/gtk-sharp10/Makefile3
-rw-r--r--x11-toolkits/gtk-sharp20/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2-Chmod/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-Dialogs/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-Utils/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2-GladeXML/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2-PathButtonBar/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2/Makefile3
-rw-r--r--x11-toolkits/p5-Pango/Makefile3
-rw-r--r--x11-toolkits/p5-Tk-FileDialog/Makefile3
-rw-r--r--x11-toolkits/p5-Tk-FontDialog/Makefile3
26 files changed, 49 insertions, 26 deletions
diff --git a/finance/cbb/Makefile b/finance/cbb/Makefile
index 874d6d660deb..f5e4693faef1 100644
--- a/finance/cbb/Makefile
+++ b/finance/cbb/Makefile
@@ -17,7 +17,7 @@ COMMENT= Checkbook balancing tool
USE_TK= yes
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-perl=${PERL} \
--with-wish=${WISH}
diff --git a/finance/p5-Finance-YahooQuote/Makefile b/finance/p5-Finance-YahooQuote/Makefile
index 38cb99bfef8f..683adadc56ec 100644
--- a/finance/p5-Finance-YahooQuote/Makefile
+++ b/finance/p5-Finance-YahooQuote/Makefile
@@ -18,7 +18,8 @@ RUN_DEPENDS= p5-HTML-Parser>=2.2:${PORTSDIR}/www/p5-HTML-Parser \
p5-libwww>=1.62:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= yahooquote.1
MAN3= Finance::YahooQuote.3
diff --git a/finance/p5-Math-Financial/Makefile b/finance/p5-Math-Financial/Makefile
index 6d82d06c7d7d..43dbd88ce4ac 100644
--- a/finance/p5-Math-Financial/Makefile
+++ b/finance/p5-Math-Financial/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skreuzer@FreeBSD.org
COMMENT= Perl module containing common functions for loans and annuities
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Math::Financial.3
diff --git a/misc/gcstar/Makefile b/misc/gcstar/Makefile
index 102a7e269386..4595a23c997a 100644
--- a/misc/gcstar/Makefile
+++ b/misc/gcstar/Makefile
@@ -35,7 +35,8 @@ MAN1= gcstar.1
MANCOMPRESSED= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GNOME= desktopfileutils
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
NO_BUILD= yes
diff --git a/misc/gnuls/Makefile b/misc/gnuls/Makefile
index a1d8c8c78b6d..1b00c2a45c44 100644
--- a/misc/gnuls/Makefile
+++ b/misc/gnuls/Makefile
@@ -18,7 +18,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
USE_XZ= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PERL5_BUILD=yes # Required for tests and man page generation
+USES= perl5
+USE_PERL5= build
MAN1= gnuls.1 dircolors.1 dir.1 vdir.1
diff --git a/misc/kenny/Makefile b/misc/kenny/Makefile
index 2e1f645404bd..cf4fde4079a6 100644
--- a/misc/kenny/Makefile
+++ b/misc/kenny/Makefile
@@ -16,7 +16,7 @@ PROJECTHOST= ak-various-projects
CONFLICTS= filters-*
-USE_PERL5= yes
+USES= perl5
EXTRACT_CMD= ${GZCAT}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= > ${WRKDIR}/${PORTNAME}
diff --git a/misc/p5-Bot-Training-MegaHAL/Makefile b/misc/p5-Bot-Training-MegaHAL/Makefile
index 922bc5d38a75..fde37d655712 100644
--- a/misc/p5-Bot-Training-MegaHAL/Makefile
+++ b/misc/p5-Bot-Training-MegaHAL/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-File-ShareDir-Install>=0:${PORTSDIR}/devel/p5-File-ShareDir-In
RUN_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
p5-Bot-Training>=0:${PORTSDIR}/misc/p5-Bot-Training
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Bot::Training::MegaHAL.3
diff --git a/misc/p5-Business-EDI/Makefile b/misc/p5-Business-EDI/Makefile
index 3969d62fe30c..be085cc5f7be 100644
--- a/misc/p5-Business-EDI/Makefile
+++ b/misc/p5-Business-EDI/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/atz-${PORTNAME}-327e01f
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Business::EDI.3 \
Business::EDI::CodeList.3 \
diff --git a/misc/p5-Geography-Countries/Makefile b/misc/p5-Geography-Countries/Makefile
index cc4b882c487d..0abc00ac6812 100644
--- a/misc/p5-Geography-Countries/Makefile
+++ b/misc/p5-Geography-Countries/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dikshie@lapi.itb.ac.id
COMMENT= Handle ISO-3166 country codes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS+= INSTALLDIRS='site'
MAN3= Geography::Countries.3
diff --git a/misc/p5-I18N-LangTags/Makefile b/misc/p5-I18N-LangTags/Makefile
index bfe5a0338f6a..2f9eef0eec3f 100644
--- a/misc/p5-I18N-LangTags/Makefile
+++ b/misc/p5-I18N-LangTags/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Functions for dealing with RFC-1766-style language tags
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= I18N::LangTags.3 I18N::LangTags::Detect.3 I18N::LangTags::List.3
diff --git a/misc/p5-List-Compare/Makefile b/misc/p5-List-Compare/Makefile
index 4a10e25884ea..05a3481832fe 100644
--- a/misc/p5-List-Compare/Makefile
+++ b/misc/p5-List-Compare/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= marck@FreeBSD.org
COMMENT= Perl extension for comparing lists
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
PLIST_FILES= \
${SITE_PERL_REL}/List/Compare.pm \
diff --git a/misc/p5-Norge/Makefile b/misc/p5-Norge/Makefile
index 529fcb199075..e6130d99f8cd 100644
--- a/misc/p5-Norge/Makefile
+++ b/misc/p5-Norge/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= anders@FreeBSD.org
COMMENT= Misc. Norwegian methods for Perl, conversion/dates/numbers etc.
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= No::Sort.3 No::KontoNr.3 No::PersonNr.3 No::Dato.3
diff --git a/misc/spamcalc/Makefile b/misc/spamcalc/Makefile
index 180afff0f3f3..aaaf5baa0109 100644
--- a/misc/spamcalc/Makefile
+++ b/misc/spamcalc/Makefile
@@ -14,7 +14,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= logix@foobar.franken.de
COMMENT= Calculates "DNS-spam"-values for hostnames
-USE_PERL5= YES
+USES= perl5
do-build:
${REINPLACE_CMD} -e "s,sc.conf,${PREFIX}/etc/spamcalc.conf," \
diff --git a/x11-toolkits/gnome-desktop-sharp20/Makefile b/x11-toolkits/gnome-desktop-sharp20/Makefile
index b05e94340b05..0cb6c9c60f79 100644
--- a/x11-toolkits/gnome-desktop-sharp20/Makefile
+++ b/x11-toolkits/gnome-desktop-sharp20/Makefile
@@ -18,7 +18,8 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_GNOME= gnomehack gnomepanel gtkhtml3 gtksharp20 gnomesharp20 librsvg2 vte \
libgnomeprintui gtksourceview2 gnomepanel libwnck nautiluscdburner
diff --git a/x11-toolkits/gnome-sharp20/Makefile b/x11-toolkits/gnome-sharp20/Makefile
index a4f02a184500..bd771dcd556d 100644
--- a/x11-toolkits/gnome-sharp20/Makefile
+++ b/x11-toolkits/gnome-sharp20/Makefile
@@ -19,7 +19,8 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_GNOME= gnomehack gnomepanel gtksharp20 librsvg2 vte libgnomeprintui \
libgnomeui
MAKE_JOBS_UNSAFE= yes
diff --git a/x11-toolkits/gtk-sharp10/Makefile b/x11-toolkits/gtk-sharp10/Makefile
index b3225311c9f5..b6cdf2ac1524 100644
--- a/x11-toolkits/gtk-sharp10/Makefile
+++ b/x11-toolkits/gtk-sharp10/Makefile
@@ -22,7 +22,8 @@ LATEST_LINK= gtk-sharp10
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_GNOME= gnomehack gtkhtml3 vte librsvg2 libgnomecanvas \
libgnomeprintui libglade2 libgnomeui
diff --git a/x11-toolkits/gtk-sharp20/Makefile b/x11-toolkits/gtk-sharp20/Makefile
index 9e2f8b5f9589..cd4e84af9e47 100644
--- a/x11-toolkits/gtk-sharp20/Makefile
+++ b/x11-toolkits/gtk-sharp20/Makefile
@@ -24,7 +24,8 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_GNOME= gnomehack gtk20 libglade2
post-patch:
diff --git a/x11-toolkits/p5-Gtk2-Chmod/Makefile b/x11-toolkits/p5-Gtk2-Chmod/Makefile
index fa2be17ea8d3..5970ab1e2e5a 100644
--- a/x11-toolkits/p5-Gtk2-Chmod/Makefile
+++ b/x11-toolkits/p5-Gtk2-Chmod/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-File-Stat-Bits>=0:${PORTSDIR}/sysutils/p5-File-Stat-Bits \
p5-Gtk2>=1.060:${PORTSDIR}/x11-toolkits/p5-Gtk2
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Gtk2::Chmod.3
diff --git a/x11-toolkits/p5-Gtk2-Ex-Dialogs/Makefile b/x11-toolkits/p5-Gtk2-Ex-Dialogs/Makefile
index ef44991253a7..9474061f0ea0 100644
--- a/x11-toolkits/p5-Gtk2-Ex-Dialogs/Makefile
+++ b/x11-toolkits/p5-Gtk2-Ex-Dialogs/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-File-Type>=0:${PORTSDIR}/devel/p5-File-Type \
p5-Gtk2-Ex-Utils>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2-Ex-Utils
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Gtk2::Ex::Dialogs::Question.3 \
Gtk2::Ex::Dialogs::ChooseDirectory.3 \
Gtk2::Ex::Dialogs::Message.3 \
diff --git a/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile b/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile
index 67b69de0bae6..d4337b729313 100644
--- a/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile
+++ b/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-Glib2>=1.00:${PORTSDIR}/devel/p5-Glib2 \
RUN_DEPENDS= p5-Glib2>=1.00:${PORTSDIR}/devel/p5-Glib2 \
p5-Gtk2>=1.060:${PORTSDIR}/x11-toolkits/p5-Gtk2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Gtk2::Ex::Constants.3 \
Gtk2::Ex::Utils.3
diff --git a/x11-toolkits/p5-Gtk2-GladeXML/Makefile b/x11-toolkits/p5-Gtk2-GladeXML/Makefile
index 3a6a2d39f0b8..11df941c96ff 100644
--- a/x11-toolkits/p5-Gtk2-GladeXML/Makefile
+++ b/x11-toolkits/p5-Gtk2-GladeXML/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= p5-Glib2>=1.00:${PORTSDIR}/devel/p5-Glib2 \
USE_GNOME= libglade2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ${PORTNAME:S/-/::/g}.3
.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Gtk2-PathButtonBar/Makefile b/x11-toolkits/p5-Gtk2-PathButtonBar/Makefile
index fac81a382fe8..36ec8af911c0 100644
--- a/x11-toolkits/p5-Gtk2-PathButtonBar/Makefile
+++ b/x11-toolkits/p5-Gtk2-PathButtonBar/Makefile
@@ -18,7 +18,8 @@ COMMENT= Creates a bar for path manipulation
RUN_DEPENDS= p5-Gtk2>=1.060:${PORTSDIR}/x11-toolkits/p5-Gtk2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Gtk2::PathButtonBar.3
diff --git a/x11-toolkits/p5-Gtk2/Makefile b/x11-toolkits/p5-Gtk2/Makefile
index d147cc7bc95e..d23855c5dc91 100644
--- a/x11-toolkits/p5-Gtk2/Makefile
+++ b/x11-toolkits/p5-Gtk2/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS= p5-Pango>=0:${PORTSDIR}/x11-toolkits/p5-Pango \
p5-Glib2>=0:${PORTSDIR}/devel/p5-Glib2
USE_GNOME= gtk20 pango
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_GMAKE= yes
CONFIGURE_ENV+= FORCE_GMAKE=yes
MAKE_ENV+= LANG=C
diff --git a/x11-toolkits/p5-Pango/Makefile b/x11-toolkits/p5-Pango/Makefile
index 798ff3829828..9133a729d3f7 100644
--- a/x11-toolkits/p5-Pango/Makefile
+++ b/x11-toolkits/p5-Pango/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-ExtUtils-Depends>=0.300:${PORTSDIR}/devel/p5-ExtUtils-Depends
RUN_DEPENDS= p5-Glib2>=1.220:${PORTSDIR}/devel/p5-Glib2
USE_GNOME= pango
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAKE_JOBS_UNSAFE=yes
post-install:
diff --git a/x11-toolkits/p5-Tk-FileDialog/Makefile b/x11-toolkits/p5-Tk-FileDialog/Makefile
index 45bad5e42ba3..9c02cdeb18c1 100644
--- a/x11-toolkits/p5-Tk-FileDialog/Makefile
+++ b/x11-toolkits/p5-Tk-FileDialog/Makefile
@@ -16,7 +16,8 @@ COMMENT= Tk::FileDialog - A file selector dialog for perl/Tk
BUILD_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tk::FileDialog.3
PLIST_SUB= PERL_VERSION=${PERL_VERSION}
diff --git a/x11-toolkits/p5-Tk-FontDialog/Makefile b/x11-toolkits/p5-Tk-FontDialog/Makefile
index a22c1bd3991f..280e5bc303df 100644
--- a/x11-toolkits/p5-Tk-FontDialog/Makefile
+++ b/x11-toolkits/p5-Tk-FontDialog/Makefile
@@ -18,7 +18,8 @@ COMMENT= Font dialog widget
BUILD_DEPENDS= p5-Tk>=804:${PORTSDIR}/x11-toolkits/p5-Tk
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ${PORTNAME:S/-/::/g}.3
.include <bsd.port.mk>