aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/rubygem-datamapper/Makefile15
-rw-r--r--databases/rubygem-dm-aggregates/Makefile3
-rw-r--r--databases/rubygem-dm-constraints/Makefile3
-rw-r--r--databases/rubygem-dm-core/Makefile3
-rw-r--r--databases/rubygem-dm-migrations/Makefile3
-rw-r--r--databases/rubygem-dm-serializer/Makefile5
-rw-r--r--databases/rubygem-dm-timestamps/Makefile3
-rw-r--r--databases/rubygem-dm-transactions/Makefile3
-rw-r--r--databases/rubygem-dm-types/Makefile5
-rw-r--r--databases/rubygem-dm-validations/Makefile3
-rw-r--r--devel/rubygem-grit/Makefile3
-rw-r--r--devel/rubygem-hoe/Makefile3
-rw-r--r--devel/rubygem-main/Makefile5
-rw-r--r--devel/rubygem-newgem/Makefile7
-rw-r--r--devel/rubygem-ruport/Makefile3
-rw-r--r--devel/rubygem-uuid/Makefile3
-rw-r--r--net/rubygem-twitter/Makefile5
-rw-r--r--sysutils/rubygem-capistrano/Makefile3
18 files changed, 48 insertions, 30 deletions
diff --git a/databases/rubygem-datamapper/Makefile b/databases/rubygem-datamapper/Makefile
index 1f458d509971..9381e6d9b31b 100644
--- a/databases/rubygem-datamapper/Makefile
+++ b/databases/rubygem-datamapper/Makefile
@@ -7,19 +7,20 @@
PORTNAME= datamapper
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Fast, thread-safe, object-relational mapper
-RUN_DEPENDS= rubygem-dm-aggregates>=1.0.1:${PORTSDIR}/databases/rubygem-dm-aggregates \
- rubygem-dm-constraints>=1.0.1:${PORTSDIR}/databases/rubygem-dm-constraints \
- rubygem-dm-transactions>=1.0.1:${PORTSDIR}/databases/rubygem-dm-transactions \
- rubygem-dm-serializer>=1.0.1:${PORTSDIR}/databases/rubygem-dm-serializer \
- rubygem-dm-timestamps>=1.0.1:${PORTSDIR}/databases/rubygem-dm-timestamps \
- rubygem-dm-validations>=1.0.1:${PORTSDIR}/databases/rubygem-dm-validations \
- rubygem-dm-types>=1.0.1:${PORTSDIR}/databases/rubygem-dm-types
+RUN_DEPENDS= rubygem-dm-aggregates>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-aggregates \
+ rubygem-dm-constraints>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-constraints \
+ rubygem-dm-transactions>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-transactions \
+ rubygem-dm-serializer>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-serializer \
+ rubygem-dm-timestamps>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-timestamps \
+ rubygem-dm-validations>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-validations \
+ rubygem-dm-types>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-types
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-aggregates/Makefile b/databases/rubygem-dm-aggregates/Makefile
index 61d2871a6459..f3aa55c269a3 100644
--- a/databases/rubygem-dm-aggregates/Makefile
+++ b/databases/rubygem-dm-aggregates/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-aggregates
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin providing support for aggregates
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-constraints/Makefile b/databases/rubygem-dm-constraints/Makefile
index 2c0e7179e9b8..0df1a869b4bb 100644
--- a/databases/rubygem-dm-constraints/Makefile
+++ b/databases/rubygem-dm-constraints/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-constraints
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin constraining relationships
-RUN_DEPENDS= rubygem-dm-migrations>=1.0.1:${PORTSDIR}/databases/rubygem-dm-migrations
+RUN_DEPENDS= rubygem-dm-migrations>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-migrations
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-core/Makefile b/databases/rubygem-dm-core/Makefile
index 7b0268685799..1b5e96765385 100644
--- a/databases/rubygem-dm-core/Makefile
+++ b/databases/rubygem-dm-core/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dm-core
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
@@ -14,7 +15,7 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= An Object/Relational Mapper for Ruby
RUN_DEPENDS= rubygem-extlib>=0.9.15:${PORTSDIR}/devel/rubygem-extlib \
- rubygem-addressable>=2.1:${PORTSDIR}/www/rubygem-addressable
+ rubygem-addressable>=2.2:${PORTSDIR}/www/rubygem-addressable
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-migrations/Makefile b/databases/rubygem-dm-migrations/Makefile
index 3836e10ac1dc..a6cb3fa0dcd4 100644
--- a/databases/rubygem-dm-migrations/Makefile
+++ b/databases/rubygem-dm-migrations/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-migrations
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin for writing and speccing migrations
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-serializer/Makefile b/databases/rubygem-dm-serializer/Makefile
index c71eae3bc4f1..09e4585f24b2 100644
--- a/databases/rubygem-dm-serializer/Makefile
+++ b/databases/rubygem-dm-serializer/Makefile
@@ -7,14 +7,15 @@
PORTNAME= dm-serializer
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin for serializing Resources and Collections
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core \
- rubygem-json_pure>=1.4.3:${PORTSDIR}/devel/rubygem-json_pure \
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core \
+ rubygem-json_pure>=1.4:${PORTSDIR}/devel/rubygem-json_pure \
rubygem-fastercsv>=1.5.3:${PORTSDIR}/devel/rubygem-fastercsv
USE_RUBY= yes
diff --git a/databases/rubygem-dm-timestamps/Makefile b/databases/rubygem-dm-timestamps/Makefile
index 013bb66f786f..a802b2ae4b20 100644
--- a/databases/rubygem-dm-timestamps/Makefile
+++ b/databases/rubygem-dm-timestamps/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-timestamps
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin for magical timestamps
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-transactions/Makefile b/databases/rubygem-dm-transactions/Makefile
index e3f5b69532b9..e3d95a7316fa 100644
--- a/databases/rubygem-dm-transactions/Makefile
+++ b/databases/rubygem-dm-transactions/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-transactions
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Makes transaction support available for adapters that support them
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/databases/rubygem-dm-types/Makefile b/databases/rubygem-dm-types/Makefile
index 421409c6f713..4edc09b6b4da 100644
--- a/databases/rubygem-dm-types/Makefile
+++ b/databases/rubygem-dm-types/Makefile
@@ -7,16 +7,17 @@
PORTNAME= dm-types
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= DataMapper plugin providing extra data types
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core \
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core \
rubygem-stringex>=1.1.0:${PORTSDIR}/devel/rubygem-stringex \
rubygem-uuidtools>=2.1.1:${PORTSDIR}/devel/rubygem-uuidtools \
- rubygem-json_pure>=1.4.3:${PORTSDIR}/devel/rubygem-json_pure \
+ rubygem-json_pure>=1.4:${PORTSDIR}/devel/rubygem-json_pure \
rubygem-fastercsv>=1.5.3:${PORTSDIR}/devel/rubygem-fastercsv
USE_RUBY= yes
diff --git a/databases/rubygem-dm-validations/Makefile b/databases/rubygem-dm-validations/Makefile
index 348dadbfee36..a3d8a8545b39 100644
--- a/databases/rubygem-dm-validations/Makefile
+++ b/databases/rubygem-dm-validations/Makefile
@@ -7,13 +7,14 @@
PORTNAME= dm-validations
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= databases rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Library for performing validations on DM models and pure Ruby object
-RUN_DEPENDS= rubygem-dm-core>=1.0.1:${PORTSDIR}/databases/rubygem-dm-core
+RUN_DEPENDS= rubygem-dm-core>=${PORTVERSION}:${PORTSDIR}/databases/rubygem-dm-core
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/devel/rubygem-grit/Makefile b/devel/rubygem-grit/Makefile
index b7e7a9fe16cb..3e6b857a370a 100644
--- a/devel/rubygem-grit/Makefile
+++ b/devel/rubygem-grit/Makefile
@@ -6,13 +6,14 @@
PORTNAME= grit
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= An object-oriented ruby library to access git repositories
-RUN_DEPENDS= rubygem-diff-lcs>=1.1.2:${PORTSDIR}/textproc/rubygem-diff-lcs \
+RUN_DEPENDS= rubygem-diff-lcs>=1.1:${PORTSDIR}/textproc/rubygem-diff-lcs \
rubygem-mime-types>=1.15:${PORTSDIR}/misc/rubygem-mime-types
USE_RUBY= yes
diff --git a/devel/rubygem-hoe/Makefile b/devel/rubygem-hoe/Makefile
index ba65866ed3fc..d32e397e6e73 100644
--- a/devel/rubygem-hoe/Makefile
+++ b/devel/rubygem-hoe/Makefile
@@ -6,13 +6,14 @@
PORTNAME= hoe
PORTVERSION= 2.6.2
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= A simple rake/rubygems helper for project Rakefiles
-RUN_DEPENDS= rubygem-rubyforge>=1.3.1:${PORTSDIR}/devel/rubygem-rubyforge
+RUN_DEPENDS= rubygem-rubyforge>=2.0.4:${PORTSDIR}/devel/rubygem-rubyforge
USE_RUBY= yes
USE_RAKE= yes
diff --git a/devel/rubygem-main/Makefile b/devel/rubygem-main/Makefile
index 03ae15b992e0..e23baac684a5 100644
--- a/devel/rubygem-main/Makefile
+++ b/devel/rubygem-main/Makefile
@@ -7,14 +7,15 @@
PORTNAME= main
PORTVERSION= 4.2.0
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Class Factory and Dsl for Generating Command Line Programs
-RUN_DEPENDS= rubygem-fattr>=1.0.3:${PORTSDIR}/devel/rubygem-fattr \
- rubygem-arrayfields>=4.5.0:${PORTSDIR}/devel/rubygem-arrayfields
+RUN_DEPENDS= rubygem-fattr>=2.1.0:${PORTSDIR}/devel/rubygem-fattr \
+ rubygem-arrayfields>=4.7.4:${PORTSDIR}/devel/rubygem-arrayfields
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/devel/rubygem-newgem/Makefile b/devel/rubygem-newgem/Makefile
index 4c3dd1c4a641..dd905e979783 100644
--- a/devel/rubygem-newgem/Makefile
+++ b/devel/rubygem-newgem/Makefile
@@ -7,15 +7,16 @@
PORTNAME= newgem
PORTVERSION= 1.5.3
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= Bundle ruby libraries into gems
-RUN_DEPENDS= rubygem-activesupport>=2.0.2:${PORTSDIR}/devel/rubygem-activesupport \
- rubygem-rubigen>=1.5.1:${PORTSDIR}/devel/rubygem-rubigen \
- rubygem-hoe>=1.8.0:${PORTSDIR}/devel/rubygem-hoe \
+RUN_DEPENDS= rubygem-activesupport>=2.3.4:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-rubigen>=1.5.3:${PORTSDIR}/devel/rubygem-rubigen \
+ rubygem-hoe>=2.4.0:${PORTSDIR}/devel/rubygem-hoe \
rubygem-redcloth>=4.0.0:${PORTSDIR}/www/rubygem-redcloth \
rubygem-syntax>=1.0.0:${PORTSDIR}/textproc/rubygem-syntax \
rubygem-rubigen>=1.5.3:${PORTSDIR}/devel/rubygem-rubigen
diff --git a/devel/rubygem-ruport/Makefile b/devel/rubygem-ruport/Makefile
index 1c9335372cee..d81989d6ae4e 100644
--- a/devel/rubygem-ruport/Makefile
+++ b/devel/rubygem-ruport/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ruport
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
@@ -14,7 +15,7 @@ MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby Reports (Ruport) is an extensible reporting system.
RUN_DEPENDS= rubygem-transactionsimple>=1.4.0:${PORTSDIR}/devel/rubygem-transactionsimple \
- rubygem-fastercsv>=1.1.0:${PORTSDIR}/devel/rubygem-fastercsv \
+ rubygem-fastercsv>=0:${PORTSDIR}/devel/rubygem-fastercsv \
rubygem-pdfwriter>=1.1.3:${PORTSDIR}/print/rubygem-pdfwriter
USE_RUBY= yes
diff --git a/devel/rubygem-uuid/Makefile b/devel/rubygem-uuid/Makefile
index 3952b4d4c3d9..f856d57e5d74 100644
--- a/devel/rubygem-uuid/Makefile
+++ b/devel/rubygem-uuid/Makefile
@@ -7,13 +7,14 @@
PORTNAME= uuid
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= devel rubygems
MASTER_SITES= RG
MAINTAINER= ruby@FreeBSD.org
COMMENT= UUID Generator for Ruby
-RUN_DEPENDS= rubygem-macaddr>=1.0.0:${PORTSDIR}/net/rubygem-macaddr
+RUN_DEPENDS= rubygem-macaddr>=1.0:${PORTSDIR}/net/rubygem-macaddr
PLIST_FILES+= bin/uuid
diff --git a/net/rubygem-twitter/Makefile b/net/rubygem-twitter/Makefile
index 1299f44cf3a2..8fcd8080f645 100644
--- a/net/rubygem-twitter/Makefile
+++ b/net/rubygem-twitter/Makefile
@@ -8,6 +8,7 @@
PORTNAME= twitter
PORTVERSION= 0.7.0
+PORTREVISION= 1
CATEGORIES= net rubygems
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pgollucci
@@ -15,9 +16,9 @@ MASTER_SITE_SUBDIR= pgollucci
MAINTAINER= ruby@FreeBSD.org
COMMENT= Command line twits and an API wrapper
-RUN_DEPENDS= rubygem-oauth>=0.3.4:${PORTSDIR}/net/rubygem-oauth \
+RUN_DEPENDS= rubygem-oauth>=0.4.1:${PORTSDIR}/net/rubygem-oauth \
rubygem-mash>=0.0.3:${PORTSDIR}/devel/rubygem-mash \
- rubygem-httparty>=0.4.3:${PORTSDIR}/www/rubygem-httparty \
+ rubygem-httparty>=0.5.0:${PORTSDIR}/www/rubygem-httparty \
rubygem-hoe>=0.12.2:${PORTSDIR}/devel/rubygem-hoe
USE_RUBY= yes
diff --git a/sysutils/rubygem-capistrano/Makefile b/sysutils/rubygem-capistrano/Makefile
index e940a69e00a9..956db9a537d3 100644
--- a/sysutils/rubygem-capistrano/Makefile
+++ b/sysutils/rubygem-capistrano/Makefile
@@ -7,6 +7,7 @@
PORTNAME= capistrano
PORTVERSION= 2.5.19
+PORTREVISION= 1
CATEGORIES= sysutils rubygems
MASTER_SITES= RG
@@ -16,7 +17,7 @@ COMMENT= A utility for executing commands in parallel on multiple machines
RUN_DEPENDS= rubygem-net-ssh-gateway>=1.0.0:${PORTSDIR}/security/rubygem-net-ssh-gateway \
rubygem-net-sftp>=2.0.0:${PORTSDIR}/security/rubygem-net-sftp \
rubygem-net-scp>=1.0.0:${PORTSDIR}/security/rubygem-net-scp \
- rubygem-highline>=1.4.0:${PORTSDIR}/devel/rubygem-highline \
+ rubygem-highline>=0:${PORTSDIR}/devel/rubygem-highline \
rubygem-echoe>0:${PORTSDIR}/devel/rubygem-echoe
USE_RUBY= yes