aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/rackmonkey/Makefile2
-rw-r--r--net-mgmt/rackmonkey/files/patch-perl_rackmonkey.pl11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/rackmonkey/Makefile b/net-mgmt/rackmonkey/Makefile
index fd84bc3271ea..2ade8525e96d 100644
--- a/net-mgmt/rackmonkey/Makefile
+++ b/net-mgmt/rackmonkey/Makefile
@@ -5,7 +5,7 @@ PORTNAME= rackmonkey
PORTVERSION= 1.2.5
PORTREVISION= 1
DISTVERSIONSUFFIX= -1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-mgmt www
MASTER_SITES= SF \
ftp://ftp.secure-computing.net/pub/FreeBSD/ports/${PORTNAME}/ \
diff --git a/net-mgmt/rackmonkey/files/patch-perl_rackmonkey.pl b/net-mgmt/rackmonkey/files/patch-perl_rackmonkey.pl
new file mode 100644
index 000000000000..3d77d1241b67
--- /dev/null
+++ b/net-mgmt/rackmonkey/files/patch-perl_rackmonkey.pl
@@ -0,0 +1,11 @@
+--- perl/rackmonkey.pl.orig 2018-05-13 19:00:11 UTC
++++ perl/rackmonkey.pl
+@@ -28,6 +28,8 @@ use 5.006_001;
+ use HTML::Template;
+ use HTML::Entities;
+ use Time::Local;
++use FindBin;
++use lib "$FindBin::Bin/";
+
+ use RackMonkey::CGI;
+ use RackMonkey::Engine;