aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/Makefile1
-rw-r--r--audio/libadplug/Makefile42
-rw-r--r--audio/libadplug/distinfo2
-rw-r--r--audio/libadplug/files/patch-adplugdb_adplugdb.cpp27
-rw-r--r--audio/libadplug/pkg-descr15
-rw-r--r--audio/libadplug/pkg-plist54
6 files changed, 141 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 983222e9f429..8cc4390c37be 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -226,6 +226,7 @@
SUBDIR += ladspa
SUBDIR += lame
SUBDIR += liba52
+ SUBDIR += libadplug
SUBDIR += libao
SUBDIR += libaudiofile
SUBDIR += libcdaudio
diff --git a/audio/libadplug/Makefile b/audio/libadplug/Makefile
new file mode 100644
index 000000000000..a33cbac21f84
--- /dev/null
+++ b/audio/libadplug/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: adplug
+# Date created: 10 August 2004
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libadplug
+PORTVERSION= 1.5
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= adplug
+DISTNAME= adplug-${PORTVERSION}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= AdLib emulator library supporting many formats
+
+LIB_DEPENDS= binio.1:${PORTSDIR}/devel/libbinio
+
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS} ${CPPFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+MAN1= adplugdb.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(SUBDIRS\ =\).*|\1 src adplugdb test|' \
+ ${WRKSRC}/Makefile.in
+
+post-install:
+ ${MKDIR} ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/adplugdb.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/audio/libadplug/distinfo b/audio/libadplug/distinfo
new file mode 100644
index 000000000000..97328fdde973
--- /dev/null
+++ b/audio/libadplug/distinfo
@@ -0,0 +1,2 @@
+MD5 (adplug-1.5.tar.gz) = b93a162bc5cfb1493d2affdfed18e9a1
+SIZE (adplug-1.5.tar.gz) = 962345
diff --git a/audio/libadplug/files/patch-adplugdb_adplugdb.cpp b/audio/libadplug/files/patch-adplugdb_adplugdb.cpp
new file mode 100644
index 000000000000..e95968907f4a
--- /dev/null
+++ b/audio/libadplug/files/patch-adplugdb_adplugdb.cpp
@@ -0,0 +1,27 @@
+--- adplugdb/adplugdb.cpp.orig Sun Aug 8 21:17:40 2004
++++ adplugdb/adplugdb.cpp Sat May 7 06:16:26 2005
+@@ -29,6 +29,7 @@
+ #include <binfile.h>
+ #include <string>
+ #include <iostream>
++#include <unistd.h>
+
+ #if defined(HAVE_SYS_TYPES_H) && defined(HAVE_SYS_STAT_H)
+ # if HAVE_SYS_TYPES_H
+@@ -46,16 +47,6 @@
+ #include "../src/adplug.h"
+ #include "../src/silentopl.h"
+ #include "../src/database.h"
+-
+-/*
+- * Apple (OS X) and Sun systems declare getopt in unistd.h, other systems
+- * (Linux) use getopt.h.
+- */
+-#if defined ( __APPLE__ ) || ( defined (__SVR4) && defined (__sun) )
+-# include <unistd.h>
+-#else
+-# include "getopt.h"
+-#endif
+
+ /***** Defines *****/
+
diff --git a/audio/libadplug/pkg-descr b/audio/libadplug/pkg-descr
new file mode 100644
index 000000000000..2320ff36a8e3
--- /dev/null
+++ b/audio/libadplug/pkg-descr
@@ -0,0 +1,15 @@
+AdPlug is a free, cross-platform, hardware independent AdLib sound player
+library, mainly written in C++ and released under the LGPL. AdPlug plays
+sound data, originally created for the AdLib (OPL2) audio board, directly
+from its original format on top of an OPL2 emulator or by using the real
+hardware. No OPL chip is required for playback.
+
+AdPlug itself is just the backend to many different audio player frontends,
+which are also being developed here. There are plugins for popular audio
+players, like Winamp and XMMS, as well as stand-alone players for many
+different systems available.
+
+WWW: http://adplug.sourceforge.net/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/audio/libadplug/pkg-plist b/audio/libadplug/pkg-plist
new file mode 100644
index 000000000000..1f3afc358ed7
--- /dev/null
+++ b/audio/libadplug/pkg-plist
@@ -0,0 +1,54 @@
+bin/adplugdb
+include/adplug/a2m.h
+include/adplug/adlibemu.h
+include/adplug/adplug.h
+include/adplug/adtrack.h
+include/adplug/amd.h
+include/adplug/bam.h
+include/adplug/bmf.h
+include/adplug/cff.h
+include/adplug/d00.h
+include/adplug/database.h
+include/adplug/dfm.h
+include/adplug/diskopl.h
+include/adplug/dmo.h
+include/adplug/dro.h
+include/adplug/dtm.h
+include/adplug/emuopl.h
+include/adplug/flash.h
+include/adplug/fmc.h
+include/adplug/fmopl.h
+include/adplug/fprovide.h
+include/adplug/hsc.h
+include/adplug/hsp.h
+include/adplug/hybrid.h
+include/adplug/hyp.h
+include/adplug/imf.h
+include/adplug/kemuopl.h
+include/adplug/ksm.h
+include/adplug/lds.h
+include/adplug/mad.h
+include/adplug/mid.h
+include/adplug/mkj.h
+include/adplug/mtk.h
+include/adplug/opl.h
+include/adplug/player.h
+include/adplug/players.h
+include/adplug/protrack.h
+include/adplug/psi.h
+include/adplug/rad.h
+include/adplug/rat.h
+include/adplug/raw.h
+include/adplug/rol.h
+include/adplug/s3m.h
+include/adplug/sa2.h
+include/adplug/silentopl.h
+include/adplug/sng.h
+include/adplug/u6m.h
+include/adplug/xad.h
+include/adplug/xsm.h
+lib/libadplug-1.5.so
+lib/libadplug-1.5.so.0
+lib/libadplug.a
+lib/libadplug.so
+@dirrm include/adplug