aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/scotty3/Makefile2
-rw-r--r--net-mgmt/scotty3/files/patch-af20
-rw-r--r--net/scotty3/Makefile2
-rw-r--r--net/scotty3/files/patch-af20
4 files changed, 42 insertions, 2 deletions
diff --git a/net-mgmt/scotty3/Makefile b/net-mgmt/scotty3/Makefile
index f4490397fa7c..c778429d107b 100644
--- a/net-mgmt/scotty3/Makefile
+++ b/net-mgmt/scotty3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scotty
PORTVERSION= 20000221
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net tcl84 tk84
MASTER_SITES= ftp://ftp.ibr.cs.tu-bs.de/pub/local/tkined/devel/
DISTNAME= ${PORTNAME}-00-02-21
diff --git a/net-mgmt/scotty3/files/patch-af b/net-mgmt/scotty3/files/patch-af
new file mode 100644
index 000000000000..19ba69fd4144
--- /dev/null
+++ b/net-mgmt/scotty3/files/patch-af
@@ -0,0 +1,20 @@
+--- ../tnm/generic/tnmInt.h.orig Tue Sep 21 14:17:18 1999
++++ ../tnm/generic/tnmInt.h Tue Dec 9 00:06:26 2003
+@@ -54,11 +54,16 @@
+ */
+
+ #define TnmGetTime TclpGetTime
++#if TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 4
++#define TnmCreateDirectory(p) mkdir (p, 0777)
++#define TnmStat stat
++#else
+ #define TnmCreateDirectory TclpCreateDirectory
+-#if TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 8 && TCL_RELEASE_SERIAL > 2
++#if TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 3 && TCL_RELEASE_SERIAL > 2
+ #define TnmStat TclStat
+ #else
+ #define TnmStat stat
++#endif
+ #endif
+
+ EXTERN void
diff --git a/net/scotty3/Makefile b/net/scotty3/Makefile
index f4490397fa7c..c778429d107b 100644
--- a/net/scotty3/Makefile
+++ b/net/scotty3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scotty
PORTVERSION= 20000221
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net tcl84 tk84
MASTER_SITES= ftp://ftp.ibr.cs.tu-bs.de/pub/local/tkined/devel/
DISTNAME= ${PORTNAME}-00-02-21
diff --git a/net/scotty3/files/patch-af b/net/scotty3/files/patch-af
new file mode 100644
index 000000000000..19ba69fd4144
--- /dev/null
+++ b/net/scotty3/files/patch-af
@@ -0,0 +1,20 @@
+--- ../tnm/generic/tnmInt.h.orig Tue Sep 21 14:17:18 1999
++++ ../tnm/generic/tnmInt.h Tue Dec 9 00:06:26 2003
+@@ -54,11 +54,16 @@
+ */
+
+ #define TnmGetTime TclpGetTime
++#if TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 4
++#define TnmCreateDirectory(p) mkdir (p, 0777)
++#define TnmStat stat
++#else
+ #define TnmCreateDirectory TclpCreateDirectory
+-#if TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 8 && TCL_RELEASE_SERIAL > 2
++#if TCL_MAJOR_VERSION == 8 && TCL_MINOR_VERSION == 3 && TCL_RELEASE_SERIAL > 2
+ #define TnmStat TclStat
+ #else
+ #define TnmStat stat
++#endif
+ #endif
+
+ EXTERN void