aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/zephyr/Makefile48
-rw-r--r--net-im/zephyr/distinfo3
-rw-r--r--net-im/zephyr/files/patch-configure45
-rw-r--r--net-im/zephyr/files/patch-zwgc-main.c26
-rw-r--r--net-im/zephyr/files/zhm.in37
-rw-r--r--net-im/zephyr/pkg-descr6
-rw-r--r--net-im/zephyr/pkg-plist26
8 files changed, 192 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 0b1775abfc3d..1eaf60beea6b 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -182,5 +182,6 @@
SUBDIR += wooztalk
SUBDIR += xfce4-messenger-plugin
SUBDIR += ysm
+ SUBDIR += zephyr
.include <bsd.port.subdir.mk>
diff --git a/net-im/zephyr/Makefile b/net-im/zephyr/Makefile
new file mode 100644
index 000000000000..45a5e8315f8f
--- /dev/null
+++ b/net-im/zephyr/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: zephyr
+# Date created: 2009-11-12
+# Whom: Ben Kaduk <kaduk@mit.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zephyr
+PORTVERSION= 3.0
+CATEGORIES= net-im
+MASTER_SITES= http://zephyr.1ts.org/export/2552/distribution/
+
+MAINTAINER= kaduk-fbsd@mit.edu
+COMMENT= An enterprise-scale distributed messaging system
+
+LICENSE= MIT
+
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+USE_RC_SUBR= zhm
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_ICONV= yes
+
+MAN1= zephyr.1 zaway.1 zctl.1 zleave.1 zlocate.1 znol.1 zwrite.1 zwgc.1
+MAN8= zhm.8 zephyrd.8 zstat.8 zshutdown_notify.8
+
+OPTIONS= HEIMDAL "Use Heimdal Kerberos for ss/com_err" no
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_HEIMDAL)
+LIB_DEPENDS+= ss.1:${PORTSDIR}/security/heimdal
+.if defined(HEIMDAL_HOME)
+KRB5_DIR?= ${HEIMDAL_HOME}
+.else
+KRB5_DIR?= ${LOCALBASE}
+.endif
+.else
+LIB_DEPENDS+= ss.2:${PORTSDIR}/devel/e2fsprogs-libss
+KRB5_DIR?= ${DESTDIR}/usr
+.endif
+
+# it is an upstream bug that --with-krb5 needs a path
+CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}"
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/net-im/zephyr/distinfo b/net-im/zephyr/distinfo
new file mode 100644
index 000000000000..5bac3db31c35
--- /dev/null
+++ b/net-im/zephyr/distinfo
@@ -0,0 +1,3 @@
+MD5 (zephyr-3.0.tar.gz) = 083824d15cbfbf12a03224a96a92bec3
+SHA256 (zephyr-3.0.tar.gz) = 8d09cd7a753ff8c8be9e5bd9db1a6a63c23171109ff2be6d876095d48cf5b6ff
+SIZE (zephyr-3.0.tar.gz) = 684678
diff --git a/net-im/zephyr/files/patch-configure b/net-im/zephyr/files/patch-configure
new file mode 100644
index 000000000000..ae2223688679
--- /dev/null
+++ b/net-im/zephyr/files/patch-configure
@@ -0,0 +1,45 @@
+--- configure.orig 2009-11-12 08:19:57.000000000 +0000
++++ configure 2009-11-12 08:32:53.000000000 +0000
+@@ -24651,15 +24651,15 @@
+ { echo "$as_me:$LINENO: result: $ac_cv_lib_resolv_res_send" >&5
+ echo "${ECHO_T}$ac_cv_lib_resolv_res_send" >&6; }
+ if test $ac_cv_lib_resolv_res_send = yes; then
+- LIBZEPHYR_LIBS="-lresolv $LIBZEPHYR_LIBS"
++ LIBZEPHYR_LIBS="-lc $LIBZEPHYR_LIBS"
+ else
+- { echo "$as_me:$LINENO: checking for __res_send in -lresolv" >&5
+-echo $ECHO_N "checking for __res_send in -lresolv... $ECHO_C" >&6; }
++ { echo "$as_me:$LINENO: checking for res_send in -lc" >&5
++echo $ECHO_N "checking for res_send in -lc... $ECHO_C" >&6; }
+ if test "${ac_cv_lib_resolv___res_send+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lresolv $LIBS"
++LIBS="-lc $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -24673,11 +24673,11 @@
+ #ifdef __cplusplus
+ extern "C"
+ #endif
+-char __res_send ();
++char res_send ();
+ int
+ main ()
+ {
+-return __res_send ();
++return res_send ();
+ ;
+ return 0;
+ }
+@@ -24715,7 +24715,7 @@
+ { echo "$as_me:$LINENO: result: $ac_cv_lib_resolv___res_send" >&5
+ echo "${ECHO_T}$ac_cv_lib_resolv___res_send" >&6; }
+ if test $ac_cv_lib_resolv___res_send = yes; then
+- LIBZEPHYR_LIBS="-lresolv $LIBZEPHYR_LIBS"
++ LIBZEPHYR_LIBS="$LIBZEPHYR_LIBS"
+ else
+ { { echo "$as_me:$LINENO: error: Zephyr requires libresolv along with Kerberos V." >&5
+ echo "$as_me: error: Zephyr requires libresolv along with Kerberos V." >&2;}
diff --git a/net-im/zephyr/files/patch-zwgc-main.c b/net-im/zephyr/files/patch-zwgc-main.c
new file mode 100644
index 000000000000..60286fe74de1
--- /dev/null
+++ b/net-im/zephyr/files/patch-zwgc-main.c
@@ -0,0 +1,26 @@
+--- zwgc/main.c.orig 2009-12-20 01:29:41.000000000 +0000
++++ zwgc/main.c 2009-12-20 01:32:34.000000000 +0000
+@@ -396,9 +396,8 @@
+ void
+ notice_handler(ZNotice_t *notice)
+ {
+-#ifndef HAVE_ARES
++ int error;
+ char node[MAXDNAME];
+-#endif
+
+ #if defined(CMU_ZWGCPLUS)
+ list_add_notice(notice);
+@@ -415,9 +414,11 @@
+ notice_callback, notice);
+
+ #else
+- getnameinfo((const struct sockaddr *)&(notice->z_sender_sockaddr),
++ error = getnameinfo((const struct sockaddr *)&(notice->z_sender_sockaddr),
+ sizeof(notice->z_sender_sockaddr),
+ node, sizeof(node), NULL, 0, 0);
++ if (error != 0)
++ snprintf(node, MAXDNAME, "?");
+
+ process_notice(notice, node);
+ #ifdef CMU_ZWGCPLUS
diff --git a/net-im/zephyr/files/zhm.in b/net-im/zephyr/files/zhm.in
new file mode 100644
index 000000000000..fd3755be0127
--- /dev/null
+++ b/net-im/zephyr/files/zhm.in
@@ -0,0 +1,37 @@
+#!/bin/sh
+#
+#
+# PROVIDE: zhm
+# REQUIRE: named
+
+. %%RC_SUBR%%
+
+name="zhm"
+rcvar="zhm_enable"
+start_cmd="zhm_start"
+stop_postcmd="zhm_postcmd"
+start_precmd="zhm_precmd"
+command="%%PREFIX%%/sbin/${name}"
+pidfile="/var/run/${name}.pid"
+
+load_rc_config "$name"
+eval "${rcvar}=\${${rcvar}:-'NO'}"
+
+zhm_zephyr_servers="${zhm_zephyr_servers:-}"
+
+zhm_precmd()
+{
+ mkdir -p $(dirname ${pidfile})
+}
+
+zhm_start()
+{
+ ${command} -f ${zhm_zephyr_servers}
+}
+
+zhm_postcmd()
+{
+ rm -f ${pidfile}
+}
+
+run_rc_command "$1"
diff --git a/net-im/zephyr/pkg-descr b/net-im/zephyr/pkg-descr
new file mode 100644
index 000000000000..f3766f344dee
--- /dev/null
+++ b/net-im/zephyr/pkg-descr
@@ -0,0 +1,6 @@
+This is an enterprise-class instant messaging/notification system.
+It was developed as part of MIT's Project Athena, and has a
+unique design that leads to the ability to develop a unique
+sense of community.
+
+WWW: http://zephyr.1ts.org/
diff --git a/net-im/zephyr/pkg-plist b/net-im/zephyr/pkg-plist
new file mode 100644
index 000000000000..5be28d831268
--- /dev/null
+++ b/net-im/zephyr/pkg-plist
@@ -0,0 +1,26 @@
+@unexec %D/etc/rc.d/zhm stop > /dev/null 2>&1 || true
+bin/zaway
+bin/zctl
+bin/zleave
+bin/zlocate
+bin/znol
+bin/zstat
+bin/zwrite
+bin/zwgc
+etc/zephyr/default.subscriptions
+include/zephyr/mit-copyright.h
+include/zephyr/zephyr.h
+include/zephyr/zephyr_err.h
+lib/libzephyr.a
+lib/libzephyr.so.4.0
+lib/libzephyr.la
+sbin/zshutdown_notify
+sbin/zephyrd
+sbin/zhm
+%%DATADIR%%/zwgc.desc
+%%DATADIR%%/zwgc_resources
+@exec mkdir -p %D/etc/zephyr/acl
+@dirrm etc/zephyr/acl
+@dirrm etc/zephyr
+@dirrm include/zephyr
+@dirrm %%DATADIR%%