aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/Makefile1
-rw-r--r--editors/deforaos-editor/Makefile23
-rw-r--r--editors/deforaos-editor/distinfo2
-rw-r--r--editors/deforaos-editor/pkg-descr3
-rw-r--r--editors/deforaos-editor/pkg-plist6
5 files changed, 35 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 0c00475b0620..3364cf24a107 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -47,6 +47,7 @@
SUBDIR += conglomerate
SUBDIR += cooledit
SUBDIR += cream
+ SUBDIR += deforaos-editor
SUBDIR += dhex
SUBDIR += diakonos
SUBDIR += dkns
diff --git a/editors/deforaos-editor/Makefile b/editors/deforaos-editor/Makefile
new file mode 100644
index 000000000000..e071c012e03a
--- /dev/null
+++ b/editors/deforaos-editor/Makefile
@@ -0,0 +1,23 @@
+# Created by: Olivier Cochard-Labbe <olivier@cochard.me>
+# $FreeBSD$
+
+PORTNAME= editor
+PORTVERSION= 0.2.1
+CATEGORIES= editors
+MASTER_SITES= http://www.defora.org/os/download/download/3702/
+DISTNAME= Editor-${PORTVERSION}
+PKGNAMEPREFIX= deforaos-
+
+MAINTAINER= olivier@cochard.me
+COMMENT= DeforaOS desktop text editor
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
+ Desktop:${PORTSDIR}/x11/deforaos-libdesktop
+
+USE_GNOME= gtk20 desktopfileutils
+USE_PKGCONFIG= build
+USE_GETTEXT= yes
+
+.include <bsd.port.mk>
diff --git a/editors/deforaos-editor/distinfo b/editors/deforaos-editor/distinfo
new file mode 100644
index 000000000000..313f95d0e58b
--- /dev/null
+++ b/editors/deforaos-editor/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Editor-0.2.1.tar.gz) = 901a63db4ed3d1a625e4fbd25e39267618c0ecb88095dffd06739f9f0d392000
+SIZE (Editor-0.2.1.tar.gz) = 27755
diff --git a/editors/deforaos-editor/pkg-descr b/editors/deforaos-editor/pkg-descr
new file mode 100644
index 000000000000..27dc15168935
--- /dev/null
+++ b/editors/deforaos-editor/pkg-descr
@@ -0,0 +1,3 @@
+DeforaOS desktop text editor
+
+WWW: http://www.defora.org/
diff --git a/editors/deforaos-editor/pkg-plist b/editors/deforaos-editor/pkg-plist
new file mode 100644
index 000000000000..85fb455f1f3f
--- /dev/null
+++ b/editors/deforaos-editor/pkg-plist
@@ -0,0 +1,6 @@
+bin/editor
+share/applications/editor.desktop
+share/locale/de/LC_MESSAGES/Editor.mo
+share/locale/es/LC_MESSAGES/Editor.mo
+share/locale/fr/LC_MESSAGES/Editor.mo
+share/locale/it/LC_MESSAGES/Editor.mo