aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/py-asyncssh/Makefile22
-rw-r--r--security/py-asyncssh/distinfo3
-rw-r--r--security/py-asyncssh/pkg-descr6
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d39ea182c613..53398653efd3 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -884,6 +884,7 @@
SUBDIR += py-acme
SUBDIR += py-acme-tiny
SUBDIR += py-artifacts
+ SUBDIR += py-asyncssh
SUBDIR += py-backports.ssl_match_hostname
SUBDIR += py-bcrypt
SUBDIR += py-borg.localrole
diff --git a/security/py-asyncssh/Makefile b/security/py-asyncssh/Makefile
new file mode 100644
index 000000000000..d7437fc39648
--- /dev/null
+++ b/security/py-asyncssh/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= asyncssh
+PORTVERSION= 1.12.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= bartosz@ixsystems.com
+COMMENT= Python asnycio SSH protocol library
+
+LICENSE= EPL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bcrypt>0:security/py-bcrypt@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${FLAVOR}
+
+USES= python:3.4+
+USE_PYTHON= autoplist concurrent distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-asyncssh/distinfo b/security/py-asyncssh/distinfo
new file mode 100644
index 000000000000..c986e62cb968
--- /dev/null
+++ b/security/py-asyncssh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1519265865
+SHA256 (asyncssh-1.12.0.tar.gz) = 183fb9fccf38f42f6d587c3068be8bcb04a83e51a036b0074a7370e7289d05d3
+SIZE (asyncssh-1.12.0.tar.gz) = 289549
diff --git a/security/py-asyncssh/pkg-descr b/security/py-asyncssh/pkg-descr
new file mode 100644
index 000000000000..141c332d87fe
--- /dev/null
+++ b/security/py-asyncssh/pkg-descr
@@ -0,0 +1,6 @@
+AsyncSSH is a Python package which provides an asynchronous client
+and server implementation of the SSHv2 protocol on top of
+the Python asyncio framework. It requires Python 3.4 or later
+and the Python cryptography library for some cryptographic functions.
+
+WWW: https://github.com/ronf/asyncssh