aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/meld/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/textproc/meld/Makefile b/textproc/meld/Makefile
index a62f10571ea6..11acc1169239 100644
--- a/textproc/meld/Makefile
+++ b/textproc/meld/Makefile
@@ -18,12 +18,15 @@ RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
USES= desktop-file-utils gettext python:3.4+ shared-mime-info \
shebangfix tar:xz
SHEBANG_FILES= bin/meld
-USE_PYTHON= distutils
+USE_PYTHON= distutils noflavors
USE_GNOME= gtksourceview3 intltool libxml2:build pygobject3
GLIB_SCHEMAS= org.gnome.meld.gschema.xml
-PYDISTUTILS_INSTALLNOSINGLE= yes
PYDISTUTILS_INSTALL_TARGET= --no-update-icon-cache --no-compile-schemas install
INSTALLS_ICONS= yes
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+PYDISTUTILS_INSTALLARGS= -c -O1 --prefix=${PREFIX} --root=${STAGEDIR}
+
+.include <bsd.port.post.mk>