aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-uopz/Makefile21
-rw-r--r--devel/pecl-uopz/distinfo2
-rw-r--r--devel/pecl-uopz/pkg-descr6
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index df9ad16bba98..f5ef4e2e944a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3343,6 +3343,7 @@
SUBDIR += pecl-statgrab
SUBDIR += pecl-svn
SUBDIR += pecl-test_helpers
+ SUBDIR += pecl-uopz
SUBDIR += pecl-uploadprogress
SUBDIR += pecl-uri_template
SUBDIR += pecl-uuid
diff --git a/devel/pecl-uopz/Makefile b/devel/pecl-uopz/Makefile
new file mode 100644
index 000000000000..b2d99891d283
--- /dev/null
+++ b/devel/pecl-uopz/Makefile
@@ -0,0 +1,21 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= uopz
+PORTVERSION= 2.0.1
+CATEGORIES= devel
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DIST_SUBDIR= PECL
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= User Operations for PHP Zend engine
+
+LICENSE= PHP301
+
+USE_PHP= yes
+USE_PHPEXT= yes
+USES= tar:tgz
+IGNORE_WITH_PHP= 53
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-uopz/distinfo b/devel/pecl-uopz/distinfo
new file mode 100644
index 000000000000..6f33327a2af1
--- /dev/null
+++ b/devel/pecl-uopz/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PECL/uopz-2.0.1.tgz) = 7c360fd988eef7a8dc10db2eec7c45d903b20513a991dc1ab4a4cd35cc5229c4
+SIZE (PECL/uopz-2.0.1.tgz) = 27184
diff --git a/devel/pecl-uopz/pkg-descr b/devel/pecl-uopz/pkg-descr
new file mode 100644
index 000000000000..5318a9aa10af
--- /dev/null
+++ b/devel/pecl-uopz/pkg-descr
@@ -0,0 +1,6 @@
+The uopz - User Operations for Zend
+extension exposes Zend Engine functionality normally used at compilation and
+execution time in order to allow modification of the internal structures that
+represent PHP code, and for user code to interact with the VM.
+
+WWW: http://pecl.php.net/package/uopz