aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/fxtv/Makefile33
-rw-r--r--multimedia/fxtv/files/patch-Makefile38
-rw-r--r--multimedia/fxtv/files/patch-ab11
-rw-r--r--multimedia/fxtv/pkg-descr7
-rw-r--r--multimedia/fxtv/pkg-plist1
5 files changed, 54 insertions, 36 deletions
diff --git a/multimedia/fxtv/Makefile b/multimedia/fxtv/Makefile
index 39bfd4b0566a..70e4c03e898c 100644
--- a/multimedia/fxtv/Makefile
+++ b/multimedia/fxtv/Makefile
@@ -5,40 +5,33 @@ PORTNAME= fxtv
PORTVERSION= 1.03
PORTREVISION= 11
CATEGORIES= multimedia
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= sanpei
+MASTER_SITES= LOCAL/sanpei
EXTRACT_SUFX= .tgz
MAINTAINER= sanpei@FreeBSD.org
-COMMENT= X-based TV Display and Capture Application (for use with bt848 driver)
+COMMENT= X11-based TV display and capture application (for use with bt848 driver)
-LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
- Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
+ONLY_FOR_ARCHS= i386 ia64 amd64
+LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
+ libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
+
+USES= gmake
MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= ice sm x11 xaw xext xmu xt xpm xxf86vm xxf86dga
-USE_GMAKE= yes
MAKE_FLAGS= -e
-MAN1= fxtv.1
-
-ONLY_FOR_ARCHS= alpha i386 ia64 amd64
OPTIONS_DEFINE= EXTRA
EXTRA_DESC= Extra programs required to record/playback/save
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
# This program does not actually require the programs below unless you
-# use audio/video recording and/or playback and save to a non-raw format.
-.if ${PORT_OPTIONS:MEXTRA}
-RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox \
- mpg123:${PORTSDIR}/audio/mpg123 \
- mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
- mplex:${PORTSDIR}/multimedia/mplex
-.endif
+# use audio/video recording and/or playback and save to a non-raw format.
+EXTRA_RUN_DEPENDS= sox:${PORTSDIR}/audio/sox \
+ mpg123:${PORTSDIR}/audio/mpg123 \
+ mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
+ mplex:${PORTSDIR}/multimedia/mplex
pre-install:
- ${CP} ${WRKSRC}/fxtv.1 ${WRKSRC}/fxtv.man
+ ${CP} -p ${WRKSRC}/fxtv.1 ${WRKSRC}/fxtv.man
.include <bsd.port.mk>
diff --git a/multimedia/fxtv/files/patch-Makefile b/multimedia/fxtv/files/patch-Makefile
new file mode 100644
index 000000000000..8bc059988fa7
--- /dev/null
+++ b/multimedia/fxtv/files/patch-Makefile
@@ -0,0 +1,38 @@
+--- Makefile.orig Tue Feb 13 09:08:59 2001
++++ Makefile Sat Mar 10 17:36:25 2001
+@@ -62,7 +62,7 @@ endif
+ ifneq ($(DEBUG),NO)
+ override CFLAGS = -DDEBUG -g
+ else
+- override CFLAGS = -DNDEBUG -O2
++ override CFLAGS += -DNDEBUG #-O2
+ endif
+ C_WARN_FLAG = -Wall
+ override CFLAGS += $(C_WARN_FLAG) $(INC) $(CF_VERS)
+@@ -116,15 +116,17 @@ $(VIDEOLIB_LIB) :
+ tv.o : tv.c app_rsrc.h
+
+ install : fxtv
+- mkdir -p $(FXTV_LIBDIR)/bitmaps
+- install -c -m 444 -o root $(PIXMAPS) $(FXTV_LIBDIR)/bitmaps
+- install -c -m 444 -o root README $(FXTV_LIBDIR)
+- mkdir -p $(X11BASEINST)/lib/X11/app-defaults
+- install -c -m 444 -o root Fxtv $(X11BASEINST)/lib/X11/app-defaults
+- mkdir -p $(X11BASEINST)/bin
+- install -c -m 444 -o root fxtv.1 $(X11BASEINST)/man/man1/fxtv.1
+- install -c -m 555 -o root fxtv $(X11BASEINST)/bin
+- install -c -m 555 -o root fxtv_cnvt.sh $(FXTV_LIBDIR)
++ mkdir -p $(DESTDIR)$(FXTV_LIBDIR)/bitmaps
++ install -c -m 444 -o root $(PIXMAPS) $(DESTDIR)$(FXTV_LIBDIR)/bitmaps
++ install -c -m 444 -o root README $(DESTDIR)$(FXTV_LIBDIR)
++ mkdir -p $(DESTDIR)$(X11BASEINST)/lib/X11/app-defaults
++ install -c -m 444 -o root Fxtv \
++ $(DESTDIR)$(X11BASEINST)/lib/X11/app-defaults
++ mkdir -p $(DESTDIR)$(X11BASEINST)/bin
++ install -c -m 444 -o root fxtv.1 \
++ $(DESTDIR)$(X11BASEINST)/man/man1/fxtv.1
++ install -c -m 555 -o root fxtv $(DESTDIR)$(X11BASEINST)/bin
++ install -c -m 555 -o root fxtv_cnvt.sh $(DESTDIR)$(FXTV_LIBDIR)
+
+ clean:
+ rm -f *.o fxtv *.core *~
diff --git a/multimedia/fxtv/files/patch-ab b/multimedia/fxtv/files/patch-ab
deleted file mode 100644
index e93539ed64f2..000000000000
--- a/multimedia/fxtv/files/patch-ab
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Tue Feb 13 09:08:59 2001
-+++ Makefile Sat Mar 10 17:36:25 2001
-@@ -62,7 +62,7 @@
- ifneq ($(DEBUG),NO)
- override CFLAGS = -DDEBUG -g
- else
-- override CFLAGS = -DNDEBUG -O2
-+ override CFLAGS += -DNDEBUG #-O2
- endif
- C_WARN_FLAG = -Wall
- override CFLAGS += $(C_WARN_FLAG) $(INC) $(CF_VERS)
diff --git a/multimedia/fxtv/pkg-descr b/multimedia/fxtv/pkg-descr
index d15f1ede0b28..7ef0bb9aa00f 100644
--- a/multimedia/fxtv/pkg-descr
+++ b/multimedia/fxtv/pkg-descr
@@ -3,10 +3,7 @@ image/audio/video capture capabilities for Brooktree Bt848/849/878/879
and Pinnacle PCTV tuner/capture cards.
To use this app, you need a capture card supported by the bktr(4) driver.
-Examples include the Hauppauge Wincast/TV, the STB TV PCI, and the
-Intel Smart Video Recorder III. See the 'bktr' man page
-for more information.
-
-Refer to the README for details on usage.
+Examples include the Hauppauge Wincast/TV, the STB TV PCI, and the Intel
+Smart Video Recorder III. See the 'bktr' man page for more information.
WWW: http://people.FreeBSD.org/~rhh/fxtv/
diff --git a/multimedia/fxtv/pkg-plist b/multimedia/fxtv/pkg-plist
index 22e59c47f156..10dec99f0cf5 100644
--- a/multimedia/fxtv/pkg-plist
+++ b/multimedia/fxtv/pkg-plist
@@ -9,5 +9,6 @@ lib/X11/fxtv/bitmaps/mini-up.xbm
lib/X11/fxtv/bitmaps/radio_off.xbm
lib/X11/fxtv/bitmaps/radio_on.xbm
lib/X11/fxtv/fxtv_cnvt.sh
+man/man1/fxtv.1.gz
@dirrm lib/X11/fxtv/bitmaps
@dirrm lib/X11/fxtv