aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/smstools3/Makefile3
-rw-r--r--comms/smstools3/distinfo6
-rw-r--r--comms/smstools3/files/patch-src-Makefile19
3 files changed, 10 insertions, 18 deletions
diff --git a/comms/smstools3/Makefile b/comms/smstools3/Makefile
index 9dafe9d7b3db..212f966815cb 100644
--- a/comms/smstools3/Makefile
+++ b/comms/smstools3/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= smstools
-PORTVERSION= 3.1.15
-PORTREVISION= 4
+PORTVERSION= 3.1.16
CATEGORIES= comms
MASTER_SITES= http://smstools3.kekekasvi.com/packages/
DISTNAME= smstools3-${PORTVERSION}
diff --git a/comms/smstools3/distinfo b/comms/smstools3/distinfo
index 130f5a90ce1a..9fe95e69555e 100644
--- a/comms/smstools3/distinfo
+++ b/comms/smstools3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1478085197
-SHA256 (smstools3-3.1.15.tar.gz) = ed00ffaeaa312a5b4f969f4e97a64603a866bbe16e393ea02f5bf05234814d59
-SIZE (smstools3-3.1.15.tar.gz) = 300088
+TIMESTAMP = 1487844294
+SHA256 (smstools3-3.1.16.tar.gz) = f79e501c3640ffeef360f75e3146ab423a30f50304e8e27044ccdaf692276799
+SIZE (smstools3-3.1.16.tar.gz) = 338866
diff --git a/comms/smstools3/files/patch-src-Makefile b/comms/smstools3/files/patch-src-Makefile
index ad904e1b18a4..d79dbcc0572d 100644
--- a/comms/smstools3/files/patch-src-Makefile
+++ b/comms/smstools3/files/patch-src-Makefile
@@ -1,4 +1,4 @@
---- src/Makefile.orig 2010-09-21 11:29:14 UTC
+--- src/Makefile.orig 2017-02-08 20:40:28 UTC
+++ src/Makefile
@@ -1,7 +1,7 @@
# In case of windows, use os_cygwin=yes setting in the configuration file (smsd.conf).
@@ -9,28 +9,21 @@
# Uncomment for Solaris
# CFLAGS += -D SOLARIS
-@@ -9,13 +9,13 @@ CFLAGS = -D NUMBER_OF_MODEMS=64
+@@ -9,7 +9,7 @@ CFLAGS = -D NUMBER_OF_MODEMS=64
# CC=gcc
# Comment this out, to enable statistics
-CFLAGS += -D NOSTATS
+#CFLAGS += -D NOSTATS
- # Comment this out if iconv is not available on the system
- #CFLAGS += -D USE_ICONV
-
- # Uncomment this is iconv is used and it's not included in libc:
--#LFLAGS += -liconv
-+#LDFLAGS += -liconv
-
# Uncomment this to force smsd to run in terminal mode
#CFLAGS += -D TERMINAL
-@@ -43,14 +43,14 @@ smsd: smsd.c extras.o locking.o cfgfile.
+@@ -46,14 +46,14 @@ smsd: smsd.c extras.o locking.o cfgfile.
ifneq (,$(findstring SOLARIS,$(CFLAGS)))
ifeq (,$(findstring DISABLE_INET_SOCKET,$(CFLAGS)))
--override LFLAGS += -lsocket -lnsl
-+override LDFLAGS += -lsocket -lnsl
+- override LFLAGS += -lsocket -lnsl
++ override LDFLAGS += -lsocket -lnsl
endif
endif
@@ -39,7 +32,7 @@
+ $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
else
- $(CC) `mm-config --cflags` $(CFLAGS) -o $@ $^ `mm-config --ldflags --libs` $(LFLAGS)
-+ $(CC) `$(LOCALBASE)/bin/mm-config --cflags` $(CFLAGS) -o $@ $^ `$(LOCALBASE)/bin/mm-config --ldflags --libs` $(LDFLAGS)
++ $(CC) `mm-config --cflags` $(CFLAGS) -o $@ $^ `mm-config --ldflags --libs` $(LDFLAGS)
endif
clean: