aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--comms/gqrx/Makefile2
-rw-r--r--comms/gqrx/files/patch-CMakeLists.txt13
2 files changed, 14 insertions, 1 deletions
diff --git a/comms/gqrx/Makefile b/comms/gqrx/Makefile
index 2974b7542287..4368cf73a328 100644
--- a/comms/gqrx/Makefile
+++ b/comms/gqrx/Makefile
@@ -1,7 +1,7 @@
PORTNAME= gqrx
PORTVERSION= 2.16
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= comms hamradio
diff --git a/comms/gqrx/files/patch-CMakeLists.txt b/comms/gqrx/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d57ee9ab2b45
--- /dev/null
+++ b/comms/gqrx/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2023-04-28 17:35:04 UTC
++++ CMakeLists.txt
+@@ -121,10 +121,7 @@ else()
+ endif()
+
+ # 3rd Party Dependency Stuff
+-find_package(Qt6 QUIET COMPONENTS Core Network Widgets Svg SvgWidgets)
+-if(NOT Qt6_FOUND)
+ find_package(Qt5 REQUIRED COMPONENTS Core Network Widgets Svg)
+-endif()
+ include(FindPkgConfig)
+ find_package(Gnuradio-osmosdr REQUIRED)
+