aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--converters/php72-mbstring/files/patch-config.m420
-rw-r--r--databases/php72-odbc/files/patch-config.m433
-rw-r--r--devel/php72-intl/Makefile1
-rw-r--r--lang/php72/Makefile2
-rw-r--r--lang/php72/distinfo6
-rw-r--r--textproc/php72-simplexml/files/patch-config.m414
6 files changed, 37 insertions, 39 deletions
diff --git a/converters/php72-mbstring/files/patch-config.m4 b/converters/php72-mbstring/files/patch-config.m4
index 026798f26a5a..3e299951c999 100644
--- a/converters/php72-mbstring/files/patch-config.m4
+++ b/converters/php72-mbstring/files/patch-config.m4
@@ -1,9 +1,10 @@
---- config.m4.orig 2009-11-25 02:30:06.000000000 +0100
-+++ config.m4 2010-04-12 09:59:54.000000000 +0200
-@@ -43,6 +43,30 @@
+--- config.m4.orig 2018-11-10 15:21:47.103604000 +0100
++++ config.m4 2018-11-10 15:24:23.615118000 +0100
+@@ -42,6 +42,30 @@ AC_DEFUN([PHP_MBSTRING_EXTENSION], [
+ PHP_ADD_INCLUDE([$ext_srcdir/$dir])
PHP_ADD_INCLUDE([$ext_builddir/$dir])
done
-
++
+ dnl This is PECL build, check if bundled PCRE library is used
+ old_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS=$INCLUDES
@@ -27,11 +28,10 @@
+ PHP_PCRE_REGEX=no
+ ])
+ ])
-+
+
if test "$ext_shared" = "no"; then
PHP_ADD_SOURCES(PHP_EXT_DIR(mbstring), $PHP_MBSTRING_BASE_SOURCES)
- out="php_config.h"
-@@ -80,7 +104,6 @@
+@@ -85,7 +109,6 @@ AC_DEFUN([PHP_MBSTRING_SETUP_MBREGEX], [
int foo(int x, ...) {
va_list va;
va_start(va, x);
@@ -39,13 +39,13 @@
va_arg(va, char *);
va_arg(va, double);
return 0;
-@@ -347,6 +370,9 @@
+@@ -367,6 +390,9 @@ PHP_ARG_WITH(onig, [for external oniguru
[ --with-onig[=DIR] MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
- If DIR is not set, the bundled oniguruma will be used], no, no)
+ If DIR is not set, the bundled oniguruma will be used], no, no)
+PHP_ARG_WITH(pcre-dir, pcre install prefix,
+[ --with-pcre-dir MBSTRING: pcre install prefix], no, no)
+
- if test "$PHP_MBSTRING" != "no"; then
+ if test "$PHP_MBSTRING" != "no"; then
AC_DEFINE([HAVE_MBSTRING],1,[whether to have multibyte string support])
diff --git a/databases/php72-odbc/files/patch-config.m4 b/databases/php72-odbc/files/patch-config.m4
index cf68ac678e4c..6479cf0f531d 100644
--- a/databases/php72-odbc/files/patch-config.m4
+++ b/databases/php72-odbc/files/patch-config.m4
@@ -1,13 +1,12 @@
---- config.m4.orig 2016-10-25 15:23:21 UTC
-+++ config.m4
-@@ -100,13 +100,17 @@ dnl
+--- config.m4.orig 2018-11-10 15:32:27.031531000 +0100
++++ config.m4 2018-11-10 15:37:40.815007000 +0100
+@@ -100,13 +100,16 @@ dnl
dnl configure options
dnl
+PHP_ARG_ENABLE(odbc,,
+[ --enable-odbc Enable ODBC support with selected driver])
+
-+
PHP_ARG_WITH(odbcver,,
[ --with-odbcver[=HEX] Force support for the passed ODBC version. A hex number is expected, default 0x0350.
Use the special value of 0 to prevent an explicit ODBCVER to be defined. ], 0x0350)
@@ -19,7 +18,7 @@
AC_MSG_CHECKING([for Adabas support])
if test "$PHP_ADABAS" != "no"; then
-@@ -135,7 +139,7 @@ fi
+@@ -135,7 +138,7 @@ fi
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(sapdb,,
@@ -28,7 +27,7 @@
AC_MSG_CHECKING([for SAP DB support])
if test "$PHP_SAPDB" != "no"; then
-@@ -155,7 +159,7 @@ fi
+@@ -155,7 +158,7 @@ fi
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(solid,,
@@ -37,7 +36,7 @@
AC_MSG_CHECKING(for Solid support)
if test "$PHP_SOLID" != "no"; then
-@@ -182,7 +186,7 @@ fi
+@@ -182,7 +185,7 @@ fi
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(ibm-db2,,
@@ -46,7 +45,7 @@
AC_MSG_CHECKING(for IBM DB2 support)
if test "$PHP_IBM_DB2" != "no"; then
-@@ -221,7 +225,7 @@ fi
+@@ -221,7 +224,7 @@ fi
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(ODBCRouter,,
@@ -55,7 +54,7 @@
AC_MSG_CHECKING(for ODBCRouter.com support)
if test "$PHP_ODBCROUTER" != "no"; then
-@@ -244,7 +248,7 @@ fi
+@@ -244,7 +247,7 @@ fi
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(empress,,
[ --with-empress[=DIR] Include Empress support [\$EMPRESSPATH]
@@ -64,7 +63,7 @@
AC_MSG_CHECKING(for Empress support)
if test "$PHP_EMPRESS" != "no"; then
-@@ -270,7 +274,7 @@ if test -z "$ODBC_TYPE"; then
+@@ -270,7 +273,7 @@ if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(empress-bcs,,
[ --with-empress-bcs[=DIR]
Include Empress Local Access support [\$EMPRESSPATH]
@@ -73,16 +72,16 @@
AC_MSG_CHECKING(for Empress local access support)
if test "$PHP_EMPRESS_BCS" != "no"; then
-@@ -310,7 +314,7 @@ fi
+@@ -310,7 +313,7 @@ fi
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(birdstep,,
-[ --with-birdstep[=DIR] Include Birdstep support [/usr/local/birdstep]])
+[ --with-birdstep[=DIR] Include Birdstep support [/usr/local/birdstep]], no, no)
-
+
AC_MSG_CHECKING(for Birdstep support)
if test "$PHP_BIRDSTEP" != "no"; then
-@@ -366,7 +370,7 @@ PHP_ARG_WITH(custom-odbc,,
+@@ -366,7 +369,7 @@ PHP_ARG_WITH(custom-odbc,,
running this configure script:
CPPFLAGS=\"-DODBC_QNX -DSQLANY_BUG\"
LDFLAGS=-lunix
@@ -91,7 +90,7 @@
AC_MSG_CHECKING(for a custom ODBC support)
if test "$PHP_CUSTOM_ODBC" != "no"; then
-@@ -388,7 +392,7 @@ fi
+@@ -388,7 +391,7 @@ fi
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(iodbc,,
@@ -100,7 +99,7 @@
AC_MSG_CHECKING(for iODBC support)
if test "$PHP_IODBC" != "no"; then
-@@ -426,7 +430,7 @@ fi
+@@ -426,7 +429,7 @@ fi
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(esoob,,
@@ -109,7 +108,7 @@
AC_MSG_CHECKING(for Easysoft ODBC-ODBC Bridge support)
if test "$PHP_ESOOB" != "no"; then
-@@ -448,7 +452,7 @@ fi
+@@ -448,7 +451,7 @@ fi
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(unixODBC,,
@@ -118,7 +117,7 @@
AC_MSG_CHECKING(for unixODBC support)
if test "$PHP_UNIXODBC" != "no"; then
-@@ -471,7 +475,7 @@ fi
+@@ -471,7 +474,7 @@ fi
if test -z "$ODBC_TYPE"; then
PHP_ARG_WITH(dbmaker,,
diff --git a/devel/php72-intl/Makefile b/devel/php72-intl/Makefile
index a4c5a5cb662e..4862fded8d55 100644
--- a/devel/php72-intl/Makefile
+++ b/devel/php72-intl/Makefile
@@ -1,6 +1,5 @@
# $FreeBSD$
-PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php72
diff --git a/lang/php72/Makefile b/lang/php72/Makefile
index 0760e757e8f9..1f47251f4d58 100644
--- a/lang/php72/Makefile
+++ b/lang/php72/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= php72
-DISTVERSION= 7.2.11
+DISTVERSION= 7.2.12
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
diff --git a/lang/php72/distinfo b/lang/php72/distinfo
index 19b437fc84a2..3081b3ff8da0 100644
--- a/lang/php72/distinfo
+++ b/lang/php72/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1539357115
-SHA256 (php-7.2.11.tar.xz) = da1a705c0bc46410e330fc6baa967666c8cd2985378fb9707c01a8e33b01d985
-SIZE (php-7.2.11.tar.xz) = 12132268
+TIMESTAMP = 1541795158
+SHA256 (php-7.2.12.tar.xz) = 989c04cc879ee71a5e1131db867f3c5102f1f7565f805e2bb8bde33f93147fe1
+SIZE (php-7.2.12.tar.xz) = 12141472
diff --git a/textproc/php72-simplexml/files/patch-config.m4 b/textproc/php72-simplexml/files/patch-config.m4
index 4eeef697dc87..ab12da0527e4 100644
--- a/textproc/php72-simplexml/files/patch-config.m4
+++ b/textproc/php72-simplexml/files/patch-config.m4
@@ -1,6 +1,6 @@
---- config.m4.orig 2014-05-14 10:14:22.929420181 +0000
-+++ config.m4 2014-05-14 10:15:36.967414693 +0000
-@@ -4,6 +4,9 @@
+--- config.m4.orig 2018-11-09 21:17:02.404698000 +0100
++++ config.m4 2018-11-09 21:18:57.799985000 +0100
+@@ -4,6 +4,9 @@ dnl config.m4 for extension simplexml
PHP_ARG_ENABLE(simplexml, whether to enable SimpleXML support,
[ --disable-simplexml Disable SimpleXML support], yes)
@@ -9,8 +9,8 @@
+
if test -z "$PHP_LIBXML_DIR"; then
PHP_ARG_WITH(libxml-dir, libxml2 install dir,
- [ --with-libxml-dir=DIR SimpleXML: libxml2 install prefix], no, no)
-@@ -11,6 +14,30 @@
+ [ --with-libxml-dir=DIR SimpleXML: libxml2 install prefix], no, no)
+@@ -11,6 +14,30 @@ fi
if test "$PHP_SIMPLEXML" != "no"; then
@@ -38,6 +38,6 @@
+ ])
+ ])
+
- if test "$PHP_LIBXML" = "no"; then
- AC_MSG_ERROR([SimpleXML extension requires LIBXML extension, add --enable-libxml])
+ if test "$PHP_LIBXML" = "no"; then
+ AC_MSG_ERROR([SimpleXML extension requires LIBXML extension, add --enable-libxml])
fi