aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/libGLU/Makefile11
-rw-r--r--graphics/libGLU/files/patch-meson.build8
2 files changed, 14 insertions, 5 deletions
diff --git a/graphics/libGLU/Makefile b/graphics/libGLU/Makefile
index 3f332cd6d995..82797034880a 100644
--- a/graphics/libGLU/Makefile
+++ b/graphics/libGLU/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libGLU
PORTVERSION= 9.0.2
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.freedesktop.org/pub/mesa/glu/ \
https://mesa.freedesktop.org/archive/glu/
@@ -10,12 +11,12 @@ DISTNAME= glu-${PORTVERSION}
MAINTAINER= x11@FreeBSD.org
COMMENT= OpenGL utility library
-USES= gl libtool pathfix pkgconfig tar:xz
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-static \
- --enable-libglvnd
-INSTALL_TARGET= install-strip
+USES= gl libtool meson pathfix pkgconfig tar:xz
+
USE_GL= opengl
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+MESON_ARGS= -Ddefault_library=shared
+
.include <bsd.port.mk>
diff --git a/graphics/libGLU/files/patch-meson.build b/graphics/libGLU/files/patch-meson.build
new file mode 100644
index 000000000000..8337df10f0fe
--- /dev/null
+++ b/graphics/libGLU/files/patch-meson.build
@@ -0,0 +1,8 @@
+--- meson.build.orig 2021-07-09 05:00:19 UTC
++++ meson.build
+@@ -34,4 +34,5 @@ pkgconf.generate(
+ libglu,
+ name : 'glu',
+ description : 'Mesa OpenGL Utility Library',
++ requires: dep_gl
+ )