aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gecko.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.gecko.mk')
-rw-r--r--Mk/bsd.gecko.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index b54be8561ffe..b7380380d03b 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -553,15 +553,15 @@ LDFLAGS+= -Wl,-rpath,${PREFIX}/lib/${MOZ_RPATH}
.if ${MOZILLA_VER:R:R} >= 19 || ${MOZILLA:Mseamonkey*}
# prefer clang
-. if ${CC} == "cc" && (exists(/usr/bin/clang) || \
+. if ${CC} == "cc" && (exists(/usr/bin/clang) && ${OSVERSION} >= 900014 || \
exists(${LOCALBASE}/bin/clang))
CC= clang
. endif
-. if ${CXX} == "c++" && (exists(/usr/bin/clang++) || \
+. if ${CXX} == "c++" && (exists(/usr/bin/clang++) && ${OSVERSION} >= 900014 || \
exists(${LOCALBASE}/bin/clang++))
CXX= clang++
. endif
-. if ${CPP} == "cpp" && (exists(/usr/bin/clang-cpp) || \
+. if ${CPP} == "cpp" && (exists(/usr/bin/clang-cpp) && ${OSVERSION} >= 900014 || \
exists(${LOCALBASE}/bin/clang-cpp))
CPP= clang-cpp
. endif