aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.php.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.php.mk')
-rw-r--r--Mk/bsd.php.mk17
1 files changed, 8 insertions, 9 deletions
diff --git a/Mk/bsd.php.mk b/Mk/bsd.php.mk
index 6b4091585c5a..90f9c6d512bf 100644
--- a/Mk/bsd.php.mk
+++ b/Mk/bsd.php.mk
@@ -59,19 +59,15 @@ PHP_EXT_INC= pcre spl
HTTPD?= ${LOCALBASE}/sbin/httpd
.if exists(${HTTPD})
-APACHE_VERSION!= ${HTTPD} -V | ${SED} -ne 's/^Server version: Apache\/\([0-9]\)\.\([0-9]*\).*/\1\2/p'
-. if ${APACHE_VERSION} > 13
APXS?= ${LOCALBASE}/sbin/apxs
APACHE_MPM!= ${APXS} -q MPM_NAME
-. if ${APACHE_MPM} == "worker"
+. if ${APACHE_MPM} == "worker" || ${APACHE_MPM} == "event"
PHP_EXT_DIR:= ${PHP_EXT_DIR}-zts
-. endif
. endif
-.elif defined(APACHE_PORT)
-APACHE_VERSION!= ${ECHO_CMD} ${APACHE_PORT} | ${SED} -ne 's,.*/apache\([0-9]*\).*,\1,p'
-. if ${APACHE_VERSION} > 13 && defined(WITH_MPM) && ${WITH_MPM} == "worker"
+.elif defined(APACHE_PORT) && (${APACHE_PORT:M*worker*} != "" || ${APACHE_PORT:M*event*} != "")
+PHP_EXT_DIR:= ${PHP_EXT_DIR}-zts
+.elif defined(WITH_MPM) && (${WITH_MPM} == "worker" || ${WITH_MPM} == "event")
PHP_EXT_DIR:= ${PHP_EXT_DIR}-zts
-. endif
.endif
.if defined(WITH_DEBUG)
@@ -81,10 +77,13 @@ PHP_SAPI?= ""
.endif # .if exists(${PHPBASE}/etc/php.conf)
PHP_EXT_INC?= ""
+PHP5_LAST_VER= 54
+
.if defined(IGNORE_WITH_PHP)
. for VER in ${IGNORE_WITH_PHP}
. if ${PHP_VER} == "${VER}"
-IGNORE= cannot install: doesn't work with PHP version : ${PHP_VER} (Doesn't support PHP ${IGNORE_WITH_PHP})
+IGNORE= cannot be installed: doesn't work with lang/php${PHP_VER} port\
+ (doesn't support PHP ${IGNORE_WITH_PHP:C/^5$/${PHP5_LAST_VER}/:C/^5/5./})
. endif
. endfor
.endif