aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk13
1 files changed, 9 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 11ac2ba3f823..2464e83e0e5b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -435,16 +435,21 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# USE_WX - If set, this port uses the WxWidgets library and related
# components. See bsd.wx.mk for more details.
##
-# USE_KDE4 - A list of the KDE4 dependencies the port has (e.g.,
+# USE_KDE4 - A list of the KDE 4 dependencies the port has (e.g.,
# kdelibs, kdebase). Implies that the port needs KDE.
# Implies inclusion of bsd.kde4.mk. See bsd.kde4.mk
# for more details.
#
-# USE_QT4 - A list of the QT4 dependencies the port has (e.g,
+# USE_QT4 - A list of the Qt 4 dependencies the port has (e.g,
# corelib, webkit). Implies that the port needs Qt.
# Implies the inclusion of bsd.qt.mk. See bsd.qt.mk
# for more details.
#
+# USE_QT5 - A list of the Qt 5 dependencies the port has (e.g,
+# core, webkit). Implies that the port needs Qt.
+# Implies the inclusion of bsd.qt.mk. See bsd.qt.mk
+# for more details.
+#
# USE_LINUX - Set to yes to say the port needs the default linux base port.
# Set to value <X>, if the port needs emulators/linux_base-<X>.
# Implies appropriate settings for STRIP and STRIP_CMD.
@@ -1440,7 +1445,7 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
.include "${PORTSDIR}/Mk/bsd.apache.mk"
.endif
-.if defined(USE_QT4)
+.if defined(USE_QT4) || defined(USE_QT5)
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif
@@ -1871,7 +1876,7 @@ IGNORE= Do not define STAGEDIR in command line
.include "${PORTSDIR}/Mk/bsd.linux-apps.mk"
.endif
-.if defined(USE_QT4)
+.if defined(USE_QT4) || defined(USE_QT5)
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif