aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 839966dab118..b619e840cc1a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -490,6 +490,10 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# RPM ports.
# Implies inclusion of bsd.linux-rpm.mk.
#
+# LINUX_OSRELEASE - Contains the value of compat.linux.osrelease sysctl.
+# Will be used to distinguish which linux
+# infrastructure ports should be used.
+# Valid values: 2.4.2, 2.6.16.
# AUTOMATIC_PLIST
# - Set to yes to enable automatic packing list generation.
# Currently has no effect unless USE_LINUX_RPM is set.
@@ -1338,6 +1342,10 @@ ETCDIR?= ${PREFIX}/etc/${PORTNAME}
.include "${PORTSDIR}/Mk/bsd.linux-rpm.mk"
.endif
+.if defined(USE_LINUX_APPS)
+.include "${PORTSDIR}/Mk/bsd.linux-apps.mk"
+.endif
+
.if defined(X_WINDOW_SYSTEM) && ${X_WINDOW_SYSTEM:L} != "xorg"
IGNORE= cannot be installed: bad X_WINDOW_SYSTEM setting; valid value is 'xorg'
.endif
@@ -1786,6 +1794,10 @@ USE_LINUX?= yes
.if defined(USE_LINUX)
+. if !defined(LINUX_OSRELEASE)
+LINUX_OSRELEASE!= ${ECHO_CMD} `${SYSCTL} -n compat.linux.osrelease 2>/dev/null`
+. endif
+
# install(1) also does a brandelf on strip, so don't strip with FreeBSD tools.
STRIP=
. if exists(${LINUXBASE}/usr/bin/strip)
@@ -1953,6 +1965,10 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
.include "${PORTSDIR}/Mk/bsd.linux-rpm.mk"
.endif
+.if defined(USE_LINUX_APPS)
+.include "${PORTSDIR}/Mk/bsd.linux-apps.mk"
+.endif
+
.if defined (USE_QT_VER) && ${USE_QT_VER:L} == 4
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif