aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 61cdec288761..e677ea728e05 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -252,7 +252,7 @@ README.html:
search: ${PORTSDIR}/INDEX
@here=`pwd`; \
cd ${PORTSDIR}; \
- top=`pwd`; \
+ top=`pwd -P`; \
there=`echo "$$here/" | sed s%$$top%${PORTSDIR}%`; \
if [ -n "$$key" ]; then \
grep $$there ${PORTSDIR}/INDEX | grep -i "${key}" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'; \