aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 6c02eb096d7f..d584cb789b81 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -110,6 +110,9 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# PYCTYPES - Dependency line for the ctypes package. As of Python-2.5,
# this module is in the base distribution.
#
+# PYHASHLIB - Dependency line for the hashlib package. As of Python-2.5,
+# this module is in the base distribution.
+#
# USE_PYTHON_PREFIX - Says that the port installs in ${PYTHONBASE}.
#
# USE_PYDISTUTILS - Use distutils as do-configure, do-build and do-install
@@ -441,6 +444,12 @@ PYCTYPES= ${PYTHON_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
PYCTYPES= ${PYTHON_LIBDIR}/ctypes/__init__py:${PYTHON_PORTSDIR}
.endif
+.if defined(PYTHON_REL) && ${PYTHON_REL} < 250
+PYHASHLIB= ${PYTHON_SITELIBDIR}/hashlib.py:${PORTSDIR}/security/py-hashlib
+.else
+PYHASHLIB= ${PYTHON_LIBDIR}/hashlib.py:${PYTHON_PORTSDIR}
+.endif
+
# dependencies
PYTHON_NO_DEPENDS?= NO