aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.qt.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.qt.mk')
-rw-r--r--Mk/bsd.qt.mk112
1 files changed, 81 insertions, 31 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index ad5343b4bd31..f4a4b843e825 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -1,10 +1,16 @@
+#-*- mode: Makefile; tab-width: 4; -*-
+# ex:ts=4
+
+# QT_NONSTANDARD - Suppress modification of configure and make environment.
+# QT_DIST - Package being built is part of the Qt distribution.
+
.if !defined(_POSTMKINCLUDED) && !defined(Qt_Pre_Include)
Qt_Include_MAINTAINER= kde@freebsd.org
Qt_Pre_Include= bsd.qt.mk
.if !defined(QT_NONSTANDARD)
-CONFIGURE_ARGS+=--with-qt-includes=${QT_PREFIX}/include \
- --with-qt-libraries=${QT_PREFIX}/lib \
+CONFIGURE_ARGS+=--with-qt-includes=${QT_INCDIR} \
+ --with-qt-libraries=${QT_LIBDIR} \
--with-extra-libs=${LOCALBASE}/lib \
--with-extra-includes=${LOCALBASE}/include
CONFIGURE_ENV+= MOC="${MOC}" UIC="${UIC}" CPPFLAGS="${CPPFLAGS} ${QTCPPFLAGS}" LIBS="${QTCFGLIBS}" \
@@ -14,39 +20,51 @@ MAKE_ENV+= QMAKESPEC="${QMAKESPEC}"
.if defined(QT_DIST)
#CONFLICTS+= Currently there are no conflicts \o/
-CONFIGURE_ARGS+=-fast -no-exceptions ${CUPS} \
- -platform ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
- -qt-gif -release -system-libjpeg -system-libpng \
+
+CONFIGURE_ARGS+=-fast ${CUPS} -platform ${QMAKESPEC} \
+ -L${PREFIX}/${QT_LIBDIR_REL} \
+ -qt-gif -system-libjpeg -system-libpng \
-system-libmng -system-libtiff -system-zlib \
-confirm-license \
- -prefix ${PREFIX} \
- -docdir ${PREFIX}/share/doc/qt4 \
- -headerdir ${PREFIX}/include \
- -plugindir ${PREFIX}/lib/qt4/plugins \
- -datadir ${PREFIX}/share/qt4 \
- -libdir ${PREFIX}/lib \
- -translationdir ${PREFIX}/share/qt4/translations \
- -sysconfdir ${PREFIX}/local/etc/xdg \
- -examplesdir ${PREFIX}/share/qt4/examples \
- -demosdir ${PREFIX}/share/qt4/demos \
- -bindir ${PREFIX}/bin
+ -prefix ${PREFIX} \
+ -bindir ${PREFIX}/bin \
+ -libdir ${PREFIX}/${QT_LIBDIR_REL} \
+ -docdir ${PREFIX}/share/doc/qt4 \
+ -headerdir ${PREFIX}/${QT_INCDIR_REL} \
+ -plugindir ${PREFIX}/lib/qt4/plugins \
+ -datadir ${PREFIX}/share/qt4 \
+ -translationdir ${PREFIX}/share/qt4/translations \
+ -sysconfdir ${PREFIX}/etc/xdg \
+ -examplesdir ${PREFIX}/share/examples/qt4/examples \
+ -demosdir ${PREFIX}/share/examples/qt4/demos
+
.if defined(PACKAGE_BUILDING)
-CONFIGURE_ARGS+=-no-3dnow -no-sse -no-sse2
+CONFIGURE_ARGS+=-no-mmx -no-3dnow -no-sse -no-sse2
.endif #defined(PACKAGE_BUILDING)
-.if !defined(WANT_QT_DEBUG)
-CONFIGURE_ARGS+=-no-separate-debug-info
-PLIST_SUB+= DEBUG="@comment "
-.else
+.if defined(PORTNAME) && ${PORTNAME} != "xmlpatterns"
+CONFIGURE_ARGS+=-no-exceptions
+.endif
+
+.if defined(WANT_QT_DEBUG)
+CONFIGURE_ARGS+=-debug
PLIST_SUB+= DEBUG=""
+.else
+CONFIGURE_ARGS+=-release -no-separate-debug-info
+PLIST_SUB+= DEBUG="@comment "
.endif
.if defined(WANT_QT_VERBOSE_CONFIGURE)
-CONFIGURE_ARGS+=-v
+CONFIGURE_ARGS+=-verbose
.endif
.endif #defined(QT_DIST)
+QT_INCDIR_REL= include/qt4
+QT_LIBDIR_REL= lib/qt4
+
QT_PREFIX?= ${LOCALBASE}
+QT_INCDIR?= ${QT_PREFIX}/${QT_INCDIR_REL}
+QT_LIBDIR?= ${QT_PREFIX}/${QT_LIBDIR_REL}
MOC?= ${QT_PREFIX}/bin/moc-qt4
UIC?= ${QT_PREFIX}/bin/uic-qt4
QMAKE?= ${QT_PREFIX}/bin/qmake-qt4
@@ -66,19 +84,26 @@ QTCGFLIBS?=
.endif # !defined(_POSTMKINCLUDED) && !defined(Qt_Pre_Include)
-QT4_VERSION?= 4.3.4
+#
+# QT4 version
+# Don't forget to update ${PORTSDIR}/devel/qt4/files/configure !
+#
+QT4_VERSION?= 4.4.1
-_QT_COMPONENTS_ALL= accessible assistant assistantclient codecs-cn \
- codecs-jp codecs-kr codecs-tw corelib dbus designer \
- doc gui iconengines imageformats inputmethods linguist \
- makeqpf moc network opengl pixeltool porting qdbusviewer \
- qmake qt3support qtconfig qtestlib qvfb rcc script sql \
- svg uic uic3 xml
+_QT_COMPONENTS_ALL= accessible assistant assistant-adp assistantclient \
+ clucene codecs-cn codecs-jp codecs-kr codecs-tw corelib \
+ dbus designer doc help help-tools gui iconengines imageformats \
+ inputmethods linguist makeqpf moc network opengl \
+ pixeltool porting phonon phonon-gst qdbusviewer \
+ qmake qt3support qtconfig qtestlib qvfb rcc script \
+ sql svg uic uic3 webkit xml xmlpatterns xmlpatterns-tool
-accessible_DEPENDS= accessibility/qt4-acessible
+accessible_DEPENDS= accessibility/qt4-accessible
assistant_DEPENDS= devel/qt4-assistant
+assistant-adp_DEPENDS= devel/qt4-assistant-adp
assistantclient_DEPENDS=devel/qt4-libqtassistantclient
assistantclient_NAME= libQtAssistantClient
+clucene_DEPENDS= textproc/qt4-clucene
codecs-cn_DEPENDS= chinese/qt4-codecs-cn
codecs-jp_DEPENDS= japanese/qt4-codecs-jp
codecs-kr_DEPENDS= korean/qt4-codecs-kr
@@ -88,6 +113,8 @@ dbus_DEPENDS= devel/dbus-qt4
designer_DEPENDS= devel/qt4-designer
doc_DEPENDS= misc/qt4-doc
gui_DEPENDS= x11-toolkits/qt4-gui
+help_DEPENDS= devel/qt4-help
+help-tools_DEPENDS= devel/qt4-help-tools
iconengines_DEPENDS= graphics/qt4-iconengines
imageformats_DEPENDS= graphics/qt4-imageformats
inputmethods_DEPENDS= x11/qt4-inputmethods
@@ -97,11 +124,13 @@ moc_DEPENDS= devel/qt4-moc
network_DEPENDS= net/qt4-network
opengl_DEPENDS= x11/qt4-opengl
pixeltool_DEPENDS= graphics/qt4-pixeltool
+phonon_DEPENDS= multimedia/qt4-phonon
+phonon-gst_DEPENDS= multimedia/qt4-phonon-gst
porting_DEPENDS= devel/qt4-porting
qdbusviewer_DEPENDS= devel/qt4-qdbusviewer
qmake_DEPENDS= devel/qmake4
qt3support_DEPENDS= devel/qt4-qt3support
-qtconfig_DEPENDS= devel/qtconfig
+qtconfig_DEPENDS= misc/qt4-qtconfig
qtestlib_DEPENDS= devel/qt4-qtestlib
qvfb_DEPENDS= devel/qt4-qvfb
rcc_DEPENDS= devel/qt4-rcc
@@ -110,12 +139,17 @@ sql_DEPENDS= databases/qt4-sql
svg_DEPENDS= graphics/qt4-svg
uic_DEPENDS= devel/qt4-uic
uic3_DEPENDS= devel/qt4-uic3
+webkit_DEPENDS= www/qt4-webkit
xml_DEPENDS= textproc/qt4-xml
+xmlpatterns_DEPENDS= textproc/qt4-xmlpatterns
+xmlpatterns-tool_DEPENDS= textproc/qt4-xmlpatterns-tool
accessible_build_DEPENDS= ${accessible_DEPENDS}
assistant_build_DEPENDS= ${assistant_DEPENDS}
+assistant-adp_build_DEPENDS= ${assistant-adp_DEPENDS}
assistantclient_build_DEPENDS= ${assistantclient_DEPENDS}
assistantclient_build_NAME= ${assistantclient_NAME}
+clucene_build_DEPENDS= ${clucene_DEPENDS}
codecs-cn_build_DEPENDS= ${codecs-cn_DEPENDS}
codecs-jp_build_DEPENDS= ${codecs-jp_DEPENDS}
codecs-kr_build_DEPENDS= ${codecs-kr_DEPENDS}
@@ -125,6 +159,8 @@ dbus_build_DEPENDS= ${dbus_DEPENDS}
designer_build_DEPENDS= ${designer_DEPENDS}
doc_build_DEPENDS= ${doc_DEPENDS}
gui_build_DEPENDS= ${gui_DEPENDS}
+help_build_DEPENDS= ${help_DEPENDS}
+help-tools_build_DEPENDS= ${help-tools_DEPENDS}
iconengines_build_DEPENDS= ${iconengines_DEPENDS}
imageformats_build_DEPENDS= ${imageformats_DEPENDS}
inputmethods_build_DEPENDS= ${inputmethods_DEPENDS}
@@ -134,6 +170,8 @@ moc_build_DEPENDS= ${moc_DEPENDS}
network_build_DEPENDS= ${network_DEPENDS}
opengl_build_DEPENDS= ${opengl_DEPENDS}
pixeltool_build_DEPENDS= ${pixeltool_DEPENDS}
+phonon_build_DEPENDS= ${phonon_DEPENDS}
+phonon-gst_build_DEPENDS= ${phonon-gst_DEPENDS}
porting_build_DEPENDS= ${porting_DEPENDS}
qdbusviewer_build_DEPENDS= ${qdbusviewer_DEPENDS}
qmake_build_DEPENDS= ${qmake_DEPENDS}
@@ -147,12 +185,17 @@ sql_build_DEPENDS= ${sql_DEPENDS}
svg_build_DEPENDS= ${svg_DEPENDS}
uic_build_DEPENDS= ${uic_DEPENDS}
uic3_build_DEPENDS= ${uic3_DEPENDS}
+webkit_build_DEPENDS= ${webkit_DEPENDS}
xml_build_DEPENDS= ${xml_DEPENDS}
+xmlpatterns_build_DEPENDS= ${xmlpatterns_DEPENDS}
+xmlpatterns-tool_build_DEPENDS= ${xmlpatterns-tool_DEPENDS}
accessible_run_DEPENDS= ${accessible_DEPENDS}
assistant_run_DEPENDS= ${assistant_DEPENDS}
+assistant-adp_run_DEPENDS= ${assistant-adp_DEPENDS}
assistantclient_run_DEPENDS= ${assistantclient_DEPENDS}
assistantclient_run_NAME= ${assistantclient_NAME}
+clucene_run_DEPENDS= ${clucene_DEPENDS}
codecs-cn_run_DEPENDS= ${codecs-cn_DEPENDS}
codecs-jp_run_DEPENDS= ${codecs-jp_DEPENDS}
codecs-kr_run_DEPENDS= ${codecs-kr_DEPENDS}
@@ -162,6 +205,8 @@ dbus_run_DEPENDS= ${dbus_DEPENDS}
designer_run_DEPENDS= ${designer_DEPENDS}
doc_run_DEPENDS= ${doc_DEPENDS}
gui_run_DEPENDS= ${gui_DEPENDS}
+help_run_DEPENDS= ${help_DEPENDS}
+help-tools_run_DEPENDS= ${help-tools_DEPENDS}
iconengines_run_DEPENDS= ${iconengines_DEPENDS}
imageformats_run_DEPENDS= ${imageformats_DEPENDS}
inputmethods_run_DEPENDS= ${inputmethods_DEPENDS}
@@ -171,6 +216,8 @@ moc_run_DEPENDS= ${moc_DEPENDS}
network_run_DEPENDS= ${network_DEPENDS}
opengl_run_DEPENDS= ${opengl_DEPENDS}
pixeltool_run_DEPENDS= ${pixeltool_DEPENDS}
+phonon_run_DEPENDS= ${phonon_DEPENDS}
+phonon-gst_run_DEPENDS= ${phonon-gst_DEPENDS}
porting_run_DEPENDS= ${porting_DEPENDS}
qdbusviewer_run_DEPENDS= ${qdbusviewer_DEPENDS}
qmake_run_DEPENDS= ${qmake_DEPENDS}
@@ -184,7 +231,10 @@ sql_run_DEPENDS= ${sql_DEPENDS}
svg_run_DEPENDS= ${svg_DEPENDS}
uic_run_DEPENDS= ${uic_DEPENDS}
uic3_run_DEPENDS= ${uic3_DEPENDS}
+webkit_run_DEPENDS= ${webkit_DEPENDS}
xml_run_DEPENDS= ${xml_DEPENDS}
+xmlpatterns_run_DEPENDS= ${xmlpatterns_DEPENDS}
+xmlpatterns-tool_run_DEPENDS= ${xmlpatterns-tool_DEPENDS}
.if defined(_POSTMKINCLUDED) && !defined(Qt_Post_Include)
Qt_Post_Include= bsd.qt.mk