aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 98e5eaa5bd78..50ef85751cee 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4284,7 +4284,7 @@ _SANITY_SEQ= ${_CHROOT_SEQ} pre-everything check-makefile \
_PKG_DEP= check-sanity
_PKG_SEQ= pkg-depends
-_FETCH_DEP= pkg-depends
+_FETCH_DEP= pkg
_FETCH_SEQ= fetch-depends pre-fetch pre-fetch-script \
do-fetch post-fetch post-fetch-script
_EXTRACT_DEP= fetch
@@ -4329,6 +4329,10 @@ check-sanity: ${_SANITY_SEQ}
fetch: ${_FETCH_DEP} ${_FETCH_SEQ}
.endif
+.if !target(pkg)
+pkg: ${_PKG_DEP} ${_PKG_SEQ}
+.endif
+
# Main logic. The loop generates 6 main targets and using cookies
# ensures that those already completed are skipped.