aboutsummaryrefslogtreecommitdiff
path: root/Mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Scripts/do-patch.sh4
-rw-r--r--Mk/bsd.port.mk5
2 files changed, 9 insertions, 0 deletions
diff --git a/Mk/Scripts/do-patch.sh b/Mk/Scripts/do-patch.sh
index 25f7dfcbdadb..a44208545c3a 100644
--- a/Mk/Scripts/do-patch.sh
+++ b/Mk/Scripts/do-patch.sh
@@ -115,3 +115,7 @@ fi
patch_from_directory "${dp_PATCHDIR}" "${dp_OPSYS}"
+if [ -n "${dp_EXTRA_PATCH_TREE}" ]; then
+ patch_from_directory "${dp_EXTRA_PATCH_TREE}/${dp_PKGORIGIN}" "local"
+fi
+
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 8fc714d83aa1..de136bc261a0 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -749,6 +749,11 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# The patches specified by this variable will be
# applied after the normal distribution patches but
# before those in ${PATCHDIR}.
+# EXTRA_PATCH_TREE - where to find extra 'out-of-tree' patches
+# Points to a directory hierarchy with the same layout
+# as the ports tree, where local patches can be found.
+# This allows a third party to keep their patches in
+# some other source control system if needed.
# PATCH_WRKSRC - Directory to apply patches in.
# Default: ${WRKSRC}
#