aboutsummaryrefslogtreecommitdiff
path: root/Tools/scripts/notconnected
diff options
context:
space:
mode:
Diffstat (limited to 'Tools/scripts/notconnected')
-rwxr-xr-xTools/scripts/notconnected43
1 files changed, 43 insertions, 0 deletions
diff --git a/Tools/scripts/notconnected b/Tools/scripts/notconnected
new file mode 100755
index 000000000000..66bcae484190
--- /dev/null
+++ b/Tools/scripts/notconnected
@@ -0,0 +1,43 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# MAINTAINER= pgollucci@FreeBSD.org
+# all committers may commit to this file without approval
+
+PATH=/rescue:$PATH
+
+if [ -z "$PORTSDIR" ]; then
+ PORTSDIR=/usr/ports
+fi
+
+echo "****************** No entry for dir in category Makefile"
+#### dir -> Makefile
+cd $PORTSDIR
+
+ports=$(find $PORTSDIR -type d -depth 2 | egrep -v 'CVS|.git|Tools')
+for port in $ports; do
+ cat=$(echo $port |awk -F'/' '{print $1}')
+ portname=$(echo $port |awk -F'/' '{print $2}')
+
+ rc=$(grep -c " $portname$" $PORTSDIR/$cat/Makefile)
+ if [ $rc -ne 1 ]; then
+ echo "$cat/$portname"
+ fi
+done
+
+echo "***************** No corresponding dir for category Makefile entry"
+#### Makefile -> dir
+cd $PORTSDIR
+categories=$(ls -1d * |grep -v [A-Z] |grep -v distfiles)
+
+for cat in $categories; do
+ cd $PORTSDIR/$cat
+ ports=$(grep SUBDIR Makefile |awk '{print $3}')
+ for port in $ports; do
+ if [ ! -d $port ]; then
+ echo "$cat/$port"
+ fi
+ done
+done
+