aboutsummaryrefslogtreecommitdiff
path: root/accessibility/dasher
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/dasher')
-rw-r--r--accessibility/dasher/Makefile14
-rw-r--r--accessibility/dasher/distinfo6
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp36
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_SimpleTimer.cpp44
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp51
-rw-r--r--accessibility/dasher/files/patch-Src_DasherCore_UserLog.cpp41
-rw-r--r--accessibility/dasher/files/patch-Src_Gtk2_speech.cc14
-rw-r--r--accessibility/dasher/files/patch-configure11
-rw-r--r--accessibility/dasher/pkg-plist25
9 files changed, 222 insertions, 20 deletions
diff --git a/accessibility/dasher/Makefile b/accessibility/dasher/Makefile
index 445df1ae2890..df97a89f56dd 100644
--- a/accessibility/dasher/Makefile
+++ b/accessibility/dasher/Makefile
@@ -3,26 +3,25 @@
# Whom: lewiz <purple@lewiz.net>
#
# $FreeBSD$
-# $MCom: ports/accessibility/dasher/Makefile,v 1.18 2005/10/29 22:31:15 marcus Exp $
+# $MCom: ports/accessibility/dasher/Makefile,v 1.34 2006/04/13 07:52:29 bland Exp $
#
PORTNAME= dasher
-PORTVERSION= 3.2.18
-PORTREVISION= 1
+PORTVERSION= 4.0.2
PORTEPOCH= 1
CATEGORIES= accessibility editors x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/3.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= lewiz@compsoc.man.ac.uk
COMMENT= Information efficient text-entry interface
BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi \
@@ -30,7 +29,7 @@ USE_GNOME= gnomeprefix gnomehack intlhack gnomehier libgnomeui atspi \
WANT_GNOME= yes
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
-USE_REINPLACE= yes
+INSTALLS_ICONS= yes
USE_GCC= 3.4+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -41,8 +40,7 @@ MAN1= dasher.1
.if ${HAVE_GNOME:Mgnomespeech}!=""
USE_GNOME+= gnomespeech
-.else
-CONFIGURE_ARGS+=--without-speech
+CONFIGURE_ARGS+=--enable-speech
.endif
post-patch:
diff --git a/accessibility/dasher/distinfo b/accessibility/dasher/distinfo
index 4bfa1d52313b..0af9bb63a4bc 100644
--- a/accessibility/dasher/distinfo
+++ b/accessibility/dasher/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/dasher-3.2.18.tar.bz2) = f724113d3148a3c7f888b9e830ae75af
-SHA256 (gnome2/dasher-3.2.18.tar.bz2) = a58ec285fb908dddde468794def6538ef2930a1e273d0b24d11a627ddbe02ee9
-SIZE (gnome2/dasher-3.2.18.tar.bz2) = 4758337
+MD5 (gnome2/dasher-4.0.2.tar.bz2) = 47cf27594abb51ea97f3a8fdb276736d
+SHA256 (gnome2/dasher-4.0.2.tar.bz2) = 4a4adb18ca80641319ffdb63c8cbd69f2faa0698b4d275a2b3ccae467de8d73c
+SIZE (gnome2/dasher-4.0.2.tar.bz2) = 5802684
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp b/accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp
new file mode 100644
index 000000000000..da5a022d06c5
--- /dev/null
+++ b/accessibility/dasher/files/patch-Src_DasherCore_FileLogger.cpp
@@ -0,0 +1,36 @@
+--- Src/DasherCore/FileLogger.cpp.orig Tue Jan 17 01:41:44 2006
++++ Src/DasherCore/FileLogger.cpp Tue Jan 17 01:51:33 2006
+@@ -17,7 +17,7 @@ static char THIS_FILE[] = __FILE__;
+ #include <windows.h>
+ #endif
+
+-#include <sys/timeb.h>
++#include <sys/time.h>
+
+ CFileLogger::CFileLogger(const std::string& strFilenamePath, eLogLevel iLogLevel, int iOptionsMask)
+ {
+@@ -492,12 +492,12 @@ std::string CFileLogger::GetTimeDateStam
+
+ if ((m_bTimeStamp) || (m_bDateStamp))
+ {
+- struct timeb sTimeBuffer;
++ struct timeval sTimeBuffer;
+ char* szTimeLine = NULL;
+
+- ftime(&sTimeBuffer);
++ gettimeofday(&sTimeBuffer, NULL);
+
+- szTimeLine = ctime(&(sTimeBuffer.time));
++ szTimeLine = ctime((const time_t *)&(sTimeBuffer.tv_sec));
+
+ // Format is:
+ // Wed Jun 22 10:22:00 2005
+@@ -520,7 +520,7 @@ std::string CFileLogger::GetTimeDateStam
+ strTimeStamp += szTimeLine[i];
+ strTimeStamp += ".";
+ char strMs[16];
+- sprintf(strMs, "%d", sTimeBuffer.millitm);
++ sprintf(strMs, "%d", (int) (sTimeBuffer.tv_usec / 1000));
+ if (strlen(strMs) == 1)
+ strTimeStamp += "00";
+ else if (strlen(strMs) == 2)
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_SimpleTimer.cpp b/accessibility/dasher/files/patch-Src_DasherCore_SimpleTimer.cpp
new file mode 100644
index 000000000000..d8679afaed3e
--- /dev/null
+++ b/accessibility/dasher/files/patch-Src_DasherCore_SimpleTimer.cpp
@@ -0,0 +1,44 @@
+--- Src/DasherCore/SimpleTimer.cpp.orig Tue Jan 17 01:43:17 2006
++++ Src/DasherCore/SimpleTimer.cpp Tue Jan 17 01:46:24 2006
+@@ -1,6 +1,6 @@
+ #include "SimpleTimer.h"
+
+-#include <sys/timeb.h>
++#include <sys/time.h>
+
+ // Track memory leaks on Windows to the line that new'd the memory
+ #ifdef _WIN32
+@@ -14,12 +14,12 @@ static char THIS_FILE[] = __FILE__;
+
+ CSimpleTimer::CSimpleTimer()
+ {
+- struct timeb sTimeBuffer;
++ struct timeval sTimeBuffer;
+
+- ftime(&sTimeBuffer);
++ gettimeofday(&sTimeBuffer, NULL);
+
+- m_iStartMs = sTimeBuffer.millitm;
+- m_iStartSecond = sTimeBuffer.time;
++ m_iStartMs = (int) (sTimeBuffer.tv_usec / 1000);
++ m_iStartSecond = (int) sTimeBuffer.tv_sec;
+ }
+
+ CSimpleTimer::~CSimpleTimer()
+@@ -28,12 +28,12 @@ CSimpleTimer::~CSimpleTimer()
+
+ double CSimpleTimer::GetElapsed()
+ {
+- struct timeb sTimeBuffer;
++ struct timeval sTimeBuffer;
+
+- ftime(&sTimeBuffer);
++ gettimeofday(&sTimeBuffer, NULL);
+
+- int iEndMs = sTimeBuffer.millitm;
+- int iEndSecond = sTimeBuffer.time;
++ int iEndMs = (int) (sTimeBuffer.tv_usec / 1000);
++ int iEndSecond = (int) sTimeBuffer.tv_sec;
+
+ return ((double) iEndMs / 1000.0 + (double) iEndSecond) -
+ ((double) m_iStartMs / 1000.0 + (double) m_iStartSecond);
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp b/accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp
new file mode 100644
index 000000000000..d5bf37daf0d2
--- /dev/null
+++ b/accessibility/dasher/files/patch-Src_DasherCore_TimeSpan.cpp
@@ -0,0 +1,51 @@
+--- Src/DasherCore/TimeSpan.cpp.orig Tue Jan 17 01:47:12 2006
++++ Src/DasherCore/TimeSpan.cpp Tue Jan 17 01:48:47 2006
+@@ -1,6 +1,6 @@
+
+ #include "TimeSpan.h"
+-#include <sys/timeb.h>
++#include <sys/time.h>
+
+ #ifdef _WIN32
+ // In order to track leaks to line number, we need this at the top of every file
+@@ -102,12 +102,12 @@ string CTimeSpan::GetXML(const string& s
+ string CTimeSpan::GetTimeStamp()
+ {
+ string strTimeStamp = "";
+- struct timeb sTimeBuffer;
++ struct timeval sTimeBuffer;
+ char* szTimeLine = NULL;
+
+- ftime(&sTimeBuffer);
++ gettimeofday(&sTimeBuffer, NULL);
+
+- szTimeLine = ctime(&(sTimeBuffer.time));
++ szTimeLine = ctime((const time_t *)&(sTimeBuffer.tv_sec));
+
+ if ((szTimeLine != NULL) && (strlen(szTimeLine) > 18))
+ {
+@@ -115,7 +115,7 @@ string CTimeSpan::GetTimeStamp()
+ strTimeStamp += szTimeLine[i];
+ strTimeStamp += ".";
+ char szMs[16];
+- sprintf(szMs, "%d", sTimeBuffer.millitm);
++ sprintf(szMs, "%d", (int) (sTimeBuffer.tv_usec / 1000));
+ if (strlen(szMs) == 1)
+ strTimeStamp += "00";
+ else if (strlen(szMs) == 2)
+@@ -163,12 +163,12 @@ string CTimeSpan::GetDateStamp()
+ {
+ std::string strDateStamp = "";
+
+- struct timeb sTimeBuffer;
++ struct timeval sTimeBuffer;
+ char* szTimeLine = NULL;
+
+- ftime(&sTimeBuffer);
++ gettimeofday(&sTimeBuffer, NULL);
+
+- szTimeLine = ctime(&(sTimeBuffer.time));
++ szTimeLine = ctime((const time_t *)&(sTimeBuffer.tv_sec));
+
+ // Format is:
+ // Wed Jun 22 10:22:00 2005
diff --git a/accessibility/dasher/files/patch-Src_DasherCore_UserLog.cpp b/accessibility/dasher/files/patch-Src_DasherCore_UserLog.cpp
new file mode 100644
index 000000000000..2ba6fec10fff
--- /dev/null
+++ b/accessibility/dasher/files/patch-Src_DasherCore_UserLog.cpp
@@ -0,0 +1,41 @@
+--- Src/DasherCore/UserLog.cpp.orig Tue Jan 17 01:49:12 2006
++++ Src/DasherCore/UserLog.cpp Tue Jan 17 01:50:11 2006
+@@ -1,7 +1,7 @@
+
+ #include "UserLog.h"
+ #include <fstream>
+-#include <sys/timeb.h>
++#include <sys/time.h>
+
+ // Track memory leaks on Windows to the line that new'd the memory
+ #ifdef _WIN32
+@@ -624,12 +624,12 @@ void CUserLog::SetOuputFilename(const st
+ {
+ m_strFilename = USER_LOG_DETAILED_PREFIX;
+
+- struct timeb sTimeBuffer;
++ struct timeval sTimeBuffer;
+ char* szTimeLine = NULL;
+
+- ftime(&sTimeBuffer);
++ gettimeofday(&sTimeBuffer, NULL);
+
+- szTimeLine = ctime(&(sTimeBuffer.time));
++ szTimeLine = ctime((const time_t *)&(sTimeBuffer.tv_sec));
+
+ if ((szTimeLine != NULL) && (strlen(szTimeLine) > 18))
+ {
+@@ -829,10 +829,10 @@ bool CUserLog::UpdateMouseLocation()
+ {
+ //CFunctionLogger f1("CUserLog::UpdateMouseLocation", g_pLogger);
+
+- struct timeb sTimeBuffer;
+- ftime(&sTimeBuffer);
++ struct timeval sTimeBuffer;
++ gettimeofday(&sTimeBuffer, NULL);
+
+- double dTime = (sTimeBuffer.time * 1000.0) + sTimeBuffer.millitm;
++ double dTime = (sTimeBuffer.tv_sec * 1000.0) + (int) (sTimeBuffer.tv_usec / 1000);
+
+ if ((dTime - m_dLastMouseUpdate) > LOG_MOUSE_EVERY_MS)
+ {
diff --git a/accessibility/dasher/files/patch-Src_Gtk2_speech.cc b/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
index 7622867dbd57..9817b2f11bb1 100644
--- a/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
+++ b/accessibility/dasher/files/patch-Src_Gtk2_speech.cc
@@ -1,12 +1,10 @@
---- Src/Gtk2/speech.cc.orig Fri Aug 19 09:57:44 2005
-+++ Src/Gtk2/speech.cc Mon Aug 22 20:23:21 2005
-@@ -78,7 +78,8 @@ void setup_speech() {
+--- Src/Gtk2/speech.cc.orig Thu Jan 12 15:52:50 2006
++++ Src/Gtk2/speech.cc Tue Jan 17 01:29:35 2006
+@@ -74,6 +74,7 @@ void setup_speech() {
void teardown_speech() {
- bonobo_object_release_unref (speaker, NULL);
-- CORBA_free (voices);
+ bonobo_object_release_unref(speaker, NULL);
+ if (voices != NULL && !BONOBO_EX (&ev) && voices->_length != 0)
-+ CORBA_free (voices);
+ CORBA_free(voices);
GNOME_Speech_SynthesisDriver_unref(rv, &ev);
- CORBA_exception_free (&ev);
-
+ CORBA_exception_free(&ev);
diff --git a/accessibility/dasher/files/patch-configure b/accessibility/dasher/files/patch-configure
new file mode 100644
index 000000000000..982daaac6663
--- /dev/null
+++ b/accessibility/dasher/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Tue Jan 31 01:13:42 2006
++++ configure Tue Jan 31 01:14:07 2006
+@@ -24818,7 +24818,7 @@
+
+
+ GTK2BUILD_CFLAGS="$GTK2_CFLAGS $SETTINGS_CFLAGS $gthread_CFLAGS $gnome_speech_CFLAGS $gnome_a11y_CFLAGS $glade_CFLAGS $gnome_CFLAGS $wnck_CFLAGS $hildon_CFLAGS"
+-GTK2BUILD_LIBS="$X_LIBS $GTK2_LIBS $SETTINGS_LIBS $gthread_LIBS $gnome_speech_LIBS $gnome_a11y_LIBS $glade_LIBS $gnome_LIBS $wnck_LIBS $hildon_LIBS -Wl,--export-dynamic,"
++GTK2BUILD_LIBS="$X_LIBS $GTK2_LIBS $SETTINGS_LIBS $gthread_LIBS $gnome_speech_LIBS $gnome_a11y_LIBS $glade_LIBS $gnome_LIBS $wnck_LIBS $hildon_LIBS -Wl,--export-dynamic"
+
+
+
diff --git a/accessibility/dasher/pkg-plist b/accessibility/dasher/pkg-plist
index baf14dc3aa72..0e3238b8a829 100644
--- a/accessibility/dasher/pkg-plist
+++ b/accessibility/dasher/pkg-plist
@@ -75,6 +75,7 @@ share/gnome/dasher/alphabet.dtd
share/gnome/dasher/alphabet.dutch.xml
share/gnome/dasher/alphabet.english.xml
share/gnome/dasher/alphabet.englishC.xml
+share/gnome/dasher/alphabet.englishLC.xml
share/gnome/dasher/alphabet.ethiopic.xml
share/gnome/dasher/alphabet.ewe.xml
share/gnome/dasher/alphabet.faroese.xml
@@ -91,6 +92,7 @@ share/gnome/dasher/alphabet.hiragana2.xml
share/gnome/dasher/alphabet.hungarian.xml
share/gnome/dasher/alphabet.ipa.xml
share/gnome/dasher/alphabet.italian.xml
+share/gnome/dasher/alphabet.japanese.canna.xml
share/gnome/dasher/alphabet.kazakh.xml
share/gnome/dasher/alphabet.kirghiz.xml
share/gnome/dasher/alphabet.kirundi.xml
@@ -144,11 +146,15 @@ share/gnome/dasher/colour.rainbow.xml
share/gnome/dasher/colour.vowels.xml
share/gnome/dasher/colour.vowels2.xml
share/gnome/dasher/colour.xml
+share/gnome/dasher/controllabels.dtd
+share/gnome/dasher/controllabels.xml
share/gnome/dasher/dasher.glade
+share/gnome/dasher/dashermaemo.glade
share/gnome/dasher/training_albanian_SQ.txt
share/gnome/dasher/training_basque_EU.txt
share/gnome/dasher/training_bengali_BD.txt
share/gnome/dasher/training_bengali_bn.txt
+share/gnome/dasher/training_canna_JP.txt
share/gnome/dasher/training_czech_CS.txt
share/gnome/dasher/training_danish_DK.txt
share/gnome/dasher/training_dutch_NL.txt
@@ -170,6 +176,7 @@ share/gnome/dasher/training_russian_RU.txt
share/gnome/dasher/training_spanish_ES.txt
share/gnome/dasher/training_swahili_KE.txt
share/gnome/dasher/training_swedish_SE.txt
+share/gnome/dasher/training_turkish_TR.txt
share/gnome/dasher/training_welsh_GB.txt
share/gnome/help/dasher/C/dasher.xml
share/gnome/help/dasher/C/figures/figure2.png
@@ -189,20 +196,23 @@ share/gnome/help/dasher/eu/figures/prefs3.png
share/gnome/help/dasher/eu/figures/prefs4.png
share/gnome/help/dasher/eu/figures/prefs5.png
share/gnome/help/dasher/eu/version.xml
-share/gnome/icons/dasher.png
share/gnome/omf/dasher/dasher-C.omf
share/gnome/omf/dasher/dasher-eu.omf
+share/icons/hicolor/48x48/apps/dasher.png
+share/icons/hicolor/scalable/apps/dasher.svg
share/locale/ar/LC_MESSAGES/dasher.mo
share/locale/az/LC_MESSAGES/dasher.mo
share/locale/be/LC_MESSAGES/dasher.mo
share/locale/bg/LC_MESSAGES/dasher.mo
share/locale/bn/LC_MESSAGES/dasher.mo
+share/locale/br/LC_MESSAGES/dasher.mo
share/locale/bs/LC_MESSAGES/dasher.mo
share/locale/ca/LC_MESSAGES/dasher.mo
share/locale/cs/LC_MESSAGES/dasher.mo
share/locale/cy/LC_MESSAGES/dasher.mo
share/locale/da/LC_MESSAGES/dasher.mo
share/locale/de/LC_MESSAGES/dasher.mo
+share/locale/dz/LC_MESSAGES/dasher.mo
share/locale/el/LC_MESSAGES/dasher.mo
share/locale/en_CA/LC_MESSAGES/dasher.mo
share/locale/en_GB/LC_MESSAGES/dasher.mo
@@ -222,7 +232,9 @@ share/locale/hu/LC_MESSAGES/dasher.mo
share/locale/id/LC_MESSAGES/dasher.mo
share/locale/it/LC_MESSAGES/dasher.mo
share/locale/ja/LC_MESSAGES/dasher.mo
+share/locale/ka/LC_MESSAGES/dasher.mo
share/locale/ko/LC_MESSAGES/dasher.mo
+share/locale/ky/LC_MESSAGES/dasher.mo
share/locale/lt/LC_MESSAGES/dasher.mo
share/locale/mk/LC_MESSAGES/dasher.mo
share/locale/mn/LC_MESSAGES/dasher.mo
@@ -244,14 +256,25 @@ share/locale/sr/LC_MESSAGES/dasher.mo
share/locale/sr@Latn/LC_MESSAGES/dasher.mo
share/locale/sv/LC_MESSAGES/dasher.mo
share/locale/ta/LC_MESSAGES/dasher.mo
+share/locale/th/LC_MESSAGES/dasher.mo
share/locale/tk/LC_MESSAGES/dasher.mo
share/locale/tr/LC_MESSAGES/dasher.mo
share/locale/ug/LC_MESSAGES/dasher.mo
share/locale/uk/LC_MESSAGES/dasher.mo
+share/locale/vi/LC_MESSAGES/dasher.mo
share/locale/zh_CN/LC_MESSAGES/dasher.mo
+share/locale/zh_HK/LC_MESSAGES/dasher.mo
share/locale/zh_TW/LC_MESSAGES/dasher.mo
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/ug/LC_MESSAGES
@dirrmtry share/locale/ug
+@dirrmtry share/locale/ky/LC_MESSAGES
+@dirrmtry share/locale/ky
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/br/LC_MESSAGES
+@dirrmtry share/locale/br
@dirrm share/gnome/omf/dasher
@dirrm share/gnome/help/dasher/eu/figures
@dirrm share/gnome/help/dasher/eu