aboutsummaryrefslogtreecommitdiff
path: root/accessibility/gnome-speech
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/gnome-speech')
-rw-r--r--accessibility/gnome-speech/Makefile2
-rw-r--r--accessibility/gnome-speech/distinfo4
-rw-r--r--accessibility/gnome-speech/files/patch-drivers_festival_festivalsynthesisdriver.c21
3 files changed, 24 insertions, 3 deletions
diff --git a/accessibility/gnome-speech/Makefile b/accessibility/gnome-speech/Makefile
index 3b2544516125..6dff5515607a 100644
--- a/accessibility/gnome-speech/Makefile
+++ b/accessibility/gnome-speech/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnomespeech
-PORTVERSION= 0.3.5
+PORTVERSION= 0.3.6
CATEGORIES= accessibility audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-speech/0.3
diff --git a/accessibility/gnome-speech/distinfo b/accessibility/gnome-speech/distinfo
index c1481e4d4f25..2df3a3d37848 100644
--- a/accessibility/gnome-speech/distinfo
+++ b/accessibility/gnome-speech/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-speech-0.3.5.tar.bz2) = 34382d0b33146b1f8fc5239895471369
-SIZE (gnome2/gnome-speech-0.3.5.tar.bz2) = 255271
+MD5 (gnome2/gnome-speech-0.3.6.tar.bz2) = 1959d2fbc36394308e99b113ac69e576
+SIZE (gnome2/gnome-speech-0.3.6.tar.bz2) = 266492
diff --git a/accessibility/gnome-speech/files/patch-drivers_festival_festivalsynthesisdriver.c b/accessibility/gnome-speech/files/patch-drivers_festival_festivalsynthesisdriver.c
new file mode 100644
index 000000000000..65dfeb2b361d
--- /dev/null
+++ b/accessibility/gnome-speech/files/patch-drivers_festival_festivalsynthesisdriver.c
@@ -0,0 +1,21 @@
+--- drivers/festival/festivalsynthesisdriver.c.orig Tue Jan 11 14:48:51 2005
++++ drivers/festival/festivalsynthesisdriver.c Tue Jan 11 14:50:22 2005
+@@ -33,6 +33,8 @@
+ #include <stdlib.h>
+ #include <libbonobo.h>
+ #include <netdb.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+ #include "festivalsynthesisdriver.h"
+ #include "festivalspeaker.h"
+
+@@ -591,8 +593,8 @@
+ static void
+ voice_list_free (GSList *l)
+ {
+- g_assert (l);
+ GSList *tmp = l;
++ g_assert (l);
+
+ while (tmp)
+ {