aboutsummaryrefslogtreecommitdiff
path: root/accessibility/jovie
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/jovie')
-rw-r--r--accessibility/jovie/Makefile44
-rw-r--r--accessibility/jovie/pkg-descr6
-rw-r--r--accessibility/jovie/pkg-message7
-rw-r--r--accessibility/jovie/pkg-plist57
4 files changed, 114 insertions, 0 deletions
diff --git a/accessibility/jovie/Makefile b/accessibility/jovie/Makefile
new file mode 100644
index 000000000000..d94dfc5ea17c
--- /dev/null
+++ b/accessibility/jovie/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: ktts
+# Date created: 2010-03-27
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ktts
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= accessibility kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DISTNAME= kdeaccessibility-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KDE text-to-speech subsystem
+
+LIB_DEPENDS+= speechd.3:${PORTSDIR}/accessibility/speech-dispatcher
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_KDE4= kdeprefix kdelibs automoc4
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build uic_build rcc_build
+USE_LDCONFIG= yes
+MD5_FILE= ${PORTSDIR}/accessibility/kdeaccessibility4/distinfo
+MAKE_JOBS_SAFE= yes
+
+CMAKE_ARGS+= -DKDE4_KTTSD_ALSA:BOOL=OFF
+
+BUILD_WRKSRC= ${WRKSRC}/kttsd
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|speechd|$$$\{SPEECHD_LIBRARY}|g' \
+ ${PATCH_WRKSRC}/kttsd/kcmkttsmgr/CMakeLists.txt \
+ ${PATCH_WRKSRC}/kttsd/kttsd/CMakeLists.txt
+
+post-install:
+ cd ${WRKSRC}/doc/kttsd && ${MAKE} install
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/accessibility/jovie/pkg-descr b/accessibility/jovie/pkg-descr
new file mode 100644
index 000000000000..682815431bab
--- /dev/null
+++ b/accessibility/jovie/pkg-descr
@@ -0,0 +1,6 @@
+KTTS -- KDE Text-to-Speech -- is a subsystem within the KDE desktop
+for conversion of text to audible speech. KTTS is currently under
+development and aims to become the standard subsystem for all KDE
+applications to provide speech output.
+
+WWW: http://www.kde.org/
diff --git a/accessibility/jovie/pkg-message b/accessibility/jovie/pkg-message
new file mode 100644
index 000000000000..7c6d1ffaf7fa
--- /dev/null
+++ b/accessibility/jovie/pkg-message
@@ -0,0 +1,7 @@
+======================================================================
+
+To enable Text-to-Speech System (KTTSD), you first need to start
+speech-dispatcher daemon (accessibility/speech-dispatcher), either
+locally or with its rc.d script.
+
+======================================================================
diff --git a/accessibility/jovie/pkg-plist b/accessibility/jovie/pkg-plist
new file mode 100644
index 000000000000..8a37a66a9f98
--- /dev/null
+++ b/accessibility/jovie/pkg-plist
@@ -0,0 +1,57 @@
+bin/kttsd
+bin/kttsmgr
+lib/kde4/kcm_kttsd.so
+lib/kde4/libkttsd_stringreplacerplugin.so
+lib/kde4/libkttsd_talkerchooserplugin.so
+lib/kde4/libkttsd_xmltransformerplugin.so
+lib/libkttsd.so
+lib/libkttsd.so.5
+lib/libkttsd.so.5.0.1
+share/applications/kde4/kttsmgr.desktop
+share/apps/kttsd/kcmkttsd_testmessage.desktop
+share/apps/kttsd/stringreplacer/abbreviations.xml
+share/apps/kttsd/stringreplacer/chat-de.xml
+share/apps/kttsd/stringreplacer/chat.xml
+share/apps/kttsd/stringreplacer/emoticons.xml
+share/apps/kttsd/stringreplacer/festival_unspeakable_chars.xml
+share/apps/kttsd/stringreplacer/kmail.xml
+share/apps/kttsd/stringreplacer/polish_festival_fixes.xml
+share/apps/kttsd/stringreplacer/polish_festival_unspeakables.xml
+share/apps/kttsd/stringreplacer/qt2plaintext.xml
+share/apps/kttsd/talkerchooser/female_notifications_rc
+share/apps/kttsd/xmltransformer/xhtml2ssml.xsl
+share/apps/kttsd/xmltransformer/xhtml2ssml_simple.xsl
+share/apps/kttsd/xslt/SSMLtoPlainText.xsl
+share/doc/HTML/en/kttsd/addtalker.png
+share/doc/HTML/en/kttsd/common
+share/doc/HTML/en/kttsd/filters.png
+share/doc/HTML/en/kttsd/general.png
+share/doc/HTML/en/kttsd/index.cache.bz2
+share/doc/HTML/en/kttsd/index.docbook
+share/doc/HTML/en/kttsd/jobs.png
+share/doc/HTML/en/kttsd/stringreplacer.png
+share/doc/HTML/en/kttsd/talkerchooser.png
+share/doc/HTML/en/kttsd/talkers.png
+share/doc/HTML/en/kttsd/xmltransformer.png
+share/icons/hicolor/16x16/actions/female.png
+share/icons/hicolor/16x16/actions/male.png
+share/icons/hicolor/16x16/actions/nospeak.png
+share/icons/hicolor/16x16/actions/speak.png
+share/icons/hicolor/22x22/actions/nospeak.png
+share/icons/hicolor/22x22/actions/speak.png
+share/icons/hicolor/32x32/actions/nospeak.png
+share/icons/hicolor/32x32/actions/speak.png
+share/icons/hicolor/48x48/actions/nospeak.png
+share/icons/hicolor/48x48/actions/speak.png
+share/kde4/services/kcmkttsd.desktop
+share/kde4/services/kttsd.desktop
+share/kde4/services/kttsd_stringreplacerplugin.desktop
+share/kde4/services/kttsd_talkerchooserplugin.desktop
+share/kde4/services/kttsd_xmltransformerplugin.desktop
+share/kde4/servicetypes/kttsd_filterplugin.desktop
+@dirrm share/doc/HTML/en/kttsd
+@dirrm share/apps/kttsd/xslt
+@dirrm share/apps/kttsd/xmltransformer
+@dirrm share/apps/kttsd/talkerchooser
+@dirrm share/apps/kttsd/stringreplacer
+@dirrm share/apps/kttsd