aboutsummaryrefslogtreecommitdiff
path: root/accessibility/kmag/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/kmag/Makefile')
-rw-r--r--accessibility/kmag/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/accessibility/kmag/Makefile b/accessibility/kmag/Makefile
index 351732671ed2..bd6f58c07da6 100644
--- a/accessibility/kmag/Makefile
+++ b/accessibility/kmag/Makefile
@@ -6,7 +6,6 @@
PORTNAME= kdeaccessibility
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= accessibility kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -22,13 +21,24 @@ USE_KDE4= kdelibs kdeprefix kdehier automoc4
KDE4_BUILDENV= yes
USE_QT_VER= 4
QT_COMPONENTS= opengl gui qmake_build moc_build rcc_build uic_build
-USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-CMAKE_ARGS+= -DKDE4_KTTSD_ALSA:BOOL=OFF
-
MAN1= kmag.1 \
kmousetool.1 \
kmouth.1
+OPTIONS= KTTS "Enable KTTS speech service" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_KTTS)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/kttsd:${PORTSDIR}/accessibility/ktts
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e '/macro_optional_add_subdirectory.*kttsd/d' \
+ ${PATCH_WRKSRC}/CMakeLists.txt
+ ${REINPLACE_CMD} -e '/add_subdirectory.*kttsd/d' \
+ ${PATCH_WRKSRC}/doc/CMakeLists.txt
+
.include <bsd.port.mk>