aboutsummaryrefslogtreecommitdiff
path: root/archivers/ark/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/ark/Makefile')
-rw-r--r--archivers/ark/Makefile38
1 files changed, 9 insertions, 29 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index fd18c7ac3fb0..3163616cd341 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -1,46 +1,26 @@
# New ports collection makefile for: kdeutils2
-# Date created: Sun 14 May 2000 02:52:20
-# Whom: Will Andrews <will@FreeBSD.org>
+# Date created: 3 November 2001
+# Whom: will@cvs.kde.org
#
# $FreeBSD$
#
PORTNAME= kdeutils
-PORTVERSION= 2.2.2
+PORTVERSION= 3.0
CATEGORIES?= misc kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+MASTER_SITES= http://www.csociety.org/~will/kde/${PORTVERSION}/
DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
-BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14
-
-USE_KDELIBS_VER=2
+#WRKSRC= ${WRKDIR}/kdeutils
+USE_KDELIBS_VER=3
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
MAN1= efax.1 efix.1 fax.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500029
-_NO_KDE_OBJPRELINK=yes
-.endif
-
-.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
-
-pre-configure:
- ${MKDIR} ${WRKSRC}/auto-bin
-.for AC in autoconf autoheader
- ${LN} -sf ${LOCALBASE}/bin/${AC}213 ${WRKSRC}/auto-bin/${AC}
-.endfor
-.for AM in automake aclocal
- ${LN} -sf ${LOCALBASE}/bin/${AM}14 ${WRKSRC}/auto-bin/${AM}
-.endfor
- cd ${WRKSRC} && env PATH=${WRKSRC}/auto-bin:$$PATH \
- ${GMAKE} -f Makefile.cvs
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>