aboutsummaryrefslogtreecommitdiff
path: root/archivers/brotli/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/brotli/Makefile')
-rw-r--r--archivers/brotli/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/archivers/brotli/Makefile b/archivers/brotli/Makefile
index 99f6bd5b674b..f770ffb243ee 100644
--- a/archivers/brotli/Makefile
+++ b/archivers/brotli/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= brotli
-PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTVERSION= 1.0.2
DISTVERSIONPREFIX= v
PORTEPOCH= 1
CATEGORIES= archivers devel
@@ -17,14 +16,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= google
-USES= cmake compiler:c++0x pkgconfig
+USES= autoreconf:build compiler:c++0x gmake libtool pkgconfig
USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
-CMAKE_ARGS= -DBUILD_TESTING:BOOL=OFF
+INSTALL_TARGET= install-strip
+PLIST_SUB= SHLIBVER=${PORTVERSION}
-post-install:
- ${LN} -s libbrotlicommon.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libbrotlicommon.so.0
- ${LN} -s libbrotlidec.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libbrotlidec.so.0
- ${LN} -s libbrotlienc.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libbrotlienc.so.0
+pre-configure:
+ (cd ${WRKSRC} && ./bootstrap)
.include <bsd.port.mk>