aboutsummaryrefslogtreecommitdiff
path: root/archivers/cabextract
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/cabextract')
-rw-r--r--archivers/cabextract/Makefile2
-rw-r--r--archivers/cabextract/distinfo4
-rw-r--r--archivers/cabextract/files/patch-configure120
-rw-r--r--archivers/cabextract/pkg-descr2
4 files changed, 124 insertions, 4 deletions
diff --git a/archivers/cabextract/Makefile b/archivers/cabextract/Makefile
index 1479ef156140..924398d82a0c 100644
--- a/archivers/cabextract/Makefile
+++ b/archivers/cabextract/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cabextract
-PORTVERSION= 1.0
+PORTVERSION= 1.1
CATEGORIES= archivers
MASTER_SITES= http://www.kyz.uklinux.net/downloads/
diff --git a/archivers/cabextract/distinfo b/archivers/cabextract/distinfo
index c6516fb1d01a..39943bb59da4 100644
--- a/archivers/cabextract/distinfo
+++ b/archivers/cabextract/distinfo
@@ -1,2 +1,2 @@
-MD5 (cabextract-1.0.tar.gz) = 8fde8ad86f7144943b7e4e5a2da7eddb
-SIZE (cabextract-1.0.tar.gz) = 189625
+MD5 (cabextract-1.1.tar.gz) = f4b729c0be7d288660f4fc167de199a1
+SIZE (cabextract-1.1.tar.gz) = 187495
diff --git a/archivers/cabextract/files/patch-configure b/archivers/cabextract/files/patch-configure
new file mode 100644
index 000000000000..b83d42091ef8
--- /dev/null
+++ b/archivers/cabextract/files/patch-configure
@@ -0,0 +1,120 @@
+--- configure.orig Mon Oct 18 17:10:34 2004
++++ configure Mon Oct 18 22:42:46 2004
+@@ -6609,117 +6650,6 @@
+
+
+
+-for ac_func in mempcpy
+-do
+-as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
+-echo "$as_me:$LINENO: checking for $ac_func" >&5
+-echo $ECHO_N "checking for $ac_func... $ECHO_C" >&6
+-if eval "test \"\${$as_ac_var+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-/* Define $ac_func to an innocuous variant, in case <limits.h> declares $ac_func.
+- For example, HP-UX 11i <limits.h> declares gettimeofday. */
+-#define $ac_func innocuous_$ac_func
+-
+-/* System header to define __stub macros and hopefully few prototypes,
+- which can conflict with char $ac_func (); below.
+- Prefer <limits.h> to <assert.h> if __STDC__ is defined, since
+- <limits.h> exists even on freestanding compilers. */
+-
+-#ifdef __STDC__
+-# include <limits.h>
+-#else
+-# include <assert.h>
+-#endif
+-
+-#undef $ac_func
+-
+-/* Override any gcc2 internal prototype to avoid an error. */
+-#ifdef __cplusplus
+-extern "C"
+-{
+-#endif
+-/* We use char because int might match the return type of a gcc2
+- builtin and then its argument prototype would still apply. */
+-char $ac_func ();
+-/* The GNU C library defines this for functions which it implements
+- to always fail with ENOSYS. Some functions are actually named
+- something starting with __ and the normal name is an alias. */
+-#if defined (__stub_$ac_func) || defined (__stub___$ac_func)
+-choke me
+-#else
+-char (*f) () = $ac_func;
+-#endif
+-#ifdef __cplusplus
+-}
+-#endif
+-
+-int
+-main ()
+-{
+-return f != $ac_func;
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>conftest.er1
+- ac_status=$?
+- grep -v '^ *+' conftest.er1 >conftest.err
+- rm -f conftest.er1
+- cat conftest.err >&5
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; } &&
+- { ac_try='test -s conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- eval "$as_ac_var=yes"
+-else
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-eval "$as_ac_var=no"
+-fi
+-rm -f conftest.err conftest.$ac_objext \
+- conftest$ac_exeext conftest.$ac_ext
+-fi
+-echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_var'}'`" >&5
+-echo "${ECHO_T}`eval echo '${'$as_ac_var'}'`" >&6
+-if test `eval echo '${'$as_ac_var'}'` = yes; then
+- cat >>confdefs.h <<_ACEOF
+-#define `echo "HAVE_$ac_func" | $as_tr_cpp` 1
+-_ACEOF
+-
+-else
+- case $LIBOBJS in
+- "$ac_func.$ac_objext" | \
+- *" $ac_func.$ac_objext" | \
+- "$ac_func.$ac_objext "* | \
+- *" $ac_func.$ac_objext "* ) ;;
+- *) LIBOBJS="$LIBOBJS $ac_func.$ac_objext" ;;
+-esac
+-
+-fi
+-done
+-
+-
+-
+ ac_config_files="$ac_config_files Makefile cabextract.spec"
+
+ cat >confcache <<\_ACEOF
diff --git a/archivers/cabextract/pkg-descr b/archivers/cabextract/pkg-descr
index c2d52d16a010..68c9757c80de 100644
--- a/archivers/cabextract/pkg-descr
+++ b/archivers/cabextract/pkg-descr
@@ -1,3 +1,3 @@
A program to extract Microsoft cabinet (.CAB) files.
-WWW: http://www.kyz.uklinux.net/cabextract.php3
+WWW: http://www.kyz.uklinux.net/cabextract.php