aboutsummaryrefslogtreecommitdiff
path: root/archivers/dact/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/dact/Makefile')
-rw-r--r--archivers/dact/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/archivers/dact/Makefile b/archivers/dact/Makefile
index 39d61dd298bf..96cad62206f0 100644
--- a/archivers/dact/Makefile
+++ b/archivers/dact/Makefile
@@ -8,7 +8,6 @@
PORTNAME= dact
PORTVERSION= 0.8.41
-PORTREVISION= 0
CATEGORIES= archivers
MASTER_SITES= http://www.rkeene.org/files/oss/dact/release/
@@ -31,12 +30,17 @@ MAKE_ARGS= CONF=${EXAMPLESDIR}/dact.conf \
MAN1= dact.1
INSTALLS_SHLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e "s|prefix = @prefix@|prefix = ${TARGETDIR}|" \
+ -e "s|libdir = @libdir@|libdir = ${TARGETDIR}/lib|" \
+ ${WRKSRC}/Makefile.in
+
pre-install:
@${MKDIR} ${EXAMPLESDIR}
@${RM} -f ${WRKSRC}/libdact.a
post-install:
- @${CP} -n ${EXAMPLESDIR}/dact.conf ${PREFIX}/etc
+ @${CP} -n ${EXAMPLESDIR}/dact.conf ${TARGETDIR}/etc
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Docs/dact.txt ${DOCSDIR}