aboutsummaryrefslogtreecommitdiff
path: root/archivers/deb2targz/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/deb2targz/Makefile')
-rw-r--r--archivers/deb2targz/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/archivers/deb2targz/Makefile b/archivers/deb2targz/Makefile
new file mode 100644
index 000000000000..b847e9607cfa
--- /dev/null
+++ b/archivers/deb2targz/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: deb2targz
+# Date created: 27 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= deb2targz
+PORTVERSION= 20021217
+CATEGORIES= archivers perl5
+MASTER_SITES= http://critical.ch/distfiles/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command-line utility for converting a Debian .deb file to a .tar.gz
+
+USE_PERL5= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/deb2targz
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>