aboutsummaryrefslogtreecommitdiff
path: root/archivers/dynamite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/dynamite/Makefile')
-rw-r--r--archivers/dynamite/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/archivers/dynamite/Makefile b/archivers/dynamite/Makefile
new file mode 100644
index 000000000000..514958e39a85
--- /dev/null
+++ b/archivers/dynamite/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: dynamite
+# Date Created: 10 January 2005
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dynamite
+PORTVERSION= 0.1
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= Decompress data compressed with PKWARE Data Compression Library
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's|<stdint.h>|<inttypes.h>|' \
+ ${WRKSRC}/lib/libdynamite.c
+.endif
+
+.include <bsd.port.post.mk>