aboutsummaryrefslogtreecommitdiff
path: root/archivers/file-roller/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/file-roller/Makefile')
-rw-r--r--archivers/file-roller/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
index 35ef9f1d2aca..853254c9f638 100644
--- a/archivers/file-roller/Makefile
+++ b/archivers/file-roller/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= fileroller
-PORTVERSION= 2.6.2
+PORTVERSION= 2.8.3
PORTEPOCH= 1
CATEGORIES= archivers gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/file-roller/2.6
+MASTER_SITE_SUBDIR= sources/file-roller/2.8
DISTNAME= file-roller-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,19 +20,19 @@ COMMENT= An archive manager for zip files, tar, etc
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui lthack
-USE_INC_LIBTOOL_VER=13
+USE_GNOME= gnomeprefix intlhack gnomehack libgnomeui desktopfileutils
+USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.pre.mk>
+GCONF_SCHEMAS= file-roller.schemas
-post-install:
.if !defined(NOPORTDOCS)
+post-install:
${MKDIR} ${DOCSDIR}
.for f in AUTHORS NEWS README TODO
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>