aboutsummaryrefslogtreecommitdiff
path: root/archivers/file-roller/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/file-roller/Makefile')
-rw-r--r--archivers/file-roller/Makefile28
1 files changed, 10 insertions, 18 deletions
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
index 503596e8aa34..74ad94c6dc47 100644
--- a/archivers/file-roller/Makefile
+++ b/archivers/file-roller/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= file-roller
-PORTVERSION= 3.26.1
+PORTVERSION= 3.28.0
PORTEPOCH= 1
CATEGORIES= archivers gnome
MASTER_SITES= GNOME
-DIST_SUBDIR= gnome3
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Archive manager for zip files, tar, etc
@@ -21,35 +21,27 @@ RUN_DEPENDS= gtar:archivers/gtar
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake libarchive libtool \
- localbase pathfix pkgconfig tar:xz
-USE_GNOME= cairo gtk30 intlhack introspection:build
-USE_XORG= sm
+USES= desktop-file-utils gettext libarchive localbase \
+ meson pkgconfig python:3.5+,build tar:xz
+USE_GNOME= cairo gtk30
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-packagekit
-INSTALL_TARGET= install-strip
+MESON_ARGS= -Dpackagekit=false
+BINARY_ALIAS= python3=${PYTHON_VERSION}
-PORTDOCS= AUTHORS NEWS README TODO ChangeLog
GLIB_SCHEMAS= org.gnome.FileRoller.gschema.xml
OPTIONS_SUB= yes
-OPTIONS_DEFINE= DOCS NAUTILUS
+OPTIONS_DEFINE= NAUTILUS
OPTIONS_DEFAULT=NAUTILUS
+
NAUTILUS_DESC= Nautilus context menu actions
NAUTILUS_USE= GNOME=nautilus3
-NAUTILUS_CONFIGURE_ENABLE= nautilus-actions
+NAUTILUS_MESON_TRUE= nautilus-actions
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/src/fr-command-tar.c \
${WRKSRC}/src/fr-command-zip.c
-post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}/${DOCSDIR}
-.endfor
-
.include <bsd.port.mk>