aboutsummaryrefslogtreecommitdiff
path: root/archivers/lha-ac/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/lha-ac/Makefile')
-rw-r--r--archivers/lha-ac/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/archivers/lha-ac/Makefile b/archivers/lha-ac/Makefile
new file mode 100644
index 000000000000..6974631eb359
--- /dev/null
+++ b/archivers/lha-ac/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: lha-autoconf
+# Date created: 24 Sep 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= lha
+PORTVERSION= 1.14i
+PORTREVISION= 7
+CATEGORIES= archivers
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP} \
+ http://qgpop.dl.sourceforge.jp/%SUBDIR%/ \
+ http://osdn.dl.sourceforge.jp/%SUBDIR%/
+MASTER_SITE_SUBDIR= lha/6052
+PKGNAMESUFFIX= -ac${PKGNAMESUFFIX2}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-ac20030921
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Archive files using LZSS and Huffman compression (.lzh files)
+
+MAN1= lha.1
+MANLANG= ja
+PLIST_FILES= bin/lha
+PLIST_DIRS= man/ja/man1
+GNU_CONFIGURE= yes
+
+RESTRICTED= "no permission to redistribute"
+NO_PACKAGE= ${RESTRICTED}
+
+.if !defined(WITHOUT_NLS)
+CONFIGURE_ARGGS+= --disable-multibyte-filename
+.else
+CONFIGURE_ARGGS+= --enable-multibyte-filename=auto
+.endif
+
+do-install:
+ -${MKDIR} ${MANPREFIX}/man/ja/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/lha ${PREFIX}/bin/lha
+ ${INSTALL_MAN} ${WRKSRC}/man/lha.n ${MANPREFIX}/man/ja/man1/lha.1
+
+.include <bsd.port.mk>