aboutsummaryrefslogtreecommitdiff
path: root/archivers/lha
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/lha')
-rw-r--r--archivers/lha/Makefile19
-rw-r--r--archivers/lha/distinfo1
-rw-r--r--archivers/lha/files/patch-aa131
-rw-r--r--archivers/lha/pkg-comment1
-rw-r--r--archivers/lha/pkg-descr26
-rw-r--r--archivers/lha/pkg-plist2
6 files changed, 0 insertions, 180 deletions
diff --git a/archivers/lha/Makefile b/archivers/lha/Makefile
deleted file mode 100644
index bf4b89bb5703..000000000000
--- a/archivers/lha/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-# New ports collection makefile for: lha
-# Version required: 1.01u
-# Date created: 26 Dec 1994
-# Whom: ache
-#
-# $Id: Makefile,v 1.2 1995/04/01 12:43:26 jkh Exp $
-#
-
-DISTNAME= lha101u
-PKGNAME= lha-1.01u
-CATEGORIES+= archivers
-MASTER_SITES= ftp://garbo.uwasa.fi/unix/arcers/
-EXTRACT_SUFX= .tar.Z
-
-MAINTAINER= ache@FreeBSD.ORG
-
-NO_WRKSUBDIR= yes
-
-.include <bsd.port.mk>
diff --git a/archivers/lha/distinfo b/archivers/lha/distinfo
deleted file mode 100644
index f1e2c7ce7a94..000000000000
--- a/archivers/lha/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (lha101u.tar.Z) = 9382c787fec1298d6b6cc78b2630f37c
diff --git a/archivers/lha/files/patch-aa b/archivers/lha/files/patch-aa
deleted file mode 100644
index da61488376ae..000000000000
--- a/archivers/lha/files/patch-aa
+++ /dev/null
@@ -1,131 +0,0 @@
-*** ./src/lharc.h.old Fri Apr 24 20:01:24 1992
---- ./src/lharc.h Mon Dec 26 11:39:42 1994
-***************
-*** 12,17 ****
---- 12,23 ----
- #include <sys/types.h>
- #include <sys/file.h>
- #include <sys/stat.h>
-+ #ifdef __FreeBSD__
-+ #include <stdlib.h>
-+ #include <unistd.h>
-+ #include <utime.h>
-+ #include <memory.h>
-+ #endif
-
- #include <signal.h>
-
-*** ./src/header.c.old Fri Apr 24 20:01:18 1992
---- ./src/header.c Mon Dec 26 11:27:48 1994
-***************
-*** 302,308 ****
- dostm.tm_mday = t >> 16 & 0x1f;
- dostm.tm_mon = (t >> 16+5 & 0x0f) - 1; /* 0..11 */
- dostm.tm_year = (t >> 16+9 & 0x7f) + 80;
-! dostm.tm_isdst = 0; /* correct? */
- #ifdef MKTIME
- return (time_t)mktime(&dostm);
- #else /* maybe defined(TIMELOCAL) */
---- 302,308 ----
- dostm.tm_mday = t >> 16 & 0x1f;
- dostm.tm_mon = (t >> 16+5 & 0x0f) - 1; /* 0..11 */
- dostm.tm_year = (t >> 16+9 & 0x7f) + 80;
-! dostm.tm_isdst = -1; /* mktime try to guess for negative value */
- #ifdef MKTIME
- return (time_t)mktime(&dostm);
- #else /* maybe defined(TIMELOCAL) */
-*** ./src/lhext.c.old Wed Sep 23 18:51:48 1992
---- ./src/lhext.c Mon Dec 26 11:10:11 1994
-***************
-*** 130,141 ****
---- 130,151 ----
- char *name;
- LzHeader *hdr;
- {
-+ #ifdef __FreeBSD__
-+ struct utimbuf utimebuf;
-+ uid_t myuid;
-+ #else
- time_t utimebuf[2];
- unsigned myuid;
-+ #endif
-
- /* adjust file stamp */
-+ #ifdef __FreeBSD__
-+ utimebuf.actime = utimebuf.modtime = hdr->unix_last_modified_stamp;
-+ utime (name, &utimebuf);
-+ #else
- utimebuf[0] = utimebuf[1] = hdr->unix_last_modified_stamp;
- utime (name, utimebuf);
-+ #endif
-
- if (hdr->extend_type == EXTEND_UNIX
- || hdr->extend_type == EXTEND_OS68K
-*** ./src/lhlist.c.old Sun May 3 01:27:32 1992
---- ./src/lhlist.c Mon Dec 26 10:59:33 1994
-***************
-*** 25,33 ****
- long packed_size, original_size;
- {
- if (verbose_listing)
-! printf ("%7d ", packed_size);
-
-! printf ("%7d ", original_size);
-
- if (original_size == 0L)
- printf ("******");
---- 25,33 ----
- long packed_size, original_size;
- {
- if (verbose_listing)
-! printf ("%7ld ", packed_size);
-
-! printf ("%7ld ", original_size);
-
- if (original_size == 0L)
- printf ("******");
-*** ./Makefile.old Wed Sep 23 23:29:48 1992
---- ./Makefile Mon Dec 26 11:52:27 1994
-***************
-*** 13,31 ****
- CC = cc
-
- # For Sun/SunOS 4.x:
-! SWITCHES = -DUSESTRCASECMP # -DEUC
- # For Amdahl/UTS:
- #SWITCHES = -DUSG -DSYSTIME_HAS_NO_TM -DNOBSTRING -DNOINDEX -DNOSTRDUP\
- # -DFTIME -DTZSET -DSYSV_SYSTEM_DIR -DNOFTRUNCATE -DNOMKDIR
-
- #OPTIMIZE = -g # -O -fstrength-reduce -fomit-frame-pointer
-! OPTIMIZE = -O
-
- BINDIR = /usr/local/bin
- MANDIR = /usr/local/man
-! MANSECT = n
-
-! INSTALL = install
- INSTALLBIN = -s -m 755
- INSTALLMAN = -m 644
-
---- 13,33 ----
- CC = cc
-
- # For Sun/SunOS 4.x:
-! #SWITCHES = -DUSESTRCASECMP # -DEUC
- # For Amdahl/UTS:
- #SWITCHES = -DUSG -DSYSTIME_HAS_NO_TM -DNOBSTRING -DNOINDEX -DNOSTRDUP\
- # -DFTIME -DTZSET -DSYSV_SYSTEM_DIR -DNOFTRUNCATE -DNOMKDIR
-+ # For FreeBSD
-+ SWITCHES = -DUSESTRCASECMP -DMKTIME -DSYSV_SYSTEM_DIR
-
- #OPTIMIZE = -g # -O -fstrength-reduce -fomit-frame-pointer
-! OPTIMIZE = -O2
-
- BINDIR = /usr/local/bin
- MANDIR = /usr/local/man
-! MANSECT = 1
-
-! INSTALL = install -c -o bin -g bin
- INSTALLBIN = -s -m 755
- INSTALLMAN = -m 644
-
diff --git a/archivers/lha/pkg-comment b/archivers/lha/pkg-comment
deleted file mode 100644
index b0765cd33010..000000000000
--- a/archivers/lha/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-LHA - version 101u. Compress/uncompress files using LZW compression (.lzh files)
diff --git a/archivers/lha/pkg-descr b/archivers/lha/pkg-descr
deleted file mode 100644
index 7b9964c44df6..000000000000
--- a/archivers/lha/pkg-descr
+++ /dev/null
@@ -1,26 +0,0 @@
-From File: README.grr 23 Sep 92
-
-This is LHa for Unix, version 1.01u. This is an unofficially patched
-version (hence `u') of LHa 1.00, which was posted around 1 Apr 92 to
-fj.sources and reposted by me to alt.sources on 24 Apr 92.
-
-I also posted to alt.sources on 24 April an unofficial patch to allow
-the use of default .lzh extensions. Tom Kloos then sent me on 2 May a
-patch to extend the use of special permissions, restore the UID and GID,
-etc. (see below); Jean-Pierre Radley sent on 26 June a patch which sets
-default .lzh extensions much more elegantly and reliably than mine (also
-see below). Finally, I fixed bugs in Tom's chown() patch and in util.c
-(the latter causing compilation errors on a SysV machine). All of the
-patches in my possession have now been integrated into these sources
-and tested to some extent (as of 23 Sep 92). The original sources may
-be regenerated by reverse-patching the context diff file "lha101u.dif".
-
-Please note that this is the limit of my involvement with this program.
-If you find problems or have subsequent patches, I would appreciate
-hearing about them, but distributing them is up to you. I do not know
-enough about LHa to offer compilation help or debugging suggestions,
-either; contact the LHa authors at the address given in "readme.eng"
-for that.
-
-Greg Roelofs
-roe2@midway.uchicago.edu
diff --git a/archivers/lha/pkg-plist b/archivers/lha/pkg-plist
deleted file mode 100644
index 884c7d17ef39..000000000000
--- a/archivers/lha/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-@cwd /usr/local
-bin/lha