aboutsummaryrefslogtreecommitdiff
path: root/archivers/libarchive/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/libarchive/Makefile')
-rw-r--r--archivers/libarchive/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/archivers/libarchive/Makefile b/archivers/libarchive/Makefile
index 74eed3b5aa25..ef800e998b26 100644
--- a/archivers/libarchive/Makefile
+++ b/archivers/libarchive/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= libarchive
-PORTVERSION= 2.2.7
+PORTVERSION= 2.3.1
PORTEPOCH= 1
CATEGORIES= archivers
MASTER_SITES= http://people.freebsd.org/~kientzle/libarchive/src/
@@ -16,13 +16,15 @@ COMMENT= Library to create and read several streaming archive formats
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+OPTIONS= BSDCPIO "Enable bsdcpio" off
+
PLIST_FILES= bin/bsdtar \
include/archive.h \
include/archive_entry.h \
lib/libarchive.a \
lib/libarchive.la \
lib/libarchive.so \
- lib/libarchive.so.4
+ lib/libarchive.so.5
MANCOMPRESSED= no
MAN1= bsdtar.1
@@ -36,4 +38,12 @@ MAN3= archive_entry.3 \
MAN5= libarchive-formats.5 \
tar.5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_BSDCPIO)
+CONFIGURE_ARGS+= --enable-bsdcpio=yes
+PLIST_FILES+= bin/bsdcpio
+#MAN1+= bsdcpio.1
+.endif
+
+.include <bsd.port.post.mk>