aboutsummaryrefslogtreecommitdiff
path: root/archivers/linux-f8-upx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/linux-f8-upx/Makefile')
-rw-r--r--archivers/linux-f8-upx/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/archivers/linux-f8-upx/Makefile b/archivers/linux-f8-upx/Makefile
new file mode 100644
index 000000000000..e68dfa35119f
--- /dev/null
+++ b/archivers/linux-f8-upx/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: archivers/linux-upx
+# Date created: 03 Jun 2007
+# Whom: Boris Samorodov <bsam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= upx
+PORTVERSION= 1.25
+CATEGORIES= archivers linux
+MASTER_SITE_SUBDIR= ../extras/${LINUX_DIST_VER}/${LINUX_RPM_ARCH}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= RPM of UPX, a high-performance executable packer
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libucl.so.1:${PORTSDIR}/archivers/linux-ucl
+
+USE_LINUX_RPM= yes
+RPMVERSION= 4
+LINUX_DIST_VER= 4
+BRANDELF_FILES= usr/bin/upx
+MASTER_SITE_SRC_SUBDIR= ../extras/${LINUX_DIST_VER}/SRPMS
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>