aboutsummaryrefslogtreecommitdiff
path: root/archivers/p5-IO-Compress-Base/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/p5-IO-Compress-Base/Makefile')
-rw-r--r--archivers/p5-IO-Compress-Base/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/archivers/p5-IO-Compress-Base/Makefile b/archivers/p5-IO-Compress-Base/Makefile
new file mode 100644
index 000000000000..7355dd2b8b41
--- /dev/null
+++ b/archivers/p5-IO-Compress-Base/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-IO-Compress-Base
+# Date created: 2006-11-07
+# Whom: Thomas Abthorpe <thomas@goodking.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Compress-Base
+PORTVERSION= 2.001
+CATEGORIES= archivers perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= thomas@goodking.ca
+COMMENT= Base Class for IO::Uncompress modules
+
+PERL_CONFIGURE= YES
+
+MAN3= IO::Uncompress::AnyUncompress.3 IO::Uncompress::Base.3 \
+ File::GlobMapper.3 IO::Compress::Base.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This module only support perl 5.6.1 or above
+.endif
+
+.include <bsd.port.post.mk>