aboutsummaryrefslogtreecommitdiff
path: root/archivers/py-attic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/py-attic/Makefile')
-rw-r--r--archivers/py-attic/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/archivers/py-attic/Makefile b/archivers/py-attic/Makefile
index eb1476e5ea10..8409d809c149 100644
--- a/archivers/py-attic/Makefile
+++ b/archivers/py-attic/Makefile
@@ -14,8 +14,8 @@ COMMENT= Deduplicating backup program
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack-python>=0.1.10:devel/py-msgpack-python
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack-python>=0.1.10:devel/py-msgpack-python
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack-python>=0.1.10:devel/py-msgpack-python@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack-python>=0.1.10:devel/py-msgpack-python@${FLAVOR}
USES= python:3.3+ ssl
USE_PYTHON= autoplist distutils
@@ -23,13 +23,6 @@ USE_PYTHON= autoplist distutils
STRIP_FILES= hashindex.so platform_freebsd.so chunker.so crypto.so
PYDISTUTILS_BUILDPATH=${BUILD_WRKSRC}/build/lib.${OPSYS:tl}-${UNAMER}-${ARCH}-${PYTHON_VER}
-.include <bsd.port.pre.mk>
-
-.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
- ${PYTHON_VER} != ${PYTHON_DEFAULT}
-IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
-.endif
-
regression-test: build
${SETENV} PYTHONPATH="${PYDISTUTILS_BUILDPATH}:${PYTHONPATH}" \
${PYTHON_CMD} -m attic.testsuite.run
@@ -37,4 +30,4 @@ regression-test: build
post-install:
${STRIP_CMD} ${STRIP_FILES:S,^,${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/attic/,}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>