aboutsummaryrefslogtreecommitdiff
path: root/archivers/unmakeself/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/unmakeself/Makefile')
-rw-r--r--archivers/unmakeself/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/archivers/unmakeself/Makefile b/archivers/unmakeself/Makefile
index 98952399c121..f06ad9e72474 100644
--- a/archivers/unmakeself/Makefile
+++ b/archivers/unmakeself/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Extract Makeself archives
USES= libarchive
-LDFLAGS+= -larchive
+LIBS+= -larchive
NO_WRKSUBDIR= yes
PLIST_FILES= bin/unmakeself
@@ -26,7 +26,7 @@ do-configure:
do-build:
${CC} ${CFLAGS} ${CPPFLAGS} -I${WRKSRC} -o ${WRKSRC}/unmakeself \
- ${FILESDIR}/unmakeself.c ${LDFLAGS}
+ ${FILESDIR}/unmakeself.c ${LDFLAGS} ${LIBS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/unmakeself ${STAGEDIR}/${PREFIX}/bin